summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2023-04-02 08:41:39 +0200
committerHans de Graaff <graaff@gentoo.org>2023-04-02 08:41:39 +0200
commitfae54bf16807fb2548b38d28878cec08de269d8c (patch)
treeb9d3f83a9bd3ce0af9f0f465a447d1edf7c920ef /dev-ruby/addressable
parentdev-ruby/loofah: add 2.20.0 (diff)
downloadgentoo-fae54bf16807fb2548b38d28878cec08de269d8c.tar.gz
gentoo-fae54bf16807fb2548b38d28878cec08de269d8c.tar.bz2
gentoo-fae54bf16807fb2548b38d28878cec08de269d8c.zip
dev-ruby/addressable: add 2.8.2
Signed-off-by: Hans de Graaff <graaff@gentoo.org>
Diffstat (limited to 'dev-ruby/addressable')
-rw-r--r--dev-ruby/addressable/Manifest1
-rw-r--r--dev-ruby/addressable/addressable-2.8.2.ebuild42
2 files changed, 43 insertions, 0 deletions
diff --git a/dev-ruby/addressable/Manifest b/dev-ruby/addressable/Manifest
index e42cc1a44dd8..2a6924b63215 100644
--- a/dev-ruby/addressable/Manifest
+++ b/dev-ruby/addressable/Manifest
@@ -1 +1,2 @@
DIST addressable-2.8.1.gem 105984 BLAKE2B 9ba6fffe2af965be57ef7b2f86c5c86c672e0037c41996d78a3b8f31a9b5a5818e06d7e119733cff3d5469bc985186fac6fa978740f107876a975b5ac662171f SHA512 ae0b7cb5fdc0b5b8717637e9589ab9167aa3924253f4c9102134b1e5aee07c7f5e3e92e2e32ca872b4a72a3a70c8086c7073cbbddf7cbb6e1948ed97de2c9108
+DIST addressable-2.8.2.gem 106496 BLAKE2B 701f4c298686593cadc7317fe2072474fa2a4a35c53047d650fb166db969d5a0e8eca703d2ec2ed334936711d7fe5c839dfe6f04bea5d413da22a41094d58b98 SHA512 9c5f2a5cad9f1f4ea9ec9ab30106123f922737f9dafdf5efd9b74c939e933976c37c0a9775743e7277a0850fa1676ede5520db4fe6e0a9507e5b3a2b94d9d8d7
diff --git a/dev-ruby/addressable/addressable-2.8.2.ebuild b/dev-ruby/addressable/addressable-2.8.2.ebuild
new file mode 100644
index 000000000000..f81a5ff2c1a3
--- /dev/null
+++ b/dev-ruby/addressable/addressable-2.8.2.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+USE_RUBY="ruby27 ruby30 ruby31 ruby32"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+
+RUBY_FAKEGEM_EXTRADOC="README.md CHANGELOG.md"
+
+RUBY_FAKEGEM_EXTRAINSTALL="data"
+
+inherit ruby-fakegem
+
+DESCRIPTION="A replacement for the URI implementation that is part of Ruby's standard library"
+HOMEPAGE="https://rubygems.org/gems/addressable https://github.com/sporkmonger/addressable"
+
+LICENSE="Apache-2.0"
+
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~loong ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x64-solaris ~x86-solaris"
+IUSE="doc test"
+
+ruby_add_rdepend "|| ( dev-ruby/public_suffix:5 dev-ruby/public_suffix:4 )"
+
+ruby_add_bdepend "test? ( dev-ruby/rspec-its )"
+
+all_ruby_prepare() {
+ # Remove spec-related tasks so that we don't need to require rspec
+ # just to build the documentation, bug 383611.
+ sed -i -e '/spectask/d' Rakefile || die
+ rm -f tasks/rspec.rake || die
+ sed -i -e '/bundler/ s:^:#:' \
+ -e '/^begin/,/^end/ s:^:#:' \
+ spec/spec_helper.rb || die
+
+ # Remove specs requiring network connectivity
+ rm -f spec/addressable/net_http_compat_spec.rb || die
+
+ # Remove spec that tests against an unreleased github fork
+ rm -f spec/addressable/rack_mount_compat_spec.rb || die
+}