summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-ruby/dalli
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-ruby/dalli')
-rw-r--r--dev-ruby/dalli/Manifest2
-rw-r--r--dev-ruby/dalli/dalli-2.6.4.ebuild40
-rw-r--r--dev-ruby/dalli/dalli-2.7.4-r1.ebuild42
-rw-r--r--dev-ruby/dalli/dalli-2.7.4.ebuild40
-rw-r--r--dev-ruby/dalli/metadata.xml8
5 files changed, 132 insertions, 0 deletions
diff --git a/dev-ruby/dalli/Manifest b/dev-ruby/dalli/Manifest
new file mode 100644
index 000000000000..34237b4b2e17
--- /dev/null
+++ b/dev-ruby/dalli/Manifest
@@ -0,0 +1,2 @@
+DIST dalli-2.6.4.gem 40448 SHA256 04fde96890b41a4b4c71bdcdddbf8522d7685bd3b57d4632ef2f4a04c481cbc1 SHA512 ce734e1d122a9b20c567497ff88dbbf5ddb03912e88ae70199746808695c139062a25797c34b82a203139568f44791dd09a91eff9b4816d26ce50f6e74cef860 WHIRLPOOL 3a30d3ddcdfc976a42a9d0feb1b8beaa39c5b45179127a01e1493899dc68c18cb79f06e57ad32c8b03dccec6c82652b218b4691567530954af0e77fab2ffa5ea
+DIST dalli-2.7.4.gem 47616 SHA256 acdf155946cda8eb55edb9af7c44888dc8b726930f157729ffa67f5bc2fc8a7b SHA512 2bd1efeb245177f15feb02fdf40ef1d2bf0cb820a2a881ef810b3d30aa837ad53dc755c5ce8b95de689c27ec83d93e85501d9b5b1e57c8bf0c6eeff8bd42a78f WHIRLPOOL 7866f0500ad2c28d8cae0a8802376474ccc31696d4e5871b1802fdcd6b4f49fdf822bf789458962e7b17a2d05ff3a114d6a8de15919efc6f218ff55a56f0a002
diff --git a/dev-ruby/dalli/dalli-2.6.4.ebuild b/dev-ruby/dalli/dalli-2.6.4.ebuild
new file mode 100644
index 000000000000..87b7357cdf9f
--- /dev/null
+++ b/dev-ruby/dalli/dalli-2.6.4.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+USE_RUBY="ruby19 ruby20 ruby21"
+
+RUBY_FAKEGEM_TASK_TEST="test"
+
+RUBY_FAKEGEM_DOCDIR="doc"
+RUBY_FAKEGEM_EXTRADOC="History.md Performance.md README.md"
+
+inherit ruby-fakegem
+
+DESCRIPTION="A high performance pure Ruby client for accessing memcached servers"
+HOMEPAGE="http://github.com/mperham/dalli"
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ppc ~ppc64 ~x86"
+IUSE=""
+
+DEPEND+="${DEPEND} test? ( >=net-misc/memcached-1.4.0 )"
+
+ruby_add_bdepend "test? (
+ dev-ruby/minitest:0
+ >=dev-ruby/mocha-0.13
+ >=dev-ruby/activesupport-3 )"
+
+all_ruby_prepare() {
+ chmod 0755 "${HOME}" || die "Failed to fix permissions on home"
+
+ sed -i -e '/appraisal/ s:^:#:' Rakefile || die
+
+ sed -i -e '1igem "minitest", "~> 4.0"' test/helper.rb || die
+
+ # Drop rails dependency which is only used to display the version
+ # number, so we only need to depend on activesupport and avoid
+ # complicated circular dependencies.
+ sed -i -e '/rails/I s:^:#:' test/helper.rb || die
+}
diff --git a/dev-ruby/dalli/dalli-2.7.4-r1.ebuild b/dev-ruby/dalli/dalli-2.7.4-r1.ebuild
new file mode 100644
index 000000000000..2c535e8ba191
--- /dev/null
+++ b/dev-ruby/dalli/dalli-2.7.4-r1.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+USE_RUBY="ruby19 ruby20 ruby21"
+
+RUBY_FAKEGEM_TASK_TEST="test"
+
+RUBY_FAKEGEM_DOCDIR="doc"
+RUBY_FAKEGEM_EXTRADOC="History.md Performance.md README.md"
+
+inherit ruby-fakegem
+
+DESCRIPTION="A high performance pure Ruby client for accessing memcached servers"
+HOMEPAGE="https://github.com/mperham/dalli"
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~hppa ~ppc64 ~x86"
+IUSE=""
+
+DEPEND+="${DEPEND} test? ( >=net-misc/memcached-1.4.0 )"
+
+ruby_add_bdepend "test? (
+ dev-ruby/minitest:5
+ >=dev-ruby/mocha-0.13
+ dev-ruby/rack
+ >=dev-ruby/activesupport-4.1
+ dev-ruby/connection_pool )"
+
+all_ruby_prepare() {
+ chmod 0755 "${HOME}" || die "Failed to fix permissions on home"
+
+ sed -i -e '/\(appraisal\|bundler\)/ s:^:#:' Rakefile || die
+
+ sed -i -e '1igem "minitest", "~> 5.0"' test/helper.rb || die
+
+ # Drop rails dependency which is only used to display the version
+ # number, so we only need to depend on activesupport and avoid
+ # complicated circular dependencies.
+ sed -i -e '/rails/I s:^:#:' test/helper.rb || die
+}
diff --git a/dev-ruby/dalli/dalli-2.7.4.ebuild b/dev-ruby/dalli/dalli-2.7.4.ebuild
new file mode 100644
index 000000000000..cd6aa8913b7a
--- /dev/null
+++ b/dev-ruby/dalli/dalli-2.7.4.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+USE_RUBY="ruby19 ruby20 ruby21"
+
+RUBY_FAKEGEM_TASK_TEST="test"
+
+RUBY_FAKEGEM_DOCDIR="doc"
+RUBY_FAKEGEM_EXTRADOC="History.md Performance.md README.md"
+
+inherit ruby-fakegem
+
+DESCRIPTION="A high performance pure Ruby client for accessing memcached servers"
+HOMEPAGE="http://github.com/mperham/dalli"
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ppc ~ppc64 ~x86"
+IUSE=""
+
+DEPEND+="${DEPEND} test? ( >=net-misc/memcached-1.4.0 )"
+
+ruby_add_bdepend "test? (
+ >=dev-ruby/minitest-4.2.0
+ >=dev-ruby/mocha-0.13
+ >=dev-ruby/activesupport-4.1 )"
+
+all_ruby_prepare() {
+ chmod 0755 "${HOME}" || die "Failed to fix permissions on home"
+
+ sed -i -e '/\(appraisal\|bundler\)/ s:^:#:' Rakefile || die
+
+ sed -i -e '1igem "minitest", "~> 5.0"' test/helper.rb || die
+
+ # Drop rails dependency which is only used to display the version
+ # number, so we only need to depend on activesupport and avoid
+ # complicated circular dependencies.
+ sed -i -e '/rails/I s:^:#:' test/helper.rb || die
+}
diff --git a/dev-ruby/dalli/metadata.xml b/dev-ruby/dalli/metadata.xml
new file mode 100644
index 000000000000..17124995cfda
--- /dev/null
+++ b/dev-ruby/dalli/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>ruby</herd>
+ <upstream>
+ <remote-id type="github">mperham/dalli</remote-id>
+ </upstream>
+</pkgmetadata>