summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2023-08-18 15:19:22 +0200
committerHans de Graaff <graaff@gentoo.org>2023-08-18 15:19:37 +0200
commitb3b9a72618c6108f1418411703c675f6b7f28e29 (patch)
treed25f6aa1cd79e6392a1fde3b8f378a60b8841ab3 /dev-ruby/ipaddr
parentx11-drivers/nvidia-drivers: add 535.43.08:0/vulkan, drop 525.47.35 (diff)
downloadgentoo-b3b9a72618c6108f1418411703c675f6b7f28e29.tar.gz
gentoo-b3b9a72618c6108f1418411703c675f6b7f28e29.tar.bz2
gentoo-b3b9a72618c6108f1418411703c675f6b7f28e29.zip
dev-ruby/ipaddr: new package, add 1.2.5
Signed-off-by: Hans de Graaff <graaff@gentoo.org>
Diffstat (limited to 'dev-ruby/ipaddr')
-rw-r--r--dev-ruby/ipaddr/Manifest1
-rw-r--r--dev-ruby/ipaddr/ipaddr-1.2.5.ebuild31
-rw-r--r--dev-ruby/ipaddr/metadata.xml11
3 files changed, 43 insertions, 0 deletions
diff --git a/dev-ruby/ipaddr/Manifest b/dev-ruby/ipaddr/Manifest
new file mode 100644
index 000000000000..08ed94e415ac
--- /dev/null
+++ b/dev-ruby/ipaddr/Manifest
@@ -0,0 +1 @@
+DIST ipaddr-1.2.5.tar.gz 21795 BLAKE2B dfc4d50941dc9275ff45bcd35ac48ea678c6d6bd4e4227e5514ba7ba1ad2bde7e6692eb81dfc066332211fa20911c58573d9e6fd6842195cebea69f004cf4dd1 SHA512 d3741e6841ad78dba364227d7f0313843068c06dd13f2f459cc3c07e5f2a9ed7d9a9ebbeb2533235ba561a52966bbfc78375b8b0ab36a9275a49251658c6deab
diff --git a/dev-ruby/ipaddr/ipaddr-1.2.5.ebuild b/dev-ruby/ipaddr/ipaddr-1.2.5.ebuild
new file mode 100644
index 000000000000..befd16d48786
--- /dev/null
+++ b/dev-ruby/ipaddr/ipaddr-1.2.5.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+USE_RUBY="ruby30 ruby31 ruby32"
+
+RUBY_FAKEGEM_BINWRAP=""
+RUBY_FAKEGEM_EXTRADOC="README.md"
+RUBY_FAKEGEM_GEMSPEC="ipaddr.gemspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="IPAddr provides a set of methods to manipulate an IPv4 or IPv6 address"
+HOMEPAGE="https://github.com/ruby/ipaddr"
+SRC_URI="https://github.com/ruby/ipaddr/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~loong ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x64-solaris"
+IUSE=""
+
+all_ruby_prepare() {
+ sed -e 's/__dir__/"."/' \
+ -e 's/__FILE__/"'${RUBY_FAKEGEM_GEMSPEC}'"/' \
+ -e 's/git ls-files -z/find * -print0/' \
+ -i ${RUBY_FAKEGEM_GEMSPEC} || die
+}
+
+each_ruby_test() {
+ ${RUBY} -Ilib:.:test:test/lib -rhelper -e 'Dir["test/**/test_*.rb"].each{|f| require f}' || die
+}
diff --git a/dev-ruby/ipaddr/metadata.xml b/dev-ruby/ipaddr/metadata.xml
new file mode 100644
index 000000000000..0057dde65dce
--- /dev/null
+++ b/dev-ruby/ipaddr/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>ruby@gentoo.org</email>
+ <name>Gentoo Ruby Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">ruby/ipaddr</remote-id>
+ </upstream>
+</pkgmetadata>