summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-ruby/liquid-c
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-ruby/liquid-c')
-rw-r--r--dev-ruby/liquid-c/Manifest1
-rw-r--r--dev-ruby/liquid-c/liquid-c-3.0.0.ebuild38
-rw-r--r--dev-ruby/liquid-c/metadata.xml8
3 files changed, 47 insertions, 0 deletions
diff --git a/dev-ruby/liquid-c/Manifest b/dev-ruby/liquid-c/Manifest
new file mode 100644
index 000000000000..026d6b4f0ab7
--- /dev/null
+++ b/dev-ruby/liquid-c/Manifest
@@ -0,0 +1 @@
+DIST liquid-c-3.0.0.gem 15360 SHA256 f19d1dcaa7cb4e5524b9d1122cacfb242c60f4352fa8b48f17435512063eb628 SHA512 500afb4669555b0e7c8ac2ab46b3bfdcf4db2e67fd89369669125e5d4598edad6dff5270599e659c64abe33c254dde556ff12e74fe35f7baae3bbd9bf9c60b36 WHIRLPOOL 953c2c611044ea0afe1d96a1084c8a7598349d97957e6a68561e4722b3d0af3c95d96de5997c496e625ac2cb7b40cad41c9704a3579360dfaf40121d61614e1e
diff --git a/dev-ruby/liquid-c/liquid-c-3.0.0.ebuild b/dev-ruby/liquid-c/liquid-c-3.0.0.ebuild
new file mode 100644
index 000000000000..3b708ade2908
--- /dev/null
+++ b/dev-ruby/liquid-c/liquid-c-3.0.0.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+USE_RUBY="ruby20 ruby21"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_TASK_TEST=""
+RUBY_FAKEGEM_EXTRADOC="README.md"
+
+inherit multilib ruby-fakegem
+
+DESCRIPTION="Liquid performance extension in C"
+HOMEPAGE="https://github.com/Shopify/liquid-c"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+MY_PN=${PN/-/_}
+
+ruby_add_rdepend ">=dev-ruby/liquid-3.0.0"
+
+all_ruby_prepare() {
+ sed -i -e "s/-Werror//" ext/${MY_PN}/extconf.rb || die
+ sed -i -e "/[Bb]undler/d" Rakefile || die
+}
+
+each_ruby_configure() {
+ ${RUBY} -Cext/${MY_PN} extconf.rb || die
+}
+
+each_ruby_compile() {
+ emake V=1 -Cext/${MY_PN}
+ cp ext/${MY_PN}/${MY_PN}$(get_modname) lib/ || die
+}
diff --git a/dev-ruby/liquid-c/metadata.xml b/dev-ruby/liquid-c/metadata.xml
new file mode 100644
index 000000000000..76486962b2d2
--- /dev/null
+++ b/dev-ruby/liquid-c/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>ruby</herd>
+ <upstream>
+ <remote-id type="github">Shopify/liquid-c</remote-id>
+ </upstream>
+</pkgmetadata>