summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-ruby/nio4r
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-ruby/nio4r')
-rw-r--r--dev-ruby/nio4r/Manifest3
-rw-r--r--dev-ruby/nio4r/metadata.xml8
-rw-r--r--dev-ruby/nio4r/nio4r-1.0.1.ebuild39
-rw-r--r--dev-ruby/nio4r/nio4r-1.1.0.ebuild39
-rw-r--r--dev-ruby/nio4r/nio4r-1.1.1.ebuild39
5 files changed, 128 insertions, 0 deletions
diff --git a/dev-ruby/nio4r/Manifest b/dev-ruby/nio4r/Manifest
new file mode 100644
index 000000000000..be8c800220fc
--- /dev/null
+++ b/dev-ruby/nio4r/Manifest
@@ -0,0 +1,3 @@
+DIST nio4r-1.0.1.gem 88576 SHA256 0b3dd204fe0174711dbd9683b3b581f3ca7d94325cdcdc8e0d99daeeea48ea7f SHA512 5a2cd7a5df221315bd145c14eef839a9bcbe5fac08b39537ef9a9cbd4522ea621b0b1172309df479c634f639eb84b97d3b52a968e6e06e600d33bd633125ab99 WHIRLPOOL 7b26d3291bcd3af4e1386868cb8ca8c95168a86e9cfb4404df85b1666815024b5dd1405d33bb86fa6e9a89efd22942bccc7096fe19617e8daf1f15be1c79fd5c
+DIST nio4r-1.1.0.gem 90112 SHA256 503e591f2fad4b34b6349f636d528fcd19af312677af96d1cf2ae674bd409af5 SHA512 c54bcd1534161d2eaf1ef12e2faa436dc7ee59f4ca4b2b5eb1260e98593d8f0e0e3c670753d1dd2dc84053952a8df39ec13aa67b325198ae63ec811cd329256c WHIRLPOOL 02776eaae219efecd4988d56832415bfcfc746bf073910eb6cbbe5373ef5d1e0ce1f9ba1335bd12d7497a1f69dfc4f3b196690a76edcdd18c9d6f34253dcd164
+DIST nio4r-1.1.1.gem 91648 SHA256 5d86fd9f8872982fd4fa623bdaafe45efe21353b64fd09632e486f1b4d40959e SHA512 3163fd7efe05200ff88d284e932244f9a8f2e3b0145c6e732cdf8cd253ca334e1ade5b7d9c61a2d69ce193fa86501f1756ab3602181754426c7a268996537ff6 WHIRLPOOL 29501589d7eac09717c898dfdf80107653e68dcf5e84a9f96d1609c377d371447f17c8119313de99e4a9b3d0d984dbf44ab8ce3cdf3358ce99667266aabbd8a9
diff --git a/dev-ruby/nio4r/metadata.xml b/dev-ruby/nio4r/metadata.xml
new file mode 100644
index 000000000000..7b48234fe416
--- /dev/null
+++ b/dev-ruby/nio4r/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>ruby</herd>
+ <upstream>
+ <remote-id type="github">celluloid/nio4r</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-ruby/nio4r/nio4r-1.0.1.ebuild b/dev-ruby/nio4r/nio4r-1.0.1.ebuild
new file mode 100644
index 000000000000..b797d655aa58
--- /dev/null
+++ b/dev-ruby/nio4r/nio4r-1.0.1.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+USE_RUBY="ruby19 ruby20 ruby21"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_EXTRADOC="CHANGES.md README.md"
+
+inherit ruby-fakegem
+
+DESCRIPTION="A high performance selector API for monitoring IO objects"
+HOMEPAGE="https://github.com/celluloid/nio4r"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64"
+IUSE=""
+
+# Note that nio4r bundles a patched copy of libev, and without these
+# patches the tests fail: https://github.com/celluloid/nio4r/issues/15
+
+all_ruby_prepare() {
+ sed -i -e '/[Cc]overalls/d' -e '/[Bb]undler/d' spec/spec_helper.rb || die
+ sed -e '/extension/ s:^:#:' -i Rakefile || die
+}
+
+each_ruby_configure() {
+ ${RUBY} -Cext/${PN} extconf.rb || die
+}
+
+each_ruby_compile() {
+ emake V=1 -Cext/${PN}
+ cp ext/${PN}/*$(get_modname) lib/ || die
+}
diff --git a/dev-ruby/nio4r/nio4r-1.1.0.ebuild b/dev-ruby/nio4r/nio4r-1.1.0.ebuild
new file mode 100644
index 000000000000..5185243fa3f8
--- /dev/null
+++ b/dev-ruby/nio4r/nio4r-1.1.0.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+USE_RUBY="ruby19 ruby20 ruby21 ruby22"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_EXTRADOC="CHANGES.md README.md"
+
+inherit ruby-fakegem
+
+DESCRIPTION="A high performance selector API for monitoring IO objects"
+HOMEPAGE="https://github.com/celluloid/nio4r"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+IUSE=""
+
+# Note that nio4r bundles a patched copy of libev, and without these
+# patches the tests fail: https://github.com/celluloid/nio4r/issues/15
+
+all_ruby_prepare() {
+ sed -i -e '/[Cc]overalls/d' -e '/[Bb]undler/d' spec/spec_helper.rb || die
+ sed -e '/extension/ s:^:#:' -i Rakefile || die
+}
+
+each_ruby_configure() {
+ ${RUBY} -Cext/${PN} extconf.rb || die
+}
+
+each_ruby_compile() {
+ emake V=1 -Cext/${PN}
+ cp ext/${PN}/*$(get_modname) lib/ || die
+}
diff --git a/dev-ruby/nio4r/nio4r-1.1.1.ebuild b/dev-ruby/nio4r/nio4r-1.1.1.ebuild
new file mode 100644
index 000000000000..967882e63734
--- /dev/null
+++ b/dev-ruby/nio4r/nio4r-1.1.1.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+USE_RUBY="ruby19 ruby20 ruby21 ruby22"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_EXTRADOC="CHANGES.md README.md"
+
+inherit ruby-fakegem
+
+DESCRIPTION="A high performance selector API for monitoring IO objects"
+HOMEPAGE="https://github.com/celluloid/nio4r"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+
+# Note that nio4r bundles a patched copy of libev, and without these
+# patches the tests fail: https://github.com/celluloid/nio4r/issues/15
+
+all_ruby_prepare() {
+ sed -i -e '/[Cc]overalls/d' -e '/[Bb]undler/d' spec/spec_helper.rb || die
+ sed -e '/extension/ s:^:#:' -i Rakefile || die
+}
+
+each_ruby_configure() {
+ ${RUBY} -Cext/${PN} extconf.rb || die
+}
+
+each_ruby_compile() {
+ emake V=1 -Cext/${PN}
+ cp ext/${PN}/*$(get_modname) lib/ || die
+}