summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2016-08-05 14:11:01 +0200
committerHans de Graaff <graaff@gentoo.org>2016-08-05 14:13:56 +0200
commitd55062216a32a90a7e7609b89a50d7b2a1173b15 (patch)
treeff78f9e37edab40e0f5295bc9509f6c32daeb9b5 /dev-ruby/rest-client/rest-client-2.0.0.ebuild
parentdev-ruby/hashie: add ruby23 revision (diff)
downloadgentoo-d55062216a32a90a7e7609b89a50d7b2a1173b15.tar.gz
gentoo-d55062216a32a90a7e7609b89a50d7b2a1173b15.tar.bz2
gentoo-d55062216a32a90a7e7609b89a50d7b2a1173b15.zip
dev-ruby/rest-client: add 2.0.0
Package-Manager: portage-2.2.28
Diffstat (limited to 'dev-ruby/rest-client/rest-client-2.0.0.ebuild')
-rw-r--r--dev-ruby/rest-client/rest-client-2.0.0.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/dev-ruby/rest-client/rest-client-2.0.0.ebuild b/dev-ruby/rest-client/rest-client-2.0.0.ebuild
new file mode 100644
index 000000000000..2d1d230ec3fb
--- /dev/null
+++ b/dev-ruby/rest-client/rest-client-2.0.0.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+USE_RUBY="ruby20 ruby21 ruby22"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+
+RUBY_FAKEGEM_EXTRADOC="history.md README.md"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Simple Simple HTTP and REST client for Ruby"
+HOMEPAGE="https://github.com/archiloque/rest-client"
+
+LICENSE="MIT"
+SLOT="2"
+KEYWORDS="~amd64"
+IUSE=""
+
+ruby_add_bdepend "test? ( dev-ruby/webmock:2 )"
+
+ruby_add_rdepend "
+ >=dev-ruby/http-cookie-1.0.2:0
+ >=dev-ruby/mime-types-1.16:* <dev-ruby/mime-types-4:*
+ >=dev-ruby/netrc-0.8:0"
+
+all_ruby_prepare() {
+ sed -e '/bundler/I s:^:#:' \
+ -e '/namespace :windows/,/^end/ s:^:#:' -i Rakefile || die
+
+ # Remove spec that requires network access.
+ rm spec/integration/request_spec.rb || die
+}