summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2023-12-30 08:22:13 +0100
committerHans de Graaff <graaff@gentoo.org>2023-12-30 08:22:13 +0100
commit771df1c4095ba35b46a5e2c76b3f1e9ebdc20ab2 (patch)
tree3d035e9fe8f6399a0422980ca916e39719ff34af /dev-ruby/rspec-expectations
parentdev-ruby/rspec-core: drop 3.12.1 (diff)
downloadgentoo-771df1c4095ba35b46a5e2c76b3f1e9ebdc20ab2.tar.gz
gentoo-771df1c4095ba35b46a5e2c76b3f1e9ebdc20ab2.tar.bz2
gentoo-771df1c4095ba35b46a5e2c76b3f1e9ebdc20ab2.zip
dev-ruby/rspec-expectations: drop 3.12.2
Signed-off-by: Hans de Graaff <graaff@gentoo.org>
Diffstat (limited to 'dev-ruby/rspec-expectations')
-rw-r--r--dev-ruby/rspec-expectations/Manifest1
-rw-r--r--dev-ruby/rspec-expectations/rspec-expectations-3.12.2.ebuild47
2 files changed, 0 insertions, 48 deletions
diff --git a/dev-ruby/rspec-expectations/Manifest b/dev-ruby/rspec-expectations/Manifest
index 6fe75f265621..efed04625a37 100644
--- a/dev-ruby/rspec-expectations/Manifest
+++ b/dev-ruby/rspec-expectations/Manifest
@@ -1,2 +1 @@
-DIST rspec-expectations-3.12.2-git.tgz 218501 BLAKE2B 9b4dffb018d11c6d2bea399a7c1c3ebea157f83231d50e641998e0cb77e85e65c097a5d21e6989ce4c123df00137146b409fa2af102691867195fe42f1e11735 SHA512 6695959bcb185654e7ae96eaf112263ab49cf89f32781ab2b445e11e5d04b070295c9fa051ed6f4925b7cce78fb233490ad12618ac8f54d24a328ae3a6788859
DIST rspec-expectations-3.12.3-git.tgz 218754 BLAKE2B be6c6c50115bec39758f792030363de88abf5affa8a4df1161a386fee3dfb620542fca6225779e76aa2e72d1f782b65ef9db393be061e9ed47c72d96f47cf981 SHA512 37f85555e0ba16b1a76f8d59571312febfc802eab1a27ff788d57bb34f410867e753dcfee83ca3d70367b77ad9f823341c653901c8ff02c75df6863937c71315
diff --git a/dev-ruby/rspec-expectations/rspec-expectations-3.12.2.ebuild b/dev-ruby/rspec-expectations/rspec-expectations-3.12.2.ebuild
deleted file mode 100644
index 0e66ac93fd45..000000000000
--- a/dev-ruby/rspec-expectations/rspec-expectations-3.12.2.ebuild
+++ /dev/null
@@ -1,47 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-USE_RUBY="ruby27 ruby30 ruby31 ruby32"
-
-RUBY_FAKEGEM_RECIPE_TEST="rspec3"
-
-RUBY_FAKEGEM_RECIPE_DOC="none"
-RUBY_FAKEGEM_EXTRADOC="Changelog.md README.md"
-
-RUBY_FAKEGEM_GEMSPEC="${PN}.gemspec"
-
-inherit ruby-fakegem
-
-DESCRIPTION="A Behaviour Driven Development (BDD) framework for Ruby"
-HOMEPAGE="https://github.com/rspec/rspec-expectations"
-SRC_URI="https://github.com/rspec/${PN}/archive/v${PV}.tar.gz -> ${P}-git.tgz"
-
-LICENSE="MIT"
-SLOT="3"
-KEYWORDS="~alpha amd64 arm arm64 ~hppa ~loong ppc ppc64 ~riscv ~s390 sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x64-solaris"
-IUSE=""
-
-SUBVERSION="$(ver_cut 1-2)"
-
-ruby_add_rdepend ">=dev-ruby/diff-lcs-1.2.0 =dev-ruby/diff-lcs-1*
- =dev-ruby/rspec-support-${SUBVERSION}*"
-
-ruby_add_bdepend "test? (
- >=dev-ruby/rspec-mocks-3.2.0:3
- >=dev-ruby/rspec-support-3.5.0:3
- )"
-
-all_ruby_prepare() {
- # Don't set up bundler: it doesn't understand our setup.
- sed -i -e '/[Bb]undler/d' Rakefile || die
-
- # Remove the Gemfile to avoid running through 'bundle exec'
- rm -f Gemfile || die
-
- # fix up the gemspecs
- sed -i \
- -e '/git ls/d' \
- -e '/add_development_dependency/d' \
- "${RUBY_FAKEGEM_GEMSPEC}" || die
-}