summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2023-03-25 11:55:03 +0000
committerSam James <sam@gentoo.org>2023-03-26 04:02:47 +0100
commit87265b315a922ae7dfad3b38cbabb14571326921 (patch)
tree63a86ac6b1144abfc4d24622c2c3f3190d1a28b8 /dev-ruby/rspectacular
parentdev-ruby/combustion: wire up tests (diff)
downloadgentoo-87265b315a922ae7dfad3b38cbabb14571326921.tar.gz
gentoo-87265b315a922ae7dfad3b38cbabb14571326921.tar.bz2
gentoo-87265b315a922ae7dfad3b38cbabb14571326921.zip
dev-ruby/rspectacular: EAPI 8, enable ruby32, update HOMEPAGE
No tests unfortunately as it's become a gem-only project, but reverse dependencies work fine when running rspec tests, etc. Gone per https://github.com/jfelchner/ruby-progressbar/issues/123. Now only on rubygems. Bug: https://github.com/jfelchner/ruby-progressbar/issues/123 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-ruby/rspectacular')
-rw-r--r--dev-ruby/rspectacular/rspectacular-0.70.8-r1.ebuild22
-rw-r--r--dev-ruby/rspectacular/rspectacular-0.70.8-r2.ebuild28
2 files changed, 28 insertions, 22 deletions
diff --git a/dev-ruby/rspectacular/rspectacular-0.70.8-r1.ebuild b/dev-ruby/rspectacular/rspectacular-0.70.8-r1.ebuild
deleted file mode 100644
index 2f9dbb3b616c..000000000000
--- a/dev-ruby/rspectacular/rspectacular-0.70.8-r1.ebuild
+++ /dev/null
@@ -1,22 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-USE_RUBY="ruby27 ruby30 ruby31"
-
-RUBY_FAKEGEM_TASK_TEST=""
-RUBY_FAKEGEM_EXTRADOC="README.md"
-
-RUBY_FAKEGEM_BINWRAP=""
-
-inherit ruby-fakegem
-
-DESCRIPTION="RSpec support and matchers"
-HOMEPAGE="https://github.com/thekompanee/rspectacular"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="amd64 ~hppa ~ppc ~ppc64 ~riscv ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
-IUSE=""
-
-ruby_add_rdepend ">=dev-ruby/rspec-3.1:3 dev-ruby/fuubar:2 dev-ruby/shoulda-matchers:3"
diff --git a/dev-ruby/rspectacular/rspectacular-0.70.8-r2.ebuild b/dev-ruby/rspectacular/rspectacular-0.70.8-r2.ebuild
new file mode 100644
index 000000000000..9fd49c741d53
--- /dev/null
+++ b/dev-ruby/rspectacular/rspectacular-0.70.8-r2.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+USE_RUBY="ruby27 ruby30 ruby31 ruby32"
+
+RUBY_FAKEGEM_TASK_TEST=""
+RUBY_FAKEGEM_EXTRADOC="README.md"
+
+RUBY_FAKEGEM_BINWRAP=""
+
+inherit ruby-fakegem
+
+DESCRIPTION="RSpec support and matchers"
+HOMEPAGE="https://rubygems.org/gems/rspectacular"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="amd64 ~hppa ~ppc ~ppc64 ~riscv ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+
+ruby_add_rdepend ">=dev-ruby/rspec-3.1:3 dev-ruby/fuubar:2"
+
+# Note that shoulda-matchers is an optional RDEPEND as a plugin.
+# rspectacular doesn't seem to be actively developed anymore and its only
+# reverse dependency passes tests w/o this dep installed, which figures given
+# it's a plugin.
+USE_RUBY="ruby27 ruby30 ruby31" ruby_add_rdepend "dev-ruby/shoulda-matchers:3"