summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2018-04-04 20:27:47 +0200
committerHans de Graaff <graaff@gentoo.org>2018-04-04 20:28:12 +0200
commitb153a4eecb17bd558b1608b0a0e92f56bbf760e1 (patch)
treefb345714c609d4ad3c838379c80875e0dd91cf9c /dev-ruby/strptime
parentprofiles/prefix/darwin/macos/10.5/ppc: ensure we use gcc-config toolchain (diff)
downloadgentoo-b153a4eecb17bd558b1608b0a0e92f56bbf760e1.tar.gz
gentoo-b153a4eecb17bd558b1608b0a0e92f56bbf760e1.tar.bz2
gentoo-b153a4eecb17bd558b1608b0a0e92f56bbf760e1.zip
dev-ruby/strptime: initial import of 0.2.3
Dependency for forthcoming app-admin/fluentd, bug 652434 Package-Manager: Portage-2.3.24, Repoman-2.3.6
Diffstat (limited to 'dev-ruby/strptime')
-rw-r--r--dev-ruby/strptime/Manifest1
-rw-r--r--dev-ruby/strptime/metadata.xml8
-rw-r--r--dev-ruby/strptime/strptime-0.2.3.ebuild38
3 files changed, 47 insertions, 0 deletions
diff --git a/dev-ruby/strptime/Manifest b/dev-ruby/strptime/Manifest
new file mode 100644
index 000000000000..687f80b2c88f
--- /dev/null
+++ b/dev-ruby/strptime/Manifest
@@ -0,0 +1 @@
+DIST strptime-0.2.3.tar.gz 17375 BLAKE2B 583566c19cdd96f97b469d3353236624b814ea9200e1479d32c552d06431e0008cd9dcf5be03564948898fb9e5a1470a5a8bdb531d4054bfe64899bbd6ec92e0 SHA512 1b9ee2f7c0fa747c6df5a56c5d7f667c4a9314c334472867e890758074f9da387aae54d9171b2460036a21e890fd743187571c6d4a995e4117d6c4307b8134cc
diff --git a/dev-ruby/strptime/metadata.xml b/dev-ruby/strptime/metadata.xml
new file mode 100644
index 000000000000..28ab0c15f206
--- /dev/null
+++ b/dev-ruby/strptime/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer type="project">
+ <email>ruby@gentoo.org</email>
+ <name>Gentoo Ruby Project</name>
+</maintainer>
+</pkgmetadata>
diff --git a/dev-ruby/strptime/strptime-0.2.3.ebuild b/dev-ruby/strptime/strptime-0.2.3.ebuild
new file mode 100644
index 000000000000..4b7ddca63c51
--- /dev/null
+++ b/dev-ruby/strptime/strptime-0.2.3.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+USE_RUBY="ruby22 ruby23 ruby24 ruby25"
+
+RUBY_FAKEGEM_RECIPE_DOC="rdoc"
+RUBY_FAKEGEM_EXTRADOC="README.md"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+
+RUBY_FAKEGEM_GEMSPEC="strptime.gemspec"
+
+RUBY_FAKEGEM_BINWRAP=""
+
+inherit multilib ruby-fakegem
+
+DESCRIPTION="A fast strptime/strftime engine which uses VM"
+HOMEPAGE="https://github.com/nurse/strptime"
+SRC_URI="https://github.com/nurse/strptime/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+all_ruby_prepare() {
+ sed -i -e 's/git ls-files -z/find -print0/' ${RUBY_FAKEGEM_GEMSPEC} || die
+}
+
+each_ruby_configure() {
+ ${RUBY} -Cext/strptime extconf.rb || die
+}
+
+each_ruby_compile() {
+ emake -Cext/strptime V=1
+ cp ext/strptime/strptime$(get_modname) lib/strptime/ || die
+}