summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-ruby/twitter
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-ruby/twitter')
-rw-r--r--dev-ruby/twitter/Manifest2
-rw-r--r--dev-ruby/twitter/metadata.xml8
-rw-r--r--dev-ruby/twitter/twitter-5.13.0.ebuild51
-rw-r--r--dev-ruby/twitter/twitter-5.14.0.ebuild52
4 files changed, 113 insertions, 0 deletions
diff --git a/dev-ruby/twitter/Manifest b/dev-ruby/twitter/Manifest
new file mode 100644
index 000000000000..ca93b3880693
--- /dev/null
+++ b/dev-ruby/twitter/Manifest
@@ -0,0 +1,2 @@
+DIST twitter-5.13.0.tar.gz 1322622 SHA256 760dede63a96f51d38a61fd172d93c97da17046f01c53c37b430c421738a6906 SHA512 28afafcfbe938fadc571dd19affd69cf1288d86fd3c4c14b743a4d573de068fdc6a6ffe487320b6a039dc2540375450d060e32761196bbbb4cb4b83a0999696a WHIRLPOOL 3a7b20e69c443c644cfe0e2a0bb21d13c6259b8db129a6ae7d32df4a4e166bfa04f97271857feb866c2e7499ed7090efdca3680b4920863cafdbe15fd984788a
+DIST twitter-5.14.0.tar.gz 1355192 SHA256 44936f6e7eb61139c5129c25c207e16065ed5a20cb4d86679edbb8600318c374 SHA512 3fc4971b191efabaafb8918d525ed0279a246f68053c0af25aef355c6f019f40d6977a0f3463679e138dfeb40ff32e13b005c6a8a9667d0c359c659917ea890a WHIRLPOOL 689f319b6c044a87b6febd27425d497789cf73c47febda0cbec0b48a7d45cd160bd5f7c8ae26bb67a7958ccbdff9651f6e94fbb6fdffc1de244bf7657f68e7dd
diff --git a/dev-ruby/twitter/metadata.xml b/dev-ruby/twitter/metadata.xml
new file mode 100644
index 000000000000..e48ef066023b
--- /dev/null
+++ b/dev-ruby/twitter/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>ruby</herd>
+ <upstream>
+ <remote-id type="github">sferik/twitter</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-ruby/twitter/twitter-5.13.0.ebuild b/dev-ruby/twitter/twitter-5.13.0.ebuild
new file mode 100644
index 000000000000..fea046962aef
--- /dev/null
+++ b/dev-ruby/twitter/twitter-5.13.0.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+USE_RUBY="ruby19 ruby20 ruby21"
+
+RUBY_FAKEGEM_RECIPE_DOC="yard"
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.md"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Ruby wrapper around the Twitter API"
+HOMEPAGE="http://sferik.github.com/twitter/"
+SRC_URI="https://github.com/sferik/twitter/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="5"
+KEYWORDS="~amd64"
+IUSE=""
+
+ruby_add_rdepend "
+ >=dev-ruby/addressable-2.3
+ >=dev-ruby/buftok-0.2.0
+ >=dev-ruby/equalizer-0.0.9
+ =dev-ruby/faraday-0*
+ >=dev-ruby/faraday-0.9.0
+ >=dev-ruby/http-0.6.0:0.6
+ >=dev-ruby/http_parser_rb-0.6.0
+ >=dev-ruby/json-1.8
+ >=dev-ruby/memoizable-0.4.0
+ >=dev-ruby/naught-1.0
+ =dev-ruby/simple_oauth-0.3*
+ >=dev-ruby/simple_oauth-0.3.0"
+
+ruby_add_bdepend "test? (
+ dev-ruby/rspec:2
+ dev-ruby/webmock
+ )
+ doc? ( dev-ruby/yard )"
+
+all_ruby_prepare() {
+# rm Gemfile || die
+ sed -i -e '/[Bb]undler/d' Rakefile || die "Unable to remove bundler code."
+
+ sed -i -e '/simplecov/,/end/ s:^:#:' spec/helper.rb || die
+}
+
+each_ruby_test() {
+ CI=true ruby-ng_rspec || die
+}
diff --git a/dev-ruby/twitter/twitter-5.14.0.ebuild b/dev-ruby/twitter/twitter-5.14.0.ebuild
new file mode 100644
index 000000000000..fff75d888f28
--- /dev/null
+++ b/dev-ruby/twitter/twitter-5.14.0.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+USE_RUBY="ruby19 ruby20 ruby21"
+
+RUBY_FAKEGEM_RECIPE_DOC="yard"
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.md"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Ruby wrapper around the Twitter API"
+HOMEPAGE="http://sferik.github.com/twitter/"
+SRC_URI="https://github.com/sferik/twitter/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="5"
+KEYWORDS="~amd64"
+IUSE=""
+
+ruby_add_rdepend "
+ >=dev-ruby/addressable-2.3
+ >=dev-ruby/buftok-0.2.0
+ >=dev-ruby/equalizer-0.0.9
+ =dev-ruby/faraday-0*
+ >=dev-ruby/faraday-0.9.0
+ >=dev-ruby/http-0.6.0:0.6
+ >=dev-ruby/http_parser_rb-0.6.0
+ >=dev-ruby/json-1.8
+ >=dev-ruby/memoizable-0.4.0
+ >=dev-ruby/naught-1.0
+ =dev-ruby/simple_oauth-0.3*
+ >=dev-ruby/simple_oauth-0.3.0"
+
+ruby_add_bdepend "test? (
+ dev-ruby/rspec:2
+ dev-ruby/webmock
+ >=dev-ruby/timecop-0.6.1
+ )
+ doc? ( dev-ruby/yard )"
+
+all_ruby_prepare() {
+# rm Gemfile || die
+ sed -i -e '/[Bb]undler/d' Rakefile || die "Unable to remove bundler code."
+
+ sed -i -e '/simplecov/,/end/ s:^:#:' spec/helper.rb || die
+}
+
+each_ruby_test() {
+ CI=true ruby-ng_rspec || die
+}