summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTupone Alfredo <tupone@gentoo.org>2019-10-12 16:19:31 +0200
committerTupone Alfredo <tupone@gentoo.org>2019-10-12 16:19:31 +0200
commit87346ea1a3c87960bab9e2dbaf4c9089859f03b3 (patch)
tree675abe5ae72f443d4bb1b05ffb4a543dc87dd948 /dev-tcltk
parentdev-libs/efl: bump to 1.23.1 (diff)
downloadgentoo-87346ea1a3c87960bab9e2dbaf4c9089859f03b3.tar.gz
gentoo-87346ea1a3c87960bab9e2dbaf4c9089859f03b3.tar.bz2
gentoo-87346ea1a3c87960bab9e2dbaf4c9089859f03b3.zip
dev-tcltk/vtcl: EAPI 7
Closes: https://bugs.gentoo.org/697338 Package-Manager: Portage-2.3.69, Repoman-2.3.16 Signed-off-by: Alfredo Tupone <tupone@gentoo.org>
Diffstat (limited to 'dev-tcltk')
-rw-r--r--dev-tcltk/vtcl/vtcl-1.6.0-r1.ebuild3
-rw-r--r--dev-tcltk/vtcl/vtcl-1.6.0-r2.ebuild32
2 files changed, 34 insertions, 1 deletions
diff --git a/dev-tcltk/vtcl/vtcl-1.6.0-r1.ebuild b/dev-tcltk/vtcl/vtcl-1.6.0-r1.ebuild
index 596e52294e4e..6b09343c4210 100644
--- a/dev-tcltk/vtcl/vtcl-1.6.0-r1.ebuild
+++ b/dev-tcltk/vtcl/vtcl-1.6.0-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=0
@@ -11,6 +11,7 @@ SLOT="0"
KEYWORDS="amd64 ppc x86"
IUSE="doc"
DEPEND="dev-lang/tk"
+RDEPEND="${DEPEND}"
MY_DESTDIR=/usr/share/${PN}
src_compile() {
diff --git a/dev-tcltk/vtcl/vtcl-1.6.0-r2.ebuild b/dev-tcltk/vtcl/vtcl-1.6.0-r2.ebuild
new file mode 100644
index 000000000000..5080e7e70cc1
--- /dev/null
+++ b/dev-tcltk/vtcl/vtcl-1.6.0-r2.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="Visual Tcl is a high-quality application development environment"
+HOMEPAGE="http://vtcl.sf.net"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="doc"
+DEPEND="dev-lang/tk:*"
+RDEPEND="${DEPEND}"
+
+MY_DESTDIR=/usr/share/${PN}
+
+src_compile() {
+ sed -i 's,^\(VTCL_HOME=\).*,\1'${MY_DESTDIR}',g' vtcl || die "Path fixing failed."
+ sed -i 's,package require -exact Tk ,package require Tk ,' lib/tkcon.tcl || die "Tcl8.5 patch failed"
+}
+
+src_install() {
+ dodir ${MY_DESTDIR}
+ dobin vtcl
+ cp -r ./{demo,images,lib,sample,vtcl.tcl} "${D}/${MY_DESTDIR}" || die "Data installation failed."
+ if use doc; then
+ DOCS=( ChangeLog README doc/tutorial.txt )
+ HTML_DOCS=( doc/*html )
+ fi
+ einstalldocs
+}