summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJason Zaman <perfinion@gentoo.org>2017-11-27 11:07:16 +0800
committerJason Zaman <perfinion@gentoo.org>2017-11-27 11:08:45 +0800
commit6e120551fbca899370335da1185fe94dba7b4466 (patch)
treebb55b79bde054dc892cb39a2878ffbcbed9f5b3c /dev-util/android-studio
parentqt5-build.eclass: improve eclassdoc (diff)
downloadgentoo-6e120551fbca899370335da1185fe94dba7b4466.tar.gz
gentoo-6e120551fbca899370335da1185fe94dba7b4466.tar.bz2
gentoo-6e120551fbca899370335da1185fe94dba7b4466.zip
dev-util/android-studio: bump to 3.0.1 and fix desktop entry
Closes: https://bugs.gentoo.org/637304 Package-Manager: Portage-2.3.13, Repoman-2.3.3
Diffstat (limited to 'dev-util/android-studio')
-rw-r--r--dev-util/android-studio/Manifest3
-rw-r--r--dev-util/android-studio/android-studio-3.0.1.0.171.4443003.ebuild108
2 files changed, 110 insertions, 1 deletions
diff --git a/dev-util/android-studio/Manifest b/dev-util/android-studio/Manifest
index aa7e4b044856..db3a6e6fc0eb 100644
--- a/dev-util/android-studio/Manifest
+++ b/dev-util/android-studio/Manifest
@@ -1,2 +1,3 @@
DIST android-studio-ide-162.4069837-linux.zip 490782431 SHA256 1383cfd47441e5f820b6257a1bdd683e0e980bc76c7f2027ef84dc2e6ad2f17f SHA512 44f093ce4c97211913bb979fb28d5fe43163462ce6153c31c03576d872e11cbc11651f10397e14247ca41ea269a3cb0998e9e7d37fc63ac6782cc653037d925c WHIRLPOOL ed833816f48abba51d8142fda91175c07f019f40a3ed21ea026367870723016c17262c0eccb71d3d85a5f963ca0a84b0ee2111ae15f95ad92ac565f225d6c10a
-DIST android-studio-ide-171.4408382-linux.zip 771324214 SHA256 7991f95ea1b6c55645a3fc48f1534d4135501a07b9d92dd83672f936d9a9d7a2 SHA512 7637cc2bfd808cd641d8420e8f5a53660139f37beaf822b7b6a3bb49369d7f5a4e5ccfc805d914ff82eee3065d694a7c3d92b53ced88090ad15d57dae4e7e737 WHIRLPOOL b8b78d6838d960313d10bba98bf3deaf6e9e1defad0d6288c7108228210d8c3a6d9b92de38620f4c9ed43338d425605437d45f19e57c56eb369e10f046e9322d
+DIST android-studio-ide-171.4408382-linux.zip 771324214 BLAKE2B 4dbb194338a139d884d05acc60db65d2d85cb80cf28a44a50adf5dbb7390851d5d2640050f17a0048c926c7022794838f5ce6c259f5dd66b04dde47d7b237796 SHA512 7637cc2bfd808cd641d8420e8f5a53660139f37beaf822b7b6a3bb49369d7f5a4e5ccfc805d914ff82eee3065d694a7c3d92b53ced88090ad15d57dae4e7e737
+DIST android-studio-ide-171.4443003-linux.zip 773670325 BLAKE2B b8cff0b85cf20f9d181b4f5c29dc75385539ca2d8e2677211c6c42fcb115616c4208faa5df8cc8a8210c4e9e869d00ae42e7c9dd212756608ff9d4f47bdc8943 SHA512 ba91309c59e4f258222f5b5978bc9ea048476bab4d0662235c7900590f9d58716dc77e937464fab0e57752ee18353a13c163ee98615474f48d0b99e04dae1d34
diff --git a/dev-util/android-studio/android-studio-3.0.1.0.171.4443003.ebuild b/dev-util/android-studio/android-studio-3.0.1.0.171.4443003.ebuild
new file mode 100644
index 000000000000..2791da5ee994
--- /dev/null
+++ b/dev-util/android-studio/android-studio-3.0.1.0.171.4443003.ebuild
@@ -0,0 +1,108 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit eutils java-pkg-2 versionator
+
+RESTRICT="strip"
+QA_PREBUILT="opt/${PN}/bin/libbreakgen*.so
+ opt/${PN}/bin/fsnotifier*
+ opt/${PN}/lib/libpty/linux/x86*/libpty.so
+ opt/${PN}/plugins/android/lib/libwebp_jni*.so
+ opt/${PN}/plugins/android/resources/perfa/*/libperfa.so
+ opt/${PN}/plugins/android/resources/perfd/*/perfd
+ opt/${PN}/plugins/android/resources/simpleperf/*/simpleperf"
+
+if [[ $(get_version_component_count) -eq 6 ]]; then
+ STUDIO_V=$(get_version_component_range 1-4)
+ BUILD_V=$(get_version_component_range 5-6)
+else
+ STUDIO_V=$(get_version_component_range 1-3)
+ BUILD_V=$(get_version_component_range 4-5)
+fi
+
+DESCRIPTION="A new Android development environment based on IntelliJ IDEA"
+HOMEPAGE="http://developer.android.com/sdk/installing/studio.html"
+SRC_URI="https://dl.google.com/dl/android/studio/ide-zips/${STUDIO_V}/${PN}-ide-${BUILD_V}-linux.zip"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+IUSE="selinux"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND="app-arch/zip
+ dev-java/commons-logging:0
+ dev-java/log4j:0"
+
+# dev-java/guava:18
+RDEPEND=">=virtual/jdk-1.7
+ selinux? ( sec-policy/selinux-android )
+ >=app-arch/bzip2-1.0.6-r4
+ dev-java/commons-logging:0
+ dev-java/log4j:0
+ >=dev-libs/expat-2.1.0-r3
+ >=dev-libs/libffi-3.0.13-r1
+ >=media-libs/fontconfig-2.10.92
+ >=media-libs/freetype-2.5.5
+ >=media-libs/libpng-1.2.51
+ >=media-libs/mesa-10.2.8
+ || ( gnome-extra/zenity kde-apps/kdialog x11-apps/xmessage x11-libs/libnotify )
+ >=sys-libs/ncurses-5.9-r3:5/5[tinfo]
+ >=sys-libs/zlib-1.2.8-r1
+ >=x11-libs/libX11-1.6.2
+ >=x11-libs/libXau-1.0.7-r1
+ >=x11-libs/libXdamage-1.1.4-r1
+ >=x11-libs/libXdmcp-1.1.1-r1
+ >=x11-libs/libXext-1.3.2
+ >=x11-libs/libXfixes-5.0.1
+ >=x11-libs/libXrender-0.9.8
+ >=x11-libs/libXxf86vm-1.1.3
+ >=x11-libs/libdrm-2.4.46
+ >=x11-libs/libxcb-1.9.1
+ >=x11-libs/libxshmfence-1.1"
+S=${WORKDIR}/${PN}
+
+src_prepare() {
+ eapply_user
+ # This is really a bundled jdk not a jre
+ rm -R "${S}/jre" || die "Could not remove bundled jdk"
+
+ # Replace bundled jars with system
+ # has problems with newer jdom:0 not updated to jdom:2
+ cd "${S}/lib" || die
+ local JARS="commons-logging log4j"
+ local j
+ for j in ${JARS}; do
+ rm -v ${j/:*/}*.jar || die
+ java-pkg_jar-from ${j}
+ done
+
+ cd "${S}" || die
+
+ # bug 629404
+ echo "-Djdk.util.zip.ensureTrailingSlash=false" >> bin/studio64.vmoptions || die
+ echo "-Djdk.util.zip.ensureTrailingSlash=false" >> bin/studio.vmoptions || die
+}
+
+src_compile() {
+ :
+}
+
+src_install() {
+ local dir="/opt/${PN}"
+
+ insinto "${dir}"
+ # Replaced bundled jre with system vm/jdk
+ # This is really a bundled jdk not a jre
+ doins -r *
+
+ rm -rf "${D}${dir}/jre" || die
+ dosym "/etc/java-config-2/current-system-vm" "${dir}/jre"
+
+ fperms 755 "${dir}/bin/studio.sh" "${dir}"/bin/fsnotifier{,64}
+ chmod 755 "${D}${dir}"/gradle/gradle-*/bin/gradle || die
+
+ newicon "bin/studio.png" "${PN}.png"
+ make_wrapper ${PN} ${dir}/bin/studio.sh
+ make_desktop_entry ${PN} "Android Studio" ${PN} "Development;IDE" "StartupWMClass=jetbrains-studio"
+}