summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2023-04-15 06:11:21 +0100
committerSam James <sam@gentoo.org>2023-04-15 06:11:21 +0100
commitd1a3661d06ab2036402024ea792bad26b7eb2cda (patch)
tree17c36af75efc309f1837560e5603789d92bc04b1 /dev-util/perf
parentmedia-libs/fontconfig: don't enable subpixel rendering by default (diff)
downloadgentoo-d1a3661d06ab2036402024ea792bad26b7eb2cda.tar.gz
gentoo-d1a3661d06ab2036402024ea792bad26b7eb2cda.tar.bz2
gentoo-d1a3661d06ab2036402024ea792bad26b7eb2cda.zip
dev-util/perf: fix build w/ clang 16
Closes: https://bugs.gentoo.org/904169 Thanks-to: Maciej S. Szmigiero <mail@maciej.szmigiero.name> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-util/perf')
-rw-r--r--dev-util/perf/files/perf-6.0-c++17.patch39
-rw-r--r--dev-util/perf/perf-6.0-r1.ebuild1
-rw-r--r--dev-util/perf/perf-6.2-r1.ebuild1
3 files changed, 41 insertions, 0 deletions
diff --git a/dev-util/perf/files/perf-6.0-c++17.patch b/dev-util/perf/files/perf-6.0-c++17.patch
new file mode 100644
index 000000000000..08c34bc552ca
--- /dev/null
+++ b/dev-util/perf/files/perf-6.0-c++17.patch
@@ -0,0 +1,39 @@
+https://bugs.gentoo.org/904169
+--- a/tools/perf/Makefile.config
++++ b/tools/perf/Makefile.config
+@@ -309,7 +309,7 @@
+ CORE_CFLAGS += -Wextra
+ CORE_CFLAGS += -std=gnu11
+
+-CXXFLAGS += -std=gnu++14 -fno-exceptions -fno-rtti
++CXXFLAGS += -std=gnu++17 -fno-exceptions -fno-rtti
+ CXXFLAGS += -Wall
+ CXXFLAGS += -fno-omit-frame-pointer
+ CXXFLAGS += -ggdb3
+--- a/tools/build/feature/Makefile
++++ b/tools/build/feature/Makefile
+@@ -339,7 +339,7 @@
+ $(BUILD)
+
+ $(OUTPUT)test-llvm.bin:
+- $(BUILDXX) -std=gnu++14 \
++ $(BUILDXX) -std=gnu++17 \
+ -I$(shell $(LLVM_CONFIG) --includedir) \
+ -L$(shell $(LLVM_CONFIG) --libdir) \
+ $(shell $(LLVM_CONFIG) --libs) \
+@@ -347,12 +347,12 @@
+ > $(@:.bin=.make.output) 2>&1
+
+ $(OUTPUT)test-llvm-version.bin:
+- $(BUILDXX) -std=gnu++14 \
++ $(BUILDXX) -std=gnu++17 \
+ -I$(shell $(LLVM_CONFIG) --includedir) \
+ > $(@:.bin=.make.output) 2>&1
+
+ $(OUTPUT)test-clang.bin:
+- $(BUILDXX) -std=gnu++14 \
++ $(BUILDXX) -std=gnu++17 \
+ -I$(shell $(LLVM_CONFIG) --includedir) \
+ -L$(shell $(LLVM_CONFIG) --libdir) \
+ -lclang-cpp $(shell $(LLVM_CONFIG) --libs) \
+
diff --git a/dev-util/perf/perf-6.0-r1.ebuild b/dev-util/perf/perf-6.0-r1.ebuild
index be9dbc82a5f9..04184b462006 100644
--- a/dev-util/perf/perf-6.0-r1.ebuild
+++ b/dev-util/perf/perf-6.0-r1.ebuild
@@ -145,6 +145,7 @@ src_prepare() {
pushd "${S_K}" >/dev/null || die
eapply "${FILESDIR}"/${P}-clang.patch
+ eapply "${FILESDIR}"/perf-6.0-c++17.patch
popd || die
# Drop some upstream too-developer-oriented flags and fix the
diff --git a/dev-util/perf/perf-6.2-r1.ebuild b/dev-util/perf/perf-6.2-r1.ebuild
index 8dc6385d598e..8a46cf67337d 100644
--- a/dev-util/perf/perf-6.2-r1.ebuild
+++ b/dev-util/perf/perf-6.2-r1.ebuild
@@ -145,6 +145,7 @@ src_prepare() {
pushd "${S_K}" >/dev/null || die
eapply "${FILESDIR}"/perf-6.0-clang.patch
+ eapply "${FILESDIR}"/perf-6.0-c++17.patch
popd || die
# Drop some upstream too-developer-oriented flags and fix the