summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorConrad Kostecki <conikost@gentoo.org>2021-07-01 22:41:43 +0200
committerConrad Kostecki <conikost@gentoo.org>2021-07-01 23:15:33 +0200
commit12e8d1ac10aab5baf68e508741924f6bc953bdd4 (patch)
tree298e18bc2678562eff73d62f922ced94fd51b63c /dev-util/smem
parentdev-python/python-sense-hat: add python3.10 support (diff)
downloadgentoo-12e8d1ac10aab5baf68e508741924f6bc953bdd4.tar.gz
gentoo-12e8d1ac10aab5baf68e508741924f6bc953bdd4.tar.bz2
gentoo-12e8d1ac10aab5baf68e508741924f6bc953bdd4.zip
dev-util/smem: add python3.10 support
Package-Manager: Portage-3.0.20, Repoman-3.0.3 Signed-off-by: Conrad Kostecki <conikost@gentoo.org>
Diffstat (limited to 'dev-util/smem')
-rw-r--r--dev-util/smem/smem-1.5-r1.ebuild7
1 files changed, 3 insertions, 4 deletions
diff --git a/dev-util/smem/smem-1.5-r1.ebuild b/dev-util/smem/smem-1.5-r1.ebuild
index a31a893131b2..539ed4ae1b7a 100644
--- a/dev-util/smem/smem-1.5-r1.ebuild
+++ b/dev-util/smem/smem-1.5-r1.ebuild
@@ -1,16 +1,17 @@
-# Copyright 2019-2020 Gentoo Authors
+# Copyright 2019-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
EGIT_COMMIT="2ab5040d5633"
-PYTHON_COMPAT=( python3_{7..9} )
+PYTHON_COMPAT=( python3_{8..10} )
inherit optfeature python-single-r1 toolchain-funcs
DESCRIPTION="A tool that can give numerous reports on memory usage on Linux systems"
HOMEPAGE="https://www.selenic.com/smem/"
SRC_URI="https://selenic.com/repo/${PN}/archive/${EGIT_COMMIT}.tar.bz2 -> ${P}.tar.bz2"
+S="${WORKDIR}/${PN}-${EGIT_COMMIT}"
LICENSE="GPL-2+"
SLOT="0"
@@ -20,8 +21,6 @@ REQUIRED_USE="${PYTHON_REQUIRED_USE}"
RDEPEND="${PYTHON_DEPS}"
BDEPEND="${RDEPEND}"
-S="${WORKDIR}/${PN}-${EGIT_COMMIT}"
-
src_compile() {
"$(tc-getCC)" ${CFLAGS} ${LDFLAGS} -o smemcap smemcap.c || die
}