summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYixun Lan <dlan@gentoo.org>2024-07-09 15:08:23 +0000
committerYixun Lan <dlan@gentoo.org>2024-07-09 15:13:22 +0000
commit4daaec02015ecc530e81beebf86ecf36e8dbece8 (patch)
tree46a296de7ea1566725799c803ce04e94548d82ea /dev-util
parentprofiles/arch/powerpc/ppc32: drop obsolete qt6 use.stable.mask (diff)
downloadgentoo-4daaec02015ecc530e81beebf86ecf36e8dbece8.tar.gz
gentoo-4daaec02015ecc530e81beebf86ecf36e8dbece8.tar.bz2
gentoo-4daaec02015ecc530e81beebf86ecf36e8dbece8.zip
dev-util/bootconfig: add version 6.6, 6.9
Signed-off-by: Yixun Lan <dlan@gentoo.org>
Diffstat (limited to 'dev-util')
-rw-r--r--dev-util/bootconfig/Manifest3
-rw-r--r--dev-util/bootconfig/bootconfig-6.6.ebuild (renamed from dev-util/bootconfig/bootconfig-5.18.ebuild)12
-rw-r--r--dev-util/bootconfig/bootconfig-6.9.ebuild104
3 files changed, 110 insertions, 9 deletions
diff --git a/dev-util/bootconfig/Manifest b/dev-util/bootconfig/Manifest
index 907336dcebdf..ebf696914397 100644
--- a/dev-util/bootconfig/Manifest
+++ b/dev-util/bootconfig/Manifest
@@ -1 +1,2 @@
-DIST linux-5.18.tar.xz 129790264 BLAKE2B e2745a69eb70169e90505a9318a3993046eab3020496eecde7d8352ecda0eb71a25b21becf7ce93fc593507dce7d1cd61b94ddcdf82b3094d79c0d3d48508eeb SHA512 dbbc9d1395898a498fa4947fceda1781344fa5d360240f753810daa4fa88e519833e2186c4e582a8f1836e6413e9e85f6563c7770523b704e8702d67622f98b5
+DIST linux-6.6.tar.xz 140064536 BLAKE2B 5f02fd8696d42f7ec8c5fbadec8e7270bdcfcb1f9844a6c4db3e1fd461c93ce1ccda650ca72dceb4890ebcbbf768ba8fba0bce91efc49fbd2c307b04e95665f2 SHA512 458b2c34d46206f9b4ccbac54cc57aeca1eaecaf831bc441e59701bac6eadffc17f6ce24af6eadd0454964e843186539ac0d63295ad2cc32d112b60360c39a35
+DIST linux-6.9.tar.xz 144034416 BLAKE2B 4cf86c3cfe6e6534745d42dfaeca59b17ea1168c4e8b615c80e6d8aac735f11283cd85fa992b440b5d4452917e94b9f08397a64af0be5894e3df23c68892377e SHA512 fed3b4cd1fbfb4d94618587c1934273d2ecc8b6e42a3d586ff8a5f24980be930f2ef803aa2923ca3bfa5e4e619f967f3af315368f24fa76f610b10443624a579
diff --git a/dev-util/bootconfig/bootconfig-5.18.ebuild b/dev-util/bootconfig/bootconfig-6.6.ebuild
index 3db6300cf029..487db83fc96d 100644
--- a/dev-util/bootconfig/bootconfig-5.18.ebuild
+++ b/dev-util/bootconfig/bootconfig-6.6.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -22,11 +22,12 @@ elif [[ ${PV} == *.*.* ]] ; then
SRC_URI="https://www.kernel.org/pub/linux/kernel/v${LINUX_V}/${LINUX_PATCH}"
else
LINUX_VER=${PV}
- SRC_URI=""
fi
LINUX_SOURCES="linux-${LINUX_VER}.tar.xz"
SRC_URI+=" https://www.kernel.org/pub/linux/kernel/v${LINUX_V}/${LINUX_SOURCES}"
+S_K="${WORKDIR}/linux-${LINUX_VER}"
+S="${S_K}/tools/bootconfig"
LICENSE="GPL-2"
SLOT="0"
@@ -37,18 +38,13 @@ BDEPEND="
${LINUX_PATCH+dev-util/patchutils}
"
-RDEPEND=""
-
DEPEND="${RDEPEND}
>=sys-kernel/linux-headers-5.10
"
-S_K="${WORKDIR}/linux-${LINUX_VER}"
-S="${S_K}/tools/bootconfig"
-
CONFIG_CHECK="~BOOT_CONFIG"
-PATCHES=( "${FILESDIR}"/${P}-cflags.patch )
+PATCHES=( "${FILESDIR}"/${PN}-5.18-cflags.patch )
src_unpack() {
local paths=(
diff --git a/dev-util/bootconfig/bootconfig-6.9.ebuild b/dev-util/bootconfig/bootconfig-6.9.ebuild
new file mode 100644
index 000000000000..487db83fc96d
--- /dev/null
+++ b/dev-util/bootconfig/bootconfig-6.9.ebuild
@@ -0,0 +1,104 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit estack linux-info
+
+DESCRIPTION="Bootconfig tools for kernel command line to support key-value"
+HOMEPAGE="https://kernel.org/"
+
+LINUX_V="${PV:0:1}.x"
+if [[ ${PV} == *_rc* ]] ; then
+ LINUX_VER=$(ver_cut 1-2).$(($(ver_cut 3)-1))
+ PATCH_VERSION=$(ver_cut 1-3)
+ LINUX_PATCH=patch-${PV//_/-}.xz
+ SRC_URI="https://www.kernel.org/pub/linux/kernel/v${LINUX_V}/testing/${LINUX_PATCH}
+ https://www.kernel.org/pub/linux/kernel/v${LINUX_V}/testing/v${PATCH_VERSION}/${LINUX_PATCH}"
+elif [[ ${PV} == *.*.* ]] ; then
+ # stable-release series
+ LINUX_VER=$(ver_cut 1-2)
+ LINUX_PATCH=patch-${PV}.xz
+ SRC_URI="https://www.kernel.org/pub/linux/kernel/v${LINUX_V}/${LINUX_PATCH}"
+else
+ LINUX_VER=${PV}
+fi
+
+LINUX_SOURCES="linux-${LINUX_VER}.tar.xz"
+SRC_URI+=" https://www.kernel.org/pub/linux/kernel/v${LINUX_V}/${LINUX_SOURCES}"
+S_K="${WORKDIR}/linux-${LINUX_VER}"
+S="${S_K}/tools/bootconfig"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~riscv"
+IUSE="examples"
+
+BDEPEND="
+ ${LINUX_PATCH+dev-util/patchutils}
+"
+
+DEPEND="${RDEPEND}
+ >=sys-kernel/linux-headers-5.10
+"
+
+CONFIG_CHECK="~BOOT_CONFIG"
+
+PATCHES=( "${FILESDIR}"/${PN}-5.18-cflags.patch )
+
+src_unpack() {
+ local paths=(
+ tools/arch tools/build tools/include tools/lib tools/bootconfig tools/scripts
+ scripts include lib "arch/*/lib"
+ )
+
+ # We expect the tar implementation to support the -j option (both
+ # GNU tar and libarchive's tar support that).
+ echo ">>> Unpacking ${LINUX_SOURCES} (${paths[*]}) to ${PWD}"
+ tar --wildcards -xpf "${DISTDIR}"/${LINUX_SOURCES} \
+ "${paths[@]/#/linux-${LINUX_VER}/}" || die
+
+ if [[ -n ${LINUX_PATCH} ]] ; then
+ eshopts_push -o noglob
+ ebegin "Filtering partial source patch"
+ filterdiff -p1 ${paths[@]/#/-i } -z "${DISTDIR}"/${LINUX_PATCH} \
+ > ${P}.patch
+ eend $? || die "filterdiff failed"
+ eshopts_pop
+ fi
+
+ local a
+ for a in ${A}; do
+ [[ ${a} == ${LINUX_SOURCES} ]] && continue
+ [[ ${a} == ${LINUX_PATCH} ]] && continue
+ unpack ${a}
+ done
+}
+
+src_prepare() {
+ default
+ if [[ -n ${LINUX_PATCH} ]] ; then
+ pushd "${S_K}" >/dev/null || die
+ eapply "${WORKDIR}"/${P}.patch
+ popd || die
+ fi
+}
+
+src_compile() {
+ emake bootconfig
+}
+
+src_test() {
+ :
+}
+
+src_install() {
+ dobin bootconfig
+
+ if use examples; then
+ dodoc -r scripts
+
+ docinto examples
+ dodoc -r samples/*
+ fi
+}