summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMagnus Granberg <zorry@gentoo.org>2024-10-27 09:20:14 +0100
committerSam James <sam@gentoo.org>2024-11-09 09:07:20 +0000
commit50707d427a02ac8fa697e16d698a6f7ff5e0b6f4 (patch)
tree176380453109cd63ed90f11e15843541afc2bac9 /dev-util
parentdev-util/buildbot-wsgi-dashboards: add 4.1.0 (diff)
downloadgentoo-50707d427a02ac8fa697e16d698a6f7ff5e0b6f4.tar.gz
gentoo-50707d427a02ac8fa697e16d698a6f7ff5e0b6f4.tar.bz2
gentoo-50707d427a02ac8fa697e16d698a6f7ff5e0b6f4.zip
dev-util/buildbot-www: add 4.1.0
Signed-off-by: Magnus Granberg <zorry@gentoo.org> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-util')
-rw-r--r--dev-util/buildbot-www/Manifest1
-rw-r--r--dev-util/buildbot-www/buildbot-www-4.1.0.ebuild23
2 files changed, 24 insertions, 0 deletions
diff --git a/dev-util/buildbot-www/Manifest b/dev-util/buildbot-www/Manifest
index 349624aabd12..fe32a5dfd2b7 100644
--- a/dev-util/buildbot-www/Manifest
+++ b/dev-util/buildbot-www/Manifest
@@ -3,3 +3,4 @@ DIST buildbot-www-3.11.1.tar.gz 3211634 BLAKE2B bb64ae2ad4ac84aee876a9b2ef4e92b8
DIST buildbot-www-3.6.1.tar.gz 3210526 BLAKE2B 6db8be32ee85cab63ad3f92d0e24042ed1ebece3b7be1b67e6f72240f61f3af2c31f1b3b31315db0d7ca18dddab1351eacffb92e762d1f1d68ce414349e52eee SHA512 d2fb3f97412e4a1b21fe7637458dffa8e8e005693ad2275222e908d35551ec64f89a88e696859a09f64b2b5be5fbdb386fbd71324356dbe8c2adc92b1c6b9f01
DIST buildbot-www-3.9.0.tar.gz 3211620 BLAKE2B d5a75845941b456537be50484d341e450f545cf14ccafdc245d4b4d296df154e333d2797f8e5f5dc42c872a83360c675b0e747564cbcc3c182c4c1c0138205fb SHA512 2c88e0f41d5f4de37eecebc43b21f5f741771e0ecaed79865744503b939335f1f1dd426cd2e1cdbcf75a7573aa89ab5913e4c64aa6dea9e13fa19646dd717c0b
DIST buildbot_www-3.11.9.tar.gz 3211692 BLAKE2B ac818354dc37cb3ec18a47d21726af5b2cab7203b25e48d76c794e178790b80cee2b36bbef7348a60e0f6f3599815029a9c4a8acf62a3212e0414df73f4baf00 SHA512 3084aa444d5d0e781036431c7f3a067fc8704c4a44a0cc9f5b99083dba28ee384d184f8085d82495bf0ac573a3131dfb610b2782f9d77f76fdbcd9ead8815df3
+DIST buildbot_www-4.1.0.tar.gz 429252 BLAKE2B 55c18b8dff8bb1e4892fe7d2ecabbf3df94b2487217bd14b3fae619779ccb63eb9a38fa46805488602ec71cecf44610b071b5965431a37e54ff6b65ade9ef5e7 SHA512 1e21ed532be488c40234920616ebdc65580a485ee5e3547094e37e1b9bd0a77e1b1b64ee720734d43d49961b68de7186efc7184dda63a2829b928d14508ae94c
diff --git a/dev-util/buildbot-www/buildbot-www-4.1.0.ebuild b/dev-util/buildbot-www/buildbot-www-4.1.0.ebuild
new file mode 100644
index 000000000000..d616f2e44595
--- /dev/null
+++ b/dev-util/buildbot-www/buildbot-www-4.1.0.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYPI_NO_NORMALIZE=1
+PYTHON_REQ_USE="sqlite"
+PYTHON_COMPAT=( python3_{10..12} )
+PYPI_PN=${PN/-/_}
+inherit distutils-r1 pypi
+
+DESCRIPTION="BuildBot base web interface, use with buildbot-{console-view,waterfall-view}..."
+HOMEPAGE="https://buildbot.net/
+ https://github.com/buildbot/buildbot
+ https://pypi.org/project/buildbot-www/"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~riscv ~amd64-linux ~x86-linux"
+
+RDEPEND="~dev-util/buildbot-pkg-${PV}[${PYTHON_USEDEP}]"
+BDEPEND="${RDEPEND}"