summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGuillermo Joandet <gjoandet@gmail.com>2024-08-09 11:19:46 -0300
committerPacho Ramos <pacho@gentoo.org>2024-11-09 11:39:47 +0100
commitd9ff48d93fb34053bd1af648d1ec77f833726dc1 (patch)
tree96ad9138ca7d1695e1e0e146a029e3fb2cac1e86 /dev-util
parentdev-util/sysprof-common: Bump to 46.0 (diff)
downloadgentoo-d9ff48d93fb34053bd1af648d1ec77f833726dc1.tar.gz
gentoo-d9ff48d93fb34053bd1af648d1ec77f833726dc1.tar.bz2
gentoo-d9ff48d93fb34053bd1af648d1ec77f833726dc1.zip
dev-util/sysprof-capture: Bump to 46.0
Closes: https://bugs.gentoo.org/892794 Signed-off-by: Guillermo Joandet <gjoandet@gmail.com> Signed-off-by: Pacho Ramos <pacho@gentoo.org>
Diffstat (limited to 'dev-util')
-rw-r--r--dev-util/sysprof-capture/Manifest1
-rw-r--r--dev-util/sysprof-capture/sysprof-capture-46.0.ebuild38
2 files changed, 39 insertions, 0 deletions
diff --git a/dev-util/sysprof-capture/Manifest b/dev-util/sysprof-capture/Manifest
index dfa3287a40ff..fb0630ee223a 100644
--- a/dev-util/sysprof-capture/Manifest
+++ b/dev-util/sysprof-capture/Manifest
@@ -1,2 +1,3 @@
DIST sysprof-3.36.0.tar.xz 435956 BLAKE2B 990a6c6c28339594df915ed1fb98f504bf6b080a5e3c31af0cc4bcfd208027361f02a9068291692d082787a6fd42ab414079122a63e4706aee2511040379f0c8 SHA512 41f99cc3446a6624ea74fcdecd7a29a2e5e2d4086383d59a9064c4a3df5d9b8d08f4903ff4dcc85ffa9c6d42bd84dec5c03f6010fffd4415cc8fecf4dc0b23f4
DIST sysprof-3.48.0.tar.xz 533092 BLAKE2B 5af48d9216f13ffcc8824b0ba6a4e0ff931c903991953e66c2b50534399320d3d3fccd6e8478b10dc895d19544f9c08733565d95fe9c2c70d64f2294ccce2330 SHA512 100b79fabee005b5445dab3ad78d43facf375a488aa6513e987deecd6a3036cc43bfd78db106a4b8a15b4280dcd975872784c839f560779183adb5a339b0648c
+DIST sysprof-46.0.tar.xz 1170396 BLAKE2B 6455d31c00509540d43137863e330dc0dff49887108f80091b4374630e91a9c1c8e16c8475f6c3e992e7e416dfb3fe19e14e6e466c37424d960b91ba6c65e5a6 SHA512 f04d887218257d177f7bc68485bcc47c310188335530ff9bf5e3efa7c383d56e97d5d969b2e8b5b0469993456aa734873c599f3d743615716305b8c7f113f534
diff --git a/dev-util/sysprof-capture/sysprof-capture-46.0.ebuild b/dev-util/sysprof-capture/sysprof-capture-46.0.ebuild
new file mode 100644
index 000000000000..703056a8f049
--- /dev/null
+++ b/dev-util/sysprof-capture/sysprof-capture-46.0.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+GNOME_ORG_MODULE="sysprof"
+
+inherit gnome.org meson-multilib systemd
+
+DESCRIPTION="Static library for sysprof capture data generation"
+HOMEPAGE="http://sysprof.com/"
+
+LICENSE="GPL-3+ GPL-2+"
+SLOT="4"
+KEYWORDS="~amd64 ~arm64 ~x86"
+
+RDEPEND=""
+DEPEND="${RDEPEND}"
+BDEPEND="
+ dev-util/gdbus-codegen
+ >=sys-kernel/linux-headers-2.6.32
+ virtual/pkgconfig
+"
+
+multilib_src_configure() {
+ local emesonargs=(
+ -Dgtk=false
+ -Dlibsysprof=false
+ -Dinstall-static=true
+ -Dsysprofd=none
+ -Dsystemdunitdir=$(systemd_get_systemunitdir)
+ # -Ddebugdir
+ -Dhelp=false
+ -Dtools=false
+ -Dtests=false
+ -Dexamples=false
+ )
+ meson_src_configure
+}