summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Mair-Keimberger <mmk@levelnine.at>2024-07-31 19:36:22 +0200
committerJames Le Cuirot <chewi@gentoo.org>2024-08-02 23:03:15 +0100
commit86f9bf500c3a2ae988157cb0c5dff5afb5e15242 (patch)
treeb8eca57b65f3301ca9336d19c2f38f94b19553b4 /games-action
parentdev-cpp/magic_enum: Drop old 0.8.2 (diff)
downloadgentoo-86f9bf500c3a2ae988157cb0c5dff5afb5e15242.tar.gz
gentoo-86f9bf500c3a2ae988157cb0c5dff5afb5e15242.tar.bz2
gentoo-86f9bf500c3a2ae988157cb0c5dff5afb5e15242.zip
games-action/armagetronad: add 0.2.9.2.3
Signed-off-by: Michael Mair-Keimberger <mmk@levelnine.at> Closes: https://github.com/gentoo/gentoo/pull/37885 Signed-off-by: James Le Cuirot <chewi@gentoo.org>
Diffstat (limited to 'games-action')
-rw-r--r--games-action/armagetronad/Manifest1
-rw-r--r--games-action/armagetronad/armagetronad-0.2.9.2.3.ebuild64
2 files changed, 65 insertions, 0 deletions
diff --git a/games-action/armagetronad/Manifest b/games-action/armagetronad/Manifest
index 7555c86c96ef..9aa1fc7dcad3 100644
--- a/games-action/armagetronad/Manifest
+++ b/games-action/armagetronad/Manifest
@@ -1 +1,2 @@
DIST armagetronad-0.2.9.1.0.tbz 1943758 BLAKE2B ed4ecef19125d69faf402829b88288124dd364eafc836be3848727c2bfbd87ca29e18b48448dc868fb995947b2daae150c3b9f5dcf048d0d90d442f5bcf425f0 SHA512 8c2b9cba7d480dec6d7d60984327a5d45c8c87b968fb81a1e192973e6826ddb66c8d41ca82bb04d80da5c6fa2152d19dd890957dabc6cc5ce2d4dffbc45d1f65
+DIST armagetronad-0.2.9.2.3.tbz 1834233 BLAKE2B 9b7d09ca7952ffe67a50be01c44adef81640e8cf222158477f66487ea89c7b25e1675bb9308ba71023ce045a4ea739891ce2273d5aa017cef2fa81128c71774c SHA512 813911a75fa1b3a90d99d62c0c38e9b325166623280c0d6a8217f8ca905b4a4617401db12bda898d82aa086a1bd673b31741b95b60b0f1247e6a5677a48c98eb
diff --git a/games-action/armagetronad/armagetronad-0.2.9.2.3.ebuild b/games-action/armagetronad/armagetronad-0.2.9.2.3.ebuild
new file mode 100644
index 000000000000..2425322ba9a9
--- /dev/null
+++ b/games-action/armagetronad/armagetronad-0.2.9.2.3.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools desktop
+
+DESCRIPTION="Fast-paced 3D lightcycle game based on Tron"
+HOMEPAGE="https://www.armagetronad.org/"
+SRC_URI="https://launchpad.net/armagetronad/$(ver_cut 1-3)/${PV}/+download/armagetronad-${PV}.tbz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="dedicated sound"
+
+RDEPEND="
+ dev-libs/libxml2
+ !dedicated? (
+ media-libs/libpng:0=
+ media-libs/libsdl[X,opengl,video,sound?]
+ media-libs/sdl-image[jpeg,png]
+ virtual/glu
+ virtual/opengl
+ sound? ( media-libs/sdl-mixer )
+ )"
+DEPEND="${RDEPEND}"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-0.2.9.1.0-AR.patch
+)
+
+src_prepare() {
+ default
+
+ eautoreconf
+}
+
+src_configure() {
+ local econfargs=(
+ $(use_enable dedicated)
+ $(use_enable sound music)
+ # following options only mess with paths and users
+ --disable-games
+ --disable-sysinstall
+ --disable-uninstall
+ --disable-useradd
+ )
+ econf ${econfargs[@]}
+}
+
+src_install() {
+ # long history of being broken without -j1 (bug #330705,698020)
+ # do not remove (again) without a proper fix or extensive tests
+ emake -j1 DESTDIR="${D}" install
+ einstalldocs
+
+ # handle misplaced .desktop / icons
+ if ! use dedicated; then
+ rm -r "${ED}"/usr/share/${PN}/desktop || die
+ doicon desktop/icons/48x48/armagetronad.png
+ make_desktop_entry ${PN}
+ fi
+}