summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2018-04-15 14:03:27 +0200
committerPacho Ramos <pacho@gentoo.org>2018-04-15 14:07:59 +0200
commit2a4f9ff2bfda0b6746434f33e8cee7106a495da0 (patch)
treedc5460b3ea13de2db359042659837d7f973ee6fc /games-arcade/berusky
parentgames-arcade/batrachians: Drop old (diff)
downloadgentoo-2a4f9ff2bfda0b6746434f33e8cee7106a495da0.tar.gz
gentoo-2a4f9ff2bfda0b6746434f33e8cee7106a495da0.tar.bz2
gentoo-2a4f9ff2bfda0b6746434f33e8cee7106a495da0.zip
games-arcade/berusky: Stop using games.eclass
Package-Manager: Portage-2.3.28, Repoman-2.3.9
Diffstat (limited to 'games-arcade/berusky')
-rw-r--r--games-arcade/berusky/berusky-1.7.1-r1.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/games-arcade/berusky/berusky-1.7.1-r1.ebuild b/games-arcade/berusky/berusky-1.7.1-r1.ebuild
new file mode 100644
index 000000000000..d56b0203f7d5
--- /dev/null
+++ b/games-arcade/berusky/berusky-1.7.1-r1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit desktop gnome2
+
+DATAFILE="${PN}-data-1.7"
+DESCRIPTION="Free logic game based on an ancient puzzle named Sokoban"
+HOMEPAGE="http://anakreon.cz/?q=node/1"
+SRC_URI="http://www.anakreon.cz/download/${P}.tar.gz
+ http://www.anakreon.cz/download/${DATAFILE}.tar.gz
+ https://dev.gentoo.org/~hasufell/distfiles/${PN}.png"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="
+ media-libs/libsdl[X,video]
+ media-libs/sdl-image[png]
+ x11-libs/gtk+:2
+"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+"
+
+src_install() {
+ gnome2_src_install
+ rm -rf "${ED}"/usr/doc
+ doicon -s 32 "${DISTDIR}"/${PN}.png
+ make_desktop_entry ${PN}
+}