summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarek Szuba <marecki@gentoo.org>2022-07-26 09:42:56 +0100
committerMarek Szuba <marecki@gentoo.org>2022-07-26 09:50:11 +0100
commitfadc1ef674faec877bbfd0967726553c537e8334 (patch)
tree74e15e7c690f9f494a63cca3c8a851fe58bfdc1c /games-engines
parentdev-util/sh: new package, add 3.5.1 (diff)
downloadgentoo-fadc1ef674faec877bbfd0967726553c537e8334.tar.gz
gentoo-fadc1ef674faec877bbfd0967726553c537e8334.tar.bz2
gentoo-fadc1ef674faec877bbfd0967726553c537e8334.zip
games-engines/love: disable strict aliasing
-fstrict-aliasing triggers build-time warnings on some (but not all) systems so let's keep it consistent. Closes: https://bugs.gentoo.org/858719 Signed-off-by: Marek Szuba <marecki@gentoo.org>
Diffstat (limited to 'games-engines')
-rw-r--r--games-engines/love/love-11.4.ebuild5
1 files changed, 4 insertions, 1 deletions
diff --git a/games-engines/love/love-11.4.ebuild b/games-engines/love/love-11.4.ebuild
index fcc2e07df8e9..5cb3aaec9bc9 100644
--- a/games-engines/love/love-11.4.ebuild
+++ b/games-engines/love/love-11.4.ebuild
@@ -5,7 +5,7 @@ EAPI=8
LUA_COMPAT=( lua5-{1..4} luajit )
-inherit lua-single xdg-utils
+inherit flag-o-matic lua-single xdg-utils
if [[ ${PV} == 9999* ]]; then
inherit git-r3
@@ -47,6 +47,9 @@ src_prepare() {
}
src_configure() {
+ # Bug #858719
+ append-flags -fno-strict-aliasing
+
local myeconfargs=(
$(use_enable gme)
--with-lua=$(usex lua_single_target_luajit luajit lua)