summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /games-misc/little-inferno
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'games-misc/little-inferno')
-rw-r--r--games-misc/little-inferno/Manifest1
-rw-r--r--games-misc/little-inferno/little-inferno-20130509.ebuild76
-rw-r--r--games-misc/little-inferno/metadata.xml8
3 files changed, 85 insertions, 0 deletions
diff --git a/games-misc/little-inferno/Manifest b/games-misc/little-inferno/Manifest
new file mode 100644
index 000000000000..163e2101b38d
--- /dev/null
+++ b/games-misc/little-inferno/Manifest
@@ -0,0 +1 @@
+DIST LittleInferno-20130509.sh 194304242 SHA256 3848f4037652699c162ebf3ae78f6dce81772394911483c9f1ef49cb51f6a198 SHA512 19e2e616b1b1a6e7f8974ba12756c4b54c1daa99c99056891c56f7ed578f20a15143d683960efbb69f3d680243dd219051fc0bdac60ab74dcddc1c69df7d00dd WHIRLPOOL 2a25aa0fd1103dca63fa422cc3573eefa8a7acc819735b591a44ce89c9f9581a75287dcae8dbd8d2be52c63782af97a3b36fc676ee98288d73b9d08f2b2b2ec4
diff --git a/games-misc/little-inferno/little-inferno-20130509.ebuild b/games-misc/little-inferno/little-inferno-20130509.ebuild
new file mode 100644
index 000000000000..bd89a01ff044
--- /dev/null
+++ b/games-misc/little-inferno/little-inferno-20130509.ebuild
@@ -0,0 +1,76 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit eutils gnome2-utils unpacker games
+
+DESCRIPTION="Throw your toys into your fire, and play with them as they burn"
+HOMEPAGE="http://tomorrowcorporation.com/"
+SRC_URI="LittleInferno-${PV}.sh"
+
+LICENSE="Gameplay-Group-EULA"
+SLOT="0"
+KEYWORDS="-* amd64 x86"
+IUSE="bundled-libs"
+RESTRICT="bindist fetch bundled-libs? ( splitdebug )"
+
+MYGAMEDIR=${GAMES_PREFIX_OPT}/${PN}
+QA_PREBUILT="${MYGAMEDIR#/}/LittleInferno.bin.x86
+ ${MYGAMEDIR#/}/lib/*"
+
+RDEPEND="
+ >=net-misc/curl-7.37.0-r1[abi_x86_32(-)]
+ x11-libs/libX11[abi_x86_32(-)]
+ virtual/opengl[abi_x86_32(-)]
+ !bundled-libs? (
+ >=media-libs/libogg-1.3.1[abi_x86_32(-)]
+ >=media-libs/libvorbis-1.3.3-r1[abi_x86_32(-)]
+ >=media-libs/openal-1.15.1-r1[abi_x86_32(-)] )"
+DEPEND="app-arch/xz-utils"
+
+src_unpack() {
+ unpack_makeself ${A}
+
+ mkdir ${P} || die
+ cd ${P} || die
+
+ local i
+ for i in instarchive_{,linux_}all ; do
+ mv ../"${i}" ../"${i}".tar.xz || die
+ unpack ./../"${i}".tar.xz
+ done
+}
+
+src_prepare() {
+ if use !bundled-libs ; then
+ rm -rv lib || die
+ fi
+}
+
+src_install() {
+ insinto "${MYGAMEDIR}"
+ doins -r *
+
+ doicon -s 128 LittleInferno.png
+ make_desktop_entry ${PN} "Little Inferno" LittleInferno
+ games_make_wrapper ${PN} "./LittleInferno.bin.x86" "${MYGAMEDIR}" "${MYGAMEDIR}/lib"
+
+ fperms +x "${MYGAMEDIR}"/LittleInferno.bin.x86
+
+ prepgamesdirs
+}
+
+pkg_preinst() {
+ games_pkg_preinst
+ gnome2_icon_savelist
+}
+
+pkg_postinst() {
+ games_pkg_postinst
+ gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+}
diff --git a/games-misc/little-inferno/metadata.xml b/games-misc/little-inferno/metadata.xml
new file mode 100644
index 000000000000..89f2b6934dc8
--- /dev/null
+++ b/games-misc/little-inferno/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>games</herd>
+ <use>
+ <flag name='bundled-libs'>Use bundled libraries.</flag>
+ </use>
+</pkgmetadata>