summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /games-puzzle/xye
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'games-puzzle/xye')
-rw-r--r--games-puzzle/xye/Manifest1
-rw-r--r--games-puzzle/xye/files/xye-0.12.1-gcc47.patch22
-rw-r--r--games-puzzle/xye/metadata.xml8
-rw-r--r--games-puzzle/xye/xye-0.12.1.ebuild41
4 files changed, 72 insertions, 0 deletions
diff --git a/games-puzzle/xye/Manifest b/games-puzzle/xye/Manifest
new file mode 100644
index 000000000000..135c83d77e0a
--- /dev/null
+++ b/games-puzzle/xye/Manifest
@@ -0,0 +1 @@
+DIST xye-0.12.1.tar.gz 2850776 SHA256 bbeb3265b0795f14deb2851b4a3bda7dde9b07d624a7ca5fb88cd7acabcf3967 SHA512 aadafdb7b8e0546435838279c2929803be8dde00f3f3c08668c35d0a8ccf5bad511e65629e3f7261140edcf0980d19fda2be1401593ac4c0410beede542e857b WHIRLPOOL 7a1aa2708361b4eddb266037af35e6915852ba1a5037fcfebd95c0a8caab54209ca1c9e3827acecff64772fd15b077f5cded64a50b5820abd7b3cde937bbc2e0
diff --git a/games-puzzle/xye/files/xye-0.12.1-gcc47.patch b/games-puzzle/xye/files/xye-0.12.1-gcc47.patch
new file mode 100644
index 000000000000..04414abc6a2b
--- /dev/null
+++ b/games-puzzle/xye/files/xye-0.12.1-gcc47.patch
@@ -0,0 +1,22 @@
+--- src/editorsave.cpp.old
++++ src/editorsave.cpp
+@@ -642,7 +642,8 @@
+ file << "<?xml version=\"1.0\" encoding=\"ISO-8859-1\"?>\n";
+ file << "<pack>\n<name>"<< stripXML(editorboard::filetitle) <<"</name><author>"<< stripXML(editorboard::author) <<"</author>\n<description>"<< stripXML(editorboard::description) <<"</description>\n";
+
+- for (int i=first; i<editorboard::CountLevels(); i++) {
++ int i;
++ for (i=first; i<editorboard::CountLevels(); i++) {
+ editorboard::LoadLevelNumber(board, i);
+ file << "\n<level>\n";
+ file << "<title>"<< stripXML(board->title) <<"</title>\n";
+--- src/gen.cpp.old
++++ src/gen.cpp
+@@ -21,6 +21,7 @@
+ #include<cstdio>
+ #include<iostream>
+ #include<fstream>
++#include <unistd.h>
+
+ const float F_RAND_MAX = (float)(RAND_MAX);
+
diff --git a/games-puzzle/xye/metadata.xml b/games-puzzle/xye/metadata.xml
new file mode 100644
index 000000000000..577d11240ad6
--- /dev/null
+++ b/games-puzzle/xye/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>games</herd>
+ <upstream>
+ <remote-id type="sourceforge">xye</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/games-puzzle/xye/xye-0.12.1.ebuild b/games-puzzle/xye/xye-0.12.1.ebuild
new file mode 100644
index 000000000000..81f5810a0989
--- /dev/null
+++ b/games-puzzle/xye/xye-0.12.1.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit autotools eutils games
+
+DESCRIPTION="Free version of the classic game Kye"
+HOMEPAGE="http://xye.sourceforge.net/"
+SRC_URI="mirror://sourceforge/xye/${P}.tar.gz"
+
+LICENSE="ZLIB"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+DEPEND="media-libs/libsdl[video]
+ media-libs/sdl-ttf
+ media-libs/sdl-image[png]
+ media-fonts/dejavu"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-gcc47.patch
+ sed -i -e '/^xye_LDFLAGS/d' Makefile.am || die
+ eautoreconf
+}
+
+src_install() {
+ dogamesbin "${PN}"
+ insinto "${GAMES_DATADIR}/${PN}"
+ doins -r levels res
+ rm -f "${D}${GAMES_DATADIR}/${PN}"/res/DejaVuSans*
+ dosym /usr/share/fonts/dejavu/DejaVuSans.ttf "${GAMES_DATADIR}/${PN}"/res/DejaVuSans.ttf
+ dosym /usr/share/fonts/dejavu/DejaVuSans-Bold.ttf "${GAMES_DATADIR}/${PN}"/res/DejaVuSans-Bold.ttf
+ dodoc AUTHORS ChangeLog README NEWS
+ dohtml ReadMe.html
+ doicon xye.svg
+ make_desktop_entry ${PN} Xye
+ prepgamesdirs
+}