summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarek Szuba <marecki@gentoo.org>2020-12-01 01:12:15 +0100
committerMarek Szuba <marecki@gentoo.org>2020-12-01 01:17:19 +0100
commit93e915dd5b6402818089203c77228ad300e3047e (patch)
tree8ff9d9a495b0b089a4d36336f3abf279a8413595 /games-simulation/corsix-th/files
parentdev-lua/toluapp: fix CMAKE_REMOVE_MODULES_LIST lines (diff)
downloadgentoo-93e915dd5b6402818089203c77228ad300e3047e.tar.gz
gentoo-93e915dd5b6402818089203c77228ad300e3047e.tar.bz2
gentoo-93e915dd5b6402818089203c77228ad300e3047e.zip
games-simulation/corsix-th: migrate to lua-single.eclass
LuaJIT is in principle supported upstream but requires one to override cmake detection of the Lua library, and more importantly dev-lua/luasocket doesn't support this implementation yet. PUC Lua 5.4 is known not to be supported yet, see e.g. http://lua-users.org/lists/lua-l/2020-07/msg00047.html Closes: https://bugs.gentoo.org/752954 Signed-off-by: Marek Szuba <marecki@gentoo.org>
Diffstat (limited to 'games-simulation/corsix-th/files')
-rw-r--r--games-simulation/corsix-th/files/corsix-th-0.64-cmake_lua_detection.patch11
1 files changed, 11 insertions, 0 deletions
diff --git a/games-simulation/corsix-th/files/corsix-th-0.64-cmake_lua_detection.patch b/games-simulation/corsix-th/files/corsix-th-0.64-cmake_lua_detection.patch
new file mode 100644
index 000000000000..d57fa953ad05
--- /dev/null
+++ b/games-simulation/corsix-th/files/corsix-th-0.64-cmake_lua_detection.patch
@@ -0,0 +1,11 @@
+--- a/CorsixTH/CMakeLists.txt
++++ b/CorsixTH/CMakeLists.txt
+@@ -103,7 +103,7 @@
+ endif()
+
+ # Find Lua
+-find_package(Lua REQUIRED)
++find_package(Lua ${LUA_VERSION} EXACT REQUIRED)
+ if(Lua_FOUND)
+ target_link_libraries(CorsixTH ${LUA_LIBRARY})
+ include_directories(${LUA_INCLUDE_DIR})