summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorConrad Kostecki <conikost@gentoo.org>2021-12-12 23:40:16 +0100
committerConrad Kostecki <conikost@gentoo.org>2021-12-12 23:40:16 +0100
commita49ebf5c5fcf197d014065f3b7eb8b489f9611d2 (patch)
tree09da278736558e5eb7b7f9801b085dc6205c2d63 /games-simulation
parentsys-cluster/k3s: Bump to version 1.22.4 (diff)
downloadgentoo-a49ebf5c5fcf197d014065f3b7eb8b489f9611d2.tar.gz
gentoo-a49ebf5c5fcf197d014065f3b7eb8b489f9611d2.tar.bz2
gentoo-a49ebf5c5fcf197d014065f3b7eb8b489f9611d2.zip
games-simulation/openrct2: update ccache logic
Closes: https://bugs.gentoo.org/828814 Signed-off-by: Conrad Kostecki <conikost@gentoo.org>
Diffstat (limited to 'games-simulation')
-rw-r--r--games-simulation/openrct2/files/openrct2-0.3.5.1-ccache.patch58
-rw-r--r--games-simulation/openrct2/openrct2-0.3.5.1.ebuild7
2 files changed, 61 insertions, 4 deletions
diff --git a/games-simulation/openrct2/files/openrct2-0.3.5.1-ccache.patch b/games-simulation/openrct2/files/openrct2-0.3.5.1-ccache.patch
new file mode 100644
index 000000000000..97a529c6a8e2
--- /dev/null
+++ b/games-simulation/openrct2/files/openrct2-0.3.5.1-ccache.patch
@@ -0,0 +1,58 @@
+From cb6d7418c53e10bd4120891f6a2312d3ef839ca8 Mon Sep 17 00:00:00 2001
+From: Conrad Kostecki <conikost@gentoo.org>
+Date: Sun, 12 Dec 2021 23:04:58 +0100
+Subject: [PATCH] CMakeLists.txt: update CCache handling (#16185)
+
+This PR updated slightly the handling of CCache. With the current
+implementation, when CCache is not being installed, CMake will complain,
+that OPENRCT2_USE_CCACHE is not set.
+
+This logic is slightly updated, so the option OPENRCT2_USE_CCACHE is always
+being available and when this option is enabled (default ON), it will
+search for CCache and warn, if it's not found.
+
+The idea behind is, as in Gentoo, we never let CCache be used by the
+package itself, instead, we enabled it globally. But this the old logic,
+on systems, which don't have CCache installed, it will complain about
+OPENRCT2_USE_CCACHE not being used, but we have to make sure, OpenRCT2
+will never use by itself CCache and this message will be gone..
+
+Signed-off-by: Conrad Kostecki <conikost@gentoo.org>
+---
+ CMakeLists.txt | 23 +++++++++++++----------
+ 1 file changed, 13 insertions(+), 10 deletions(-)
+
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index 8d202cf5a9b8..566f3a8a9688 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -8,16 +8,19 @@ endif()
+ # if it is available
+ list(APPEND CMAKE_MODULE_PATH "${CMAKE_CURRENT_SOURCE_DIR}/cmake")
+
+-find_package(CCache)
+-
+-if (CCache_FOUND)
+- option(OPENRCT2_USE_CCACHE "Use CCache to improve recompilation speed (optional)" ON)
+- if (OPENRCT2_USE_CCACHE)
+- # Use e.g. "ccache clang++" instead of "clang++"
+- set_property(GLOBAL PROPERTY RULE_LAUNCH_COMPILE "${CCache_EXECUTABLE}")
+- set_property(GLOBAL PROPERTY RULE_LAUNCH_LINK "${CCache_EXECUTABLE}")
+- endif (OPENRCT2_USE_CCACHE)
+-endif (CCache_FOUND)
++option(OPENRCT2_USE_CCACHE "Use CCache to improve recompilation speed (optional)" ON)
++
++if (OPENRCT2_USE_CCACHE)
++ find_package(CCache)
++
++ if (CCache_FOUND)
++ # Use e.g. "ccache clang++" instead of "clang++"
++ set_property(GLOBAL PROPERTY RULE_LAUNCH_COMPILE "${CCache_EXECUTABLE}")
++ set_property(GLOBAL PROPERTY RULE_LAUNCH_LINK "${CCache_EXECUTABLE}")
++ else()
++ message("Usage of CCache was enabled, but CCache was not found, so CCache is not being enabled.")
++ endif()
++endif (OPENRCT2_USE_CCACHE)
+
+ if (APPLE)
+ execute_process(COMMAND /usr/bin/uname -m OUTPUT_VARIABLE SYSTEM_MACOS_ARCH OUTPUT_STRIP_TRAILING_WHITESPACE)
diff --git a/games-simulation/openrct2/openrct2-0.3.5.1.ebuild b/games-simulation/openrct2/openrct2-0.3.5.1.ebuild
index af9c013eb4ff..6563d4bf797d 100644
--- a/games-simulation/openrct2/openrct2-0.3.5.1.ebuild
+++ b/games-simulation/openrct2/openrct2-0.3.5.1.ebuild
@@ -21,11 +21,13 @@ SRC_URI="
https://github.com/${MY_PN}/${MY_PN_TS}/releases/download/v${MY_PV_TS}/${MY_PN_TS}.zip -> ${PN}-${MY_PN_TS}-${MY_PV_TS}.zip
test? ( https://github.com/${MY_PN}/${MY_PN_RPL}/releases/download/v${MY_PV_RPL}/${MY_PN_RPL}.zip -> ${PN}-${MY_PN_RPL}-${MY_PV_RPL}.zip )
"
+S="${WORKDIR}/${MY_PN}-${PV}"
LICENSE="GPL-3"
SLOT="0"
KEYWORDS="~amd64 ~arm ~arm64 ~x86"
IUSE="dedicated +lightfx +opengl scripting test +truetype"
+RESTRICT="!test? ( test )"
COMMON_DEPEND="
dev-libs/icu:=
@@ -66,13 +68,10 @@ BDEPEND="
virtual/pkgconfig
"
-RESTRICT="!test? ( test )"
-
-S="${WORKDIR}/${MY_PN}-${PV}"
-
PATCHES=(
"${FILESDIR}/${PN}-0.2.4-include-additional-paths.patch"
"${FILESDIR}/${PN}-0.2.6-gtest-1.10.patch"
+ "${FILESDIR}/${PN}-0.3.5.1-ccache.patch"
)
src_unpack() {