summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /games-strategy/glob2
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'games-strategy/glob2')
-rw-r--r--games-strategy/glob2/Manifest1
-rw-r--r--games-strategy/glob2/files/glob2-0.9.4.4-gcc44.patch12
-rw-r--r--games-strategy/glob2/files/glob2-0.9.4.4-gcc49.patch35
-rw-r--r--games-strategy/glob2/files/glob2-0.9.4.4-scons-blows.patch26
-rw-r--r--games-strategy/glob2/files/glob2-0.9.4.4-underlinking.patch19
-rw-r--r--games-strategy/glob2/glob2-0.9.4.4-r1.ebuild69
-rw-r--r--games-strategy/glob2/metadata.xml12
7 files changed, 174 insertions, 0 deletions
diff --git a/games-strategy/glob2/Manifest b/games-strategy/glob2/Manifest
new file mode 100644
index 000000000000..843e1901a2b7
--- /dev/null
+++ b/games-strategy/glob2/Manifest
@@ -0,0 +1 @@
+DIST glob2-0.9.4.4.tar.gz 11338986 SHA256 0f4d898ec6b05ce27b4a12ef242cc26571304b90d2509932a4743c71311314b8 SHA512 c82ace807ad208bc386b730f1fe6d6162640a9468440482f3584f8ccab825967660d8bbf6b3bebf70c74d1ed95f153cd9b5a0bd72dc247a1f97176c6c737f6ca WHIRLPOOL d151bc9601eb283a366d98ae23bd5eb6b793024c5f9b9cf49ddc55910142885e5b2f89bfdce4f879190368466f2cc01e836a9178fd899d27d4342bee4c1f9a3a
diff --git a/games-strategy/glob2/files/glob2-0.9.4.4-gcc44.patch b/games-strategy/glob2/files/glob2-0.9.4.4-gcc44.patch
new file mode 100644
index 000000000000..5ce62ea6e46c
--- /dev/null
+++ b/games-strategy/glob2/files/glob2-0.9.4.4-gcc44.patch
@@ -0,0 +1,12 @@
+--- libgag/include/StreamBackend.h.old
++++ libgag/include/StreamBackend.h
+@@ -28,6 +28,9 @@
+ #ifdef putc
+ #undef putc
+ #endif
++#ifdef getc
++#undef getc
++#endif
+
+ namespace GAGCore
+ {
diff --git a/games-strategy/glob2/files/glob2-0.9.4.4-gcc49.patch b/games-strategy/glob2/files/glob2-0.9.4.4-gcc49.patch
new file mode 100644
index 000000000000..fca1efb5891a
--- /dev/null
+++ b/games-strategy/glob2/files/glob2-0.9.4.4-gcc49.patch
@@ -0,0 +1,35 @@
+From https://bugs.gentoo.org/show_bug.cgi?id=538580
+
+Works around this build failure:
+
+In file included from src/AICastor.cpp:26:0:
+src/Game.h: In member function 'void AICastor::computeBuildingNeighbourMap(int, int)':
+src/Game.h:152:9: error: 'struct Game::BuildProject' is private
+ struct BuildProject
+ ^
+src/AICastor.cpp:2296:23: error: within this context
+ for (std::list<Game::BuildProject>::iterator bpi=game->buildProjects.begin(); bpi!=game->buildProjects.end(); bpi++)
+ ^
+scons: *** [src/AICastor.o] Error 1
+scons: building terminated because of errors.
+
+patch submitted by zimous
+
+--- glob2-0.9.4.4.orig/src/Game.h
++++ glob2-0.9.4.4/src/Game.h
+@@ -149,6 +149,7 @@
+ BOTTOM_TO_TOP
+ };
+
++public:
+ struct BuildProject
+ {
+ int posX;
+@@ -159,6 +160,7 @@
+ int unitWorkingFuture;
+ };
+
++private:
+ ///Initiates Game
+ void init(GameGUI *gui, MapEdit* edit);
+
diff --git a/games-strategy/glob2/files/glob2-0.9.4.4-scons-blows.patch b/games-strategy/glob2/files/glob2-0.9.4.4-scons-blows.patch
new file mode 100644
index 000000000000..70619f04839d
--- /dev/null
+++ b/games-strategy/glob2/files/glob2-0.9.4.4-scons-blows.patch
@@ -0,0 +1,26 @@
+--- SConstruct.orig
++++ SConstruct
+@@ -1,6 +1,7 @@
+ EnsureSConsVersion(0, 96, 92)
+ import sys
+ import os
++import SCons.Util
+ import glob
+ sys.path.append( os.path.abspath("scons") )
+ import bundle
+@@ -268,6 +269,15 @@
+ env["TARFILE"] = env.Dir("#").abspath + "/glob2-" + env["VERSION"] + ".tar.gz"
+ env["TARFLAGS"] = "-c -z"
+ env.Alias("dist", env["TARFILE"])
++ # Using suggestions for http://dev.gentoo.org/~vapier/scons-blows.txt
++ if os.environ.has_key('CC'):
++ env['CC'] = os.environ['CC']
++ if os.environ.has_key('CXX'):
++ env['CXX'] = os.environ['CXX']
++ if os.environ.has_key('CXXFLAGS'):
++ env['CXXFLAGS'] += SCons.Util.CLVar(os.environ['CXXFLAGS'])
++ if os.environ.has_key('LDFLAGS'):
++ env['LINKFLAGS'] += SCons.Util.CLVar(os.environ['LDFLAGS'])
+
+ def PackTar(target, source):
+ if "dist" in COMMAND_LINE_TARGETS:
diff --git a/games-strategy/glob2/files/glob2-0.9.4.4-underlinking.patch b/games-strategy/glob2/files/glob2-0.9.4.4-underlinking.patch
new file mode 100644
index 000000000000..65eba48717db
--- /dev/null
+++ b/games-strategy/glob2/files/glob2-0.9.4.4-underlinking.patch
@@ -0,0 +1,19 @@
+--- glob2-0.9.4.4.orig/SConstruct
++++ glob2-0.9.4.4/SConstruct
+@@ -110,6 +110,16 @@
+ print "Could not find libz or zlib1.dll"
+ missing.append("zlib")
+
++ boost_system = ''
++ if conf.CheckLib("boost_system"):
++ boost_system="boost_system"
++ elif conf.CheckLib("boost_system-mt"):
++ boost_system="boost_system-mt"
++ else:
++ print "Could not find libboost_system or libboost_system-mt"
++ missing.append("libboost_system")
++ env.Append(LIBS=[boost_system])
++
+ boost_thread = ''
+ if conf.CheckLib("boost_thread") and conf.CheckCXXHeader("boost/thread/thread.hpp"):
+ boost_thread="boost_thread"
diff --git a/games-strategy/glob2/glob2-0.9.4.4-r1.ebuild b/games-strategy/glob2/glob2-0.9.4.4-r1.ebuild
new file mode 100644
index 000000000000..06a7f2bf085e
--- /dev/null
+++ b/games-strategy/glob2/glob2-0.9.4.4-r1.ebuild
@@ -0,0 +1,69 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit eutils gnome2-utils scons-utils games
+
+DESCRIPTION="Real Time Strategy (RTS) game involving a brave army of globs"
+HOMEPAGE="http://globulation2.org/"
+SRC_URI="mirror://nongnu/glob2/${PV:0:5}/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="amd64 ppc x86"
+IUSE=""
+
+RDEPEND="
+ >=dev-libs/boost-1.34[threads]
+ dev-libs/fribidi
+ media-libs/libsdl[opengl]
+ media-libs/libvorbis
+ media-libs/sdl-image[png]
+ media-libs/sdl-net
+ media-libs/sdl-ttf
+ media-libs/speex
+ virtual/glu
+ virtual/opengl"
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-{gcc44,scons-blows,underlinking,gcc49}.patch
+}
+
+src_configure() {
+ myesconsargs=(
+ INSTALLDIR="${GAMES_DATADIR}"/${PN}
+ DATADIR="${GAMES_DATADIR}"/${PN}
+ )
+ escons data
+}
+
+src_compile() {
+ escons
+}
+
+src_install() {
+ dogamesbin src/${PN}
+ insinto "${GAMES_DATADIR}"/${PN}
+ doins -r campaigns data maps scripts
+ find "${D}/${GAMES_DATADIR}"/${PN} -name SConscript -exec rm -f '{}' +
+ newicon -s 48 data/icons/glob2-icon-48x48.png ${PN}.png
+ make_desktop_entry glob2 "Globulation 2"
+ dodoc README*
+ prepgamesdirs
+}
+
+pkg_preinst() {
+ games_pkg_preinst
+ gnome2_icon_savelist
+}
+
+pkg_postinst() {
+ games_pkg_postinst
+ gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+}
diff --git a/games-strategy/glob2/metadata.xml b/games-strategy/glob2/metadata.xml
new file mode 100644
index 000000000000..fc67f56d09d1
--- /dev/null
+++ b/games-strategy/glob2/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>games</herd>
+<longdescription>
+Globulation2 is an innovative high quality Real-Time Strategy [RTS],
+which minimizes micro-management by automatically assigning tasks to
+the units. The player has to choose the number of units he wants for
+the different tasks, and the units will do their best to satisfy the
+requests. This allows to manage more units and to focus on strategies.
+</longdescription>
+</pkgmetadata>