summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <Arfrever@Apache.Org>2021-01-16 04:00:00 +0000
committerSam James <sam@gentoo.org>2021-01-17 01:17:14 +0000
commit84eacd197ad2a5551821b77854a5da1f7f1b245f (patch)
treec2bc97630e162d94a0624e4625953b5b0fa7b4f7 /games-strategy
parentgames-strategy/0ad: Version bump (0.0.24_alpha_pre20210116040036). (diff)
downloadgentoo-84eacd197ad2a5551821b77854a5da1f7f1b245f.tar.gz
gentoo-84eacd197ad2a5551821b77854a5da1f7f1b245f.tar.bz2
gentoo-84eacd197ad2a5551821b77854a5da1f7f1b245f.zip
games-strategy/0ad-data: Version bump (0.0.24_alpha_pre20210116040036).
Signed-off-by: Arfrever Frehtes Taifersar Arahesis <Arfrever@Apache.Org> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'games-strategy')
-rw-r--r--games-strategy/0ad-data/0ad-data-0.0.24_alpha_pre20210116040036.ebuild88
-rw-r--r--games-strategy/0ad-data/Manifest1
2 files changed, 89 insertions, 0 deletions
diff --git a/games-strategy/0ad-data/0ad-data-0.0.24_alpha_pre20210116040036.ebuild b/games-strategy/0ad-data/0ad-data-0.0.24_alpha_pre20210116040036.ebuild
new file mode 100644
index 000000000000..da5bd064e6ec
--- /dev/null
+++ b/games-strategy/0ad-data/0ad-data-0.0.24_alpha_pre20210116040036.ebuild
@@ -0,0 +1,88 @@
+# Copyright 2014-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+
+MY_PN="0ad"
+
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+
+ EGIT_REPO_URI="https://github.com/0ad/0ad"
+ ZEROAD_GIT_REVISION=""
+elif [[ ${PV} == *_pre* ]]; then
+ ZEROAD_GIT_REVISION="c7d07d3979f969b969211a5e5748fa775f6768a7"
+else
+ MY_P="${MY_PN}-${PV/_/-}"
+fi
+
+DESCRIPTION="Data files for 0ad"
+HOMEPAGE="https://play0ad.com/"
+if [[ ${PV} == 9999 ]]; then
+ SRC_URI=""
+elif [[ ${PV} == *_pre* ]]; then
+ SRC_URI="https://github.com/0ad/0ad/archive/${ZEROAD_GIT_REVISION}.tar.gz -> ${MY_PN}-${PV}.tar.gz"
+else
+ SRC_URI="http://releases.wildfiregames.com/${MY_P}-unix-data.tar.xz"
+fi
+
+LICENSE="BitstreamVera CC-BY-SA-3.0 GPL-2 LPPL-1.3c"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+if [[ ${PV} == 9999 || ${PV} == *_pre* ]]; then
+ BDEPEND="~games-strategy/0ad-${PV}[nvtt]"
+else
+ BDEPEND=""
+fi
+DEPEND=""
+RDEPEND=""
+
+if [[ ${PV} == 9999 ]]; then
+ S="${WORKDIR}/${MY_PN}-${PV}"
+elif [[ ${PV} == *_pre* ]]; then
+ S="${WORKDIR}/${MY_PN}-${ZEROAD_GIT_REVISION}"
+else
+ S="${WORKDIR}/${MY_P}"
+fi
+
+src_prepare() {
+ default
+ rm binaries/data/tools/fontbuilder/fonts/*.txt || die
+}
+
+src_compile() {
+ if [[ ${PV} == 9999 || ${PV} == *_pre* ]]; then
+ # source/lib/sysdep/os/linux/ldbg.cpp:debug_SetThreadName() tries to open /proc/self/task/${TID}/comm for writing.
+ addpredict /proc/self/task
+
+ # Based on source/tools/dist/build-archives.sh used by source/tools/dist/build.sh.
+ local archivebuild_input archivebuild_output mod_name
+ for archivebuild_input in binaries/data/mods/[A-Za-z0-9]*; do
+ mod_name="${archivebuild_input##*/}"
+ archivebuild_output="archives/${mod_name}"
+
+ mkdir -p "${archivebuild_output}"
+
+ einfo 0ad -archivebuild="${archivebuild_input}" -archivebuild-output="${archivebuild_output}/${mod_name}.zip"
+ 0ad -archivebuild="${archivebuild_input}" -archivebuild-output="${archivebuild_output}/${mod_name}.zip" || die
+
+ if [[ -f "${archivebuild_input}/mod.json" ]]; then
+ cp "${archivebuild_input}/mod.json" "${archivebuild_output}"
+ fi
+
+ rm -r "${archivebuild_input}" || die
+ mv "${archivebuild_output}" "${archivebuild_input}" || die
+ done
+
+ # Based on source/tools/dist/build-unix-win32.sh used by source/tools/dist/build.sh.
+ rm binaries/data/config/dev.cfg || die
+ rm -r binaries/data/mods/_test.* || die
+ fi
+}
+
+src_install() {
+ insinto /usr/share/0ad
+ doins -r binaries/data/{config,mods,tools}
+}
diff --git a/games-strategy/0ad-data/Manifest b/games-strategy/0ad-data/Manifest
index b346a707690d..b46c67536ae3 100644
--- a/games-strategy/0ad-data/Manifest
+++ b/games-strategy/0ad-data/Manifest
@@ -1,2 +1,3 @@
DIST 0ad-0.0.23-alpha-unix-data.tar.xz 691973492 BLAKE2B 7dcd36d21ea2c12f314f5a185a0fce57cec33754fbd26ad34c376fb9c7725fe5487e79a3da54249981fe58bf03c39350a871198a4cfb98c3a40eb878c6cc39b6 SHA512 9eae8bbdf83f609a0775261d691435c2924b505499fdf36ac0922b5f0c1d605dae49f257a872153c718d8bad018f6635320ec376418761c0d650bf165765e062
DIST 0ad-0.0.23b-alpha-unix-data.tar.xz 691280800 BLAKE2B 9ee0a1c14adb4fa2a842ad734f67a40af60d063c2f1876a34c49e584017b3fc6894a6be7c6533f15031b118d8a88b40b223decdbc3b8ea95f912271ec56f3a90 SHA512 d0515e44f575737a06f27c75c0a58a5229ead474ae6d48531142015548e5986145f895f95e0fa9209cf9085c7c431f4179ff2e70c1a532f61d1cb62c0a91bcfc
+DIST 0ad-0.0.24_alpha_pre20210116040036.tar.gz 2562395684 BLAKE2B 03d6655f7aa1f2f91a87536a7f2afa465585856c4209ddc05e666e1e5596416883596331118ac4257ff314b04d8a5c08821eaa6ae76e5d3095146ab04f8c79ed SHA512 e1239a56b184a87708c87fc03ca41190a16d813e495c5d81ee073df98761f1524a23902e5d03a21a1b1f657b496fce6eeee4a5ef22eee30f70fbe3b0dbd44510