summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2021-06-02 20:14:15 -0400
committerIonen Wolkens <ionen@gentoo.org>2021-06-02 20:16:03 -0400
commit3e3601fa7d66be964e0ec785bcb9e8ad9e15dc6a (patch)
tree3c8c1a12274d1c1d0e1f259fcfe5653b2eef35a4 /games-util/glbsp
parentmedia-libs/openimageio: disable automagic ccache usage (diff)
downloadgentoo-3e3601fa7d66be964e0ec785bcb9e8ad9e15dc6a.tar.gz
gentoo-3e3601fa7d66be964e0ec785bcb9e8ad9e15dc6a.tar.bz2
gentoo-3e3601fa7d66be964e0ec785bcb9e8ad9e15dc6a.zip
games-util/glbsp: fix build with USE=fltk
Closes: https://bugs.gentoo.org/627412 Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Diffstat (limited to 'games-util/glbsp')
-rw-r--r--games-util/glbsp/files/glbsp-2.24-return-type.patch9
-rw-r--r--games-util/glbsp/glbsp-2.24.ebuild1
2 files changed, 10 insertions, 0 deletions
diff --git a/games-util/glbsp/files/glbsp-2.24-return-type.patch b/games-util/glbsp/files/glbsp-2.24-return-type.patch
new file mode 100644
index 000000000000..c1ae57cec8d1
--- /dev/null
+++ b/games-util/glbsp/files/glbsp-2.24-return-type.patch
@@ -0,0 +1,9 @@
+Fix build failure with USE=fltk due to wrong return type.
+https://bugs.gentoo.org/627412
+--- a/nodeview/path.cc
++++ b/nodeview/path.cc
+@@ -47,3 +47,3 @@
+ PrintWarn("Unable to open path file: %s\n", strerror(errno));
+- return false;
++ return NULL;
+ }
diff --git a/games-util/glbsp/glbsp-2.24.ebuild b/games-util/glbsp/glbsp-2.24.ebuild
index 79ed87ae1288..335f4b3cd574 100644
--- a/games-util/glbsp/glbsp-2.24.ebuild
+++ b/games-util/glbsp/glbsp-2.24.ebuild
@@ -21,6 +21,7 @@ RDEPEND="${DEPEND}"
PATCHES=(
"${FILESDIR}"/${P}-ldflags.patch
+ "${FILESDIR}"/${P}-return-type.patch
)
src_prepare() {