summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2022-09-04 13:08:08 -0400
committerMatt Turner <mattst88@gentoo.org>2022-09-04 13:11:00 -0400
commitad04ff8f3b899885372bf5d0845d9395392b9290 (patch)
tree09b173a402534ffcbd001a0ac0120583b80c4566 /gnome-base
parentdev-java/logback-core: dependency updates (diff)
downloadgentoo-ad04ff8f3b899885372bf5d0845d9395392b9290.tar.gz
gentoo-ad04ff8f3b899885372bf5d0845d9395392b9290.tar.bz2
gentoo-ad04ff8f3b899885372bf5d0845d9395392b9290.zip
gnome-base/libgnomekbd: Version bump to 3.28.1
Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'gnome-base')
-rw-r--r--gnome-base/libgnomekbd/Manifest1
-rw-r--r--gnome-base/libgnomekbd/libgnomekbd-3.28.1.ebuild38
2 files changed, 39 insertions, 0 deletions
diff --git a/gnome-base/libgnomekbd/Manifest b/gnome-base/libgnomekbd/Manifest
index 18bf1ff82664..b90476cf41d6 100644
--- a/gnome-base/libgnomekbd/Manifest
+++ b/gnome-base/libgnomekbd/Manifest
@@ -1 +1,2 @@
DIST libgnomekbd-3.26.1.tar.xz 450636 BLAKE2B 241f2f9af95696600f82ab3a1f53f80c6e76f6e81636419407957f172a2758ee16f5c6d419ab1c1c37d2e054c42b65404062471eceabc0fba45099481eb7b214 SHA512 8e83522f4d96001f9635278a001e0208d6d37e74b19a8c1702ec6de651036ad37a03385e66adbd3bae01d845a9a6181bb76f45bffec31eac98d600b49ab4360c
+DIST libgnomekbd-3.28.1.tar.xz 154800 BLAKE2B 803ef97d5d9cd31d762be1f57cbe967a93097ee724bf8e6bcb11aea414947d27c78b06b02e7843f48c505e4eea7c88e79d1d3b6d0090641c7d8ebf363bc90845 SHA512 ffcabfe19289057dd3d7489170093ff1614c3344103ba8ebc6c69f5668d01fea652b7be6c7d5c66291df3a319f975df5cf5167168cd0f60cede022b76bb57cb5
diff --git a/gnome-base/libgnomekbd/libgnomekbd-3.28.1.ebuild b/gnome-base/libgnomekbd/libgnomekbd-3.28.1.ebuild
new file mode 100644
index 000000000000..a87b7335273f
--- /dev/null
+++ b/gnome-base/libgnomekbd/libgnomekbd-3.28.1.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit gnome.org meson
+
+DESCRIPTION="Gnome keyboard configuration library"
+HOMEPAGE="https://gitlab.gnome.org/GNOME/libgnomekbd"
+
+LICENSE="LGPL-2+"
+SLOT="0/8"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux ~x86-solaris"
+IUSE="+introspection"
+
+RDEPEND="
+ >=dev-libs/glib-2.44.0:2
+ >=x11-libs/gtk+-2.91.7:3[X,introspection?]
+ x11-libs/libX11
+ >=x11-libs/libxklavier-5.2:=[introspection?]
+
+ introspection? ( >=dev-libs/gobject-introspection-0.6.7:= )
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ dev-util/glib-utils
+ >=sys-devel/gettext-0.19.6
+ virtual/pkgconfig
+"
+
+src_configure() {
+ local emesonargs=(
+ $(meson_use introspection)
+ -Dvapi=false # will add USE=vala if there's a reverse dependency
+ -Dtests=false # Controls building test programs that are not installed
+ )
+ meson_src_configure
+}