summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2023-06-19 14:19:18 +0200
committerPacho Ramos <pacho@gentoo.org>2023-06-19 14:19:18 +0200
commit0e16db1c88ffaf4d480c79159523c9f053c5fc8d (patch)
tree8f5120669fc05eadd9f0f12306eb8a2ed27319ad /gnome-extra/gnome-shell-extension-alphabetical-grid
parentdev-vcs/svneverever: 1.7.2 (diff)
downloadgentoo-0e16db1c88ffaf4d480c79159523c9f053c5fc8d.tar.gz
gentoo-0e16db1c88ffaf4d480c79159523c9f053c5fc8d.tar.bz2
gentoo-0e16db1c88ffaf4d480c79159523c9f053c5fc8d.zip
gnome-extra/gnome-shell-extension-alphabetical-grid: add 30.0
Signed-off-by: Pacho Ramos <pacho@gentoo.org>
Diffstat (limited to 'gnome-extra/gnome-shell-extension-alphabetical-grid')
-rw-r--r--gnome-extra/gnome-shell-extension-alphabetical-grid/Manifest1
-rw-r--r--gnome-extra/gnome-shell-extension-alphabetical-grid/gnome-shell-extension-alphabetical-grid-30.0.ebuild59
2 files changed, 60 insertions, 0 deletions
diff --git a/gnome-extra/gnome-shell-extension-alphabetical-grid/Manifest b/gnome-extra/gnome-shell-extension-alphabetical-grid/Manifest
index 19e3bede975b..fd4c5a4d1d6a 100644
--- a/gnome-extra/gnome-shell-extension-alphabetical-grid/Manifest
+++ b/gnome-extra/gnome-shell-extension-alphabetical-grid/Manifest
@@ -1 +1,2 @@
DIST gnome-shell-extension-alphabetical-grid-29.0.tar.gz 213643 BLAKE2B f4e0244f41ec426f5c2189ccfb32144c419d10d22ea477b102d60defd203cc80cb5272aaeedcc5fd3e554341a51aa9ed0e829e38a2c6977daaf82f954fd6a073 SHA512 a4417637d719cc2d35fca80b3621e8bd6e965ed87890105f611d69ae4b901c25080c64599ceac3518dafedd0fb240989b447b643bb88fc2164463371eb0c98f2
+DIST gnome-shell-extension-alphabetical-grid-30.0.tar.gz 214324 BLAKE2B 36e20967f3f67b613ad1fc6c3730aff16e40bc3680e452f98eb801991b7a76ec9c08192d0e10dddc34d28ed8418a45b6905cab7b8d2a80e8b2afb43d43c746c8 SHA512 49708adb6d8f78cf426cdb6b67de9c9db0d0a0f4500b6e491b2b806de658cfa99528df6a6042bbf201fbb69a34782aca6072d17a2da43e5ea148e2cec8a3f9be
diff --git a/gnome-extra/gnome-shell-extension-alphabetical-grid/gnome-shell-extension-alphabetical-grid-30.0.ebuild b/gnome-extra/gnome-shell-extension-alphabetical-grid/gnome-shell-extension-alphabetical-grid-30.0.ebuild
new file mode 100644
index 000000000000..60d548d52ade
--- /dev/null
+++ b/gnome-extra/gnome-shell-extension-alphabetical-grid/gnome-shell-extension-alphabetical-grid-30.0.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+inherit gnome2-utils
+
+# Useful specially to prevent
+# https://gitlab.gnome.org/GNOME/gnome-shell/-/issues/4684
+# https://gitlab.gnome.org/GNOME/gnome-shell/-/issues/3180
+DESCRIPTION="Restore the alphabetical ordering of the app grid"
+HOMEPAGE="https://github.com/stuarthayhurst/alphabetical-grid-extension"
+SRC_URI="https://github.com/stuarthayhurst/alphabetical-grid-extension/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="
+ app-eselect/eselect-gnome-shell-extensions
+ >=gnome-base/gnome-shell-3.38
+"
+DEPEND="${COMMON_DEPEND}"
+BDEPEND=""
+
+S="${WORKDIR}/alphabetical-grid-extension-${PV}"
+extension_uuid="AlphabeticalAppGrid@stuarthayhurst"
+
+# Tests are only useful for upstream
+RESTRICT="test"
+
+# Not useful for us
+src_compile() { :; }
+
+src_install() {
+ einstalldocs
+ mv docs/icon.svg extension || die
+ cd extension || die
+ insinto /usr/share/glib-2.0/schemas
+ doins schemas/*.xml
+ rm -rf schemas || die
+ insinto /usr/share/gnome-shell/extensions/"${extension_uuid}"
+ doins -r *
+}
+
+pkg_preinst() {
+ gnome2_schemas_savelist
+}
+
+pkg_postinst() {
+ gnome2_schemas_update
+ ebegin "Updating list of installed extensions"
+ eselect gnome-shell-extensions update
+ eend $?
+}
+
+pkg_postrm() {
+ gnome2_schemas_update
+}