summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew S. Turnbull <sparky@bluefang-logic.com>2023-07-04 23:47:10 -0400
committerSam James <sam@gentoo.org>2023-07-16 19:33:01 +0100
commit56c22b5804b1aec01473e34624237720f311fa5c (patch)
tree1c8d84ee82315aa572c8e880a5fb77ed8206f508 /gnome-extra
parentgnome-extra/cinnamon-translations: add 5.8.2 (diff)
downloadgentoo-56c22b5804b1aec01473e34624237720f311fa5c.tar.gz
gentoo-56c22b5804b1aec01473e34624237720f311fa5c.tar.bz2
gentoo-56c22b5804b1aec01473e34624237720f311fa5c.zip
gnome-extra/cjs: add 5.8.0
Signed-off-by: Matthew S. Turnbull <sparky@bluefang-logic.com> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'gnome-extra')
-rw-r--r--gnome-extra/cjs/Manifest1
-rw-r--r--gnome-extra/cjs/cjs-5.8.0.ebuild95
-rw-r--r--gnome-extra/cjs/files/cjs-5.8.0-move_have_gtk4_to_the_appropriate_place.patch38
3 files changed, 134 insertions, 0 deletions
diff --git a/gnome-extra/cjs/Manifest b/gnome-extra/cjs/Manifest
index 7475c2fec6ef..29fe45dfc6c9 100644
--- a/gnome-extra/cjs/Manifest
+++ b/gnome-extra/cjs/Manifest
@@ -1 +1,2 @@
DIST cjs-5.6.1.tar.gz 794907 BLAKE2B 9ec6d5ffb33a28dca96d640da7b499e81751d5889dd0caec354fdf41de7b42c8d8edd737def68c2506c94af7a69a4d3433c459da2a5884f2668f14eac22163a0 SHA512 35662d78174d428610642198d7777a2c19137cd61dce93de69011fea235b0f461a2072ff219da0f18ef36068c1e3e5c2dc88684493b900a12fc1cd0b32503ae5
+DIST cjs-5.8.0.tar.gz 877668 BLAKE2B e4c031631030c2a4221937d5ca04034163f70f21e6e5ff2d0ca15f31a7455e83ecb1f977c4c4fb9a57e58d266856f817446e53b86ee87460bedf5339e33461b6 SHA512 f43bda5810b90ceab24d096d884c65503b2d9b94f5c0a9e6082215a427df97fbec4a21ee3f2d4f22d98ac24a04af1dcd9064600ec191ccec96ae0869cc803a02
diff --git a/gnome-extra/cjs/cjs-5.8.0.ebuild b/gnome-extra/cjs/cjs-5.8.0.ebuild
new file mode 100644
index 000000000000..4a0965dcd743
--- /dev/null
+++ b/gnome-extra/cjs/cjs-5.8.0.ebuild
@@ -0,0 +1,95 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{9..11} )
+
+inherit flag-o-matic meson pax-utils python-any-r1 virtualx
+
+DESCRIPTION="Linux Mint's fork of gjs for Cinnamon"
+HOMEPAGE="https://projects.linuxmint.com/cinnamon/ https://github.com/linuxmint/cjs"
+SRC_URI="https://github.com/linuxmint/cjs/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD CC0-1.0 MIT MPL-2.0 || ( MPL-1.1 GPL-2+ LGPL-2.1+ )"
+SLOT="0"
+IUSE="+cairo examples readline sysprof test"
+KEYWORDS="~amd64 ~arm64 ~ppc64 ~riscv ~x86"
+
+RDEPEND="
+ dev-lang/spidermonkey:102
+ >=dev-libs/glib-2.66.0:2
+ >=dev-libs/gobject-introspection-1.71.0:=
+ >=dev-libs/libffi-3.3:0=
+
+ cairo? (
+ x11-libs/cairo[glib,svg(+),X]
+ x11-libs/libX11
+ )
+ readline? ( sys-libs/readline:0= )
+"
+DEPEND="
+ ${RDEPEND}
+ sysprof? ( >=dev-util/sysprof-capture-3.40.1:4 )
+ test? (
+ sys-apps/dbus
+ x11-libs/gtk+:3[introspection]
+ )
+"
+BDEPEND="
+ ${PYTHON_DEPS}
+ virtual/pkgconfig
+"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-5.8.0-move_have_gtk4_to_the_appropriate_place.patch
+)
+
+src_prepare() {
+ default
+ python_fix_shebang build
+}
+
+src_configure() {
+ append-cppflags -DG_DISABLE_CAST_CHECKS
+
+ # On musl, it's required that either gjs, pixman or gnome-shell to be built
+ # with a larger stack otherwise librsvg fails to render a particular SVG, as
+ # a result we fail to get gdm or gnome-shell running (greeted with a fail
+ # whale screen). The bug has been reported to librsvg. This is ideally just
+ # a temporary workaround until we understand what exactly needs a larger
+ # stack size, as it's not sufficient to do just librsvg.
+ #
+ # Please refer to:
+ # https://gitlab.gnome.org/GNOME/librsvg/-/issues/686
+ # https://gitlab.gnome.org/GNOME/librsvg/-/issues/874
+ #
+ # TODO: Find an actual fix instead of increasing the stack
+ use elibc_musl && append-ldflags -Wl,-z,stack-size=2097152
+
+ local emesonargs=(
+ $(meson_feature cairo)
+ $(meson_feature readline)
+ $(meson_feature sysprof profiler)
+ -Dinstalled_tests=false
+ $(meson_use !test skip_dbus_tests)
+ $(meson_use !test skip_gtk_tests)
+ )
+ meson_src_configure
+}
+
+src_test() {
+ virtx meson_src_test
+}
+
+src_install() {
+ meson_src_install
+
+ if use examples; then
+ docinto examples
+ dodoc "${S}"/examples/*
+ fi
+
+ # Required for cjs-console to run correctly on PaX systems
+ pax-mark mr "${ED}/usr/bin/cjs-console"
+}
diff --git a/gnome-extra/cjs/files/cjs-5.8.0-move_have_gtk4_to_the_appropriate_place.patch b/gnome-extra/cjs/files/cjs-5.8.0-move_have_gtk4_to_the_appropriate_place.patch
new file mode 100644
index 000000000000..2bb80126507f
--- /dev/null
+++ b/gnome-extra/cjs/files/cjs-5.8.0-move_have_gtk4_to_the_appropriate_place.patch
@@ -0,0 +1,38 @@
+# https://gitlab.gnome.org/GNOME/gjs/-/issues/532
+# https://gitlab.gnome.org/GNOME/gjs/-/merge_requests/830/diffs?commit_id=83683d093c157828cf7787e53a32c586ae4e85d3
+diff --git a/installed-tests/js/meson.build b/installed-tests/js/meson.build
+index 6db887d2250face397079b03d215bbd13f455efb..1e953ceb7695356b6e854775e5db005a9c22e053 100644
+--- a/installed-tests/js/meson.build
++++ b/installed-tests/js/meson.build
+@@ -203,9 +203,13 @@ endif
+ # during build should be run using dbus-run-session
+
+ dbus_tests = ['GDBus']
+-if have_gtk4 and not get_option('skip_gtk_tests')
+- # FIXME: find out why GTK4 tries to acquire a message bus
+- dbus_tests += 'Gtk4'
++if not get_option('skip_gtk_tests')
++ have_gtk4 = dependency('gtk4', required: false).found()
++
++ if have_gtk4
++ # FIXME: find out why GTK4 tries to acquire a message bus
++ dbus_tests += 'Gtk4'
++ endif
+ endif
+
+ bus_config = files('../../test/test-bus.conf')
+diff --git a/meson.build b/meson.build
+index 3ac372a16b0bfaa364ed7422119f3e6e4af8971e..5c7703935b68c724347692ef5bf47a3edf868c61 100644
+--- a/meson.build
++++ b/meson.build
+@@ -679,10 +679,6 @@ endif
+
+ ### Tests and test setups ######################################################
+
+-if not get_option('skip_gtk_tests')
+- have_gtk4 = dependency('gtk4', required: false).found()
+-endif
+-
+ subdir('installed-tests')
+
+ # Note: The test program in test/ needs to be ported