summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMart Raudsepp <leio@gentoo.org>2018-09-09 20:45:48 +0300
committerMart Raudsepp <leio@gentoo.org>2018-09-09 20:52:02 +0300
commitdb38d778b39b98cd1efdf0c53b41c10f6cecc35e (patch)
tree2c6eda69d45e8d4d90c42455b1c9e42b67325b38 /gnome-extra
parentmail-client/evolution: bump to 3.26.6 (diff)
downloadgentoo-db38d778b39b98cd1efdf0c53b41c10f6cecc35e.tar.gz
gentoo-db38d778b39b98cd1efdf0c53b41c10f6cecc35e.tar.bz2
gentoo-db38d778b39b98cd1efdf0c53b41c10f6cecc35e.zip
gnome-extra/evolution-ews: bump to 3.26.6
Package-Manager: Portage-2.3.49, Repoman-2.3.10
Diffstat (limited to 'gnome-extra')
-rw-r--r--gnome-extra/evolution-ews/Manifest1
-rw-r--r--gnome-extra/evolution-ews/evolution-ews-3.26.6.ebuild66
2 files changed, 67 insertions, 0 deletions
diff --git a/gnome-extra/evolution-ews/Manifest b/gnome-extra/evolution-ews/Manifest
index 96a148fa2a20..6cf54081b0e6 100644
--- a/gnome-extra/evolution-ews/Manifest
+++ b/gnome-extra/evolution-ews/Manifest
@@ -1 +1,2 @@
DIST evolution-ews-3.24.6.tar.xz 488668 BLAKE2B 3ec507b654042882158d2d8dfdbaae0372cc67d515501e45e327ef006cd8674f7b6e48de63f8930add9f29536d3428604f21666cfac98a764cb2eb0c20353ef3 SHA512 24bcaf9755b9d45d4848624b42f2b41bf1532aa836cdd26f8ab57b4dd5ac83d4375c340e0cac6f7f1b830c3ab998597893bce0fdd471ed7b0758a69367edfac1
+DIST evolution-ews-3.26.6.tar.xz 485624 BLAKE2B 7e9b13fff05122a54fe502d0d4bd1f0ba895259b89d074d9f39ab4e56bdd2794e780c61023294ceea79adb94f80a42a232e4cc1743c41b062c1b03c9276a6253 SHA512 eeee228699989d0407ed65d2b8fa37f643890b40084484a125738dc9a10152de435cbc9e3109c1aa5ae90daeb4aba6e06da135c84d7f7e0fd330f5d8448383ee
diff --git a/gnome-extra/evolution-ews/evolution-ews-3.26.6.ebuild b/gnome-extra/evolution-ews/evolution-ews-3.26.6.ebuild
new file mode 100644
index 000000000000..2d35e29eb5ce
--- /dev/null
+++ b/gnome-extra/evolution-ews/evolution-ews-3.26.6.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+GNOME2_LA_PUNT="yes"
+
+inherit cmake-utils gnome2
+
+DESCRIPTION="Evolution module for connecting to Microsoft Exchange Web Services"
+HOMEPAGE="https://wiki.gnome.org/Apps/Evolution"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RDEPEND="
+ dev-db/sqlite:3=
+ >=dev-libs/glib-2.46:2
+ dev-libs/libical:0=
+ >=dev-libs/libmspack-0.4
+ >=dev-libs/libxml2-2
+ >=gnome-extra/evolution-data-server-3.24.7:0=
+ >=mail-client/evolution-${PV}:2.0
+ >=net-libs/libsoup-2.42:2.4
+ >=x11-libs/gtk+-3.10:3
+"
+DEPEND="${RDEPEND}
+ dev-util/gdbus-codegen
+ dev-util/glib-utils
+ >=dev-util/intltool-0.35.5
+ >=sys-devel/gettext-0.18.3
+ virtual/pkgconfig
+ test? ( net-libs/uhttpmock )
+"
+
+# Unittests fail to find libevolution-ews.so
+RESTRICT="test !test? ( test )"
+
+# global scope PATCHES or DOCS array mustn't be used due to double default_src_prepare
+# call; if needed, set them after cmake-utils_src_prepare call, if that works
+
+src_prepare() {
+ cmake-utils_src_prepare
+ gnome2_src_prepare
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DWITH_MSPACK=ON
+ -DENABLE_TESTS=$(usex test)
+ )
+ cmake-utils_src_configure
+}
+
+src_compile() {
+ cmake-utils_src_compile
+}
+
+src_test() {
+ cmake-utils_src_test
+}
+
+src_install() {
+ cmake-utils_src_install
+}