summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2023-12-29 18:50:44 +0200
committerArthur Zamarin <arthurzam@gentoo.org>2023-12-29 19:07:51 +0200
commit34a0f053e0c9e90c5adf2aa1a4896207479a81d7 (patch)
tree834f394b124486037658011298fa29717b2401dc /gui-apps/kanshi
parentprofiles/arch/arm64: Unmask gts flag, it's stable now (diff)
downloadgentoo-34a0f053e0c9e90c5adf2aa1a4896207479a81d7.tar.gz
gentoo-34a0f053e0c9e90c5adf2aa1a4896207479a81d7.tar.bz2
gentoo-34a0f053e0c9e90c5adf2aa1a4896207479a81d7.zip
gui-apps/kanshi: add 1.5.0
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'gui-apps/kanshi')
-rw-r--r--gui-apps/kanshi/Manifest1
-rw-r--r--gui-apps/kanshi/kanshi-1.5.0.ebuild39
2 files changed, 40 insertions, 0 deletions
diff --git a/gui-apps/kanshi/Manifest b/gui-apps/kanshi/Manifest
index 6a0272f947a2..648cbaa47c5e 100644
--- a/gui-apps/kanshi/Manifest
+++ b/gui-apps/kanshi/Manifest
@@ -1 +1,2 @@
DIST kanshi-1.4.0.tar.gz 22207 BLAKE2B 9d3d1172c77e77049cfa16a279cf77daaeaf8276a76228a3a5f0c141db4a27c2023e2398fc1591747116d4691c48caa323a6d96e2f2b8379e956478dabaff6fc SHA512 bf894865268f706487379b97e7de0df44c2e69aaa1feaca3f4e68f966382f0663ade6a770457803e274ec3afa9fa5661f7509c344a2f71a2b4cd7289277664a2
+DIST kanshi-1.5.0.tar.gz 22330 BLAKE2B 6cccc0a178f2434073ab1438688e678be9abba427d042bfc2325c9b88fc71c183b2ea6d058fdcc3caaab32f9d140263b7daccc1dc812778bdb04f0b4762375be SHA512 a3bb11644382727bd52ff26942ca031246ca4ac006c02b5c6dcd0c21948f7cb8ad3cfc6141c51637ee9150069711b59cc0bdd9bb7bde9583fe9c11b02bb89088
diff --git a/gui-apps/kanshi/kanshi-1.5.0.ebuild b/gui-apps/kanshi/kanshi-1.5.0.ebuild
new file mode 100644
index 000000000000..a3441df26d64
--- /dev/null
+++ b/gui-apps/kanshi/kanshi-1.5.0.ebuild
@@ -0,0 +1,39 @@
+# Copyright 2020-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit meson
+
+DESCRIPTION="dynamic display configuration (autorandr for wayland)"
+HOMEPAGE="https://wayland.emersion.fr/kanshi/ https://sr.ht/~emersion/kanshi/"
+SRC_URI="
+ https://git.sr.ht/~emersion/kanshi/archive/v${PV}.tar.gz
+ -> ${P}.tar.gz
+"
+S=${WORKDIR}/${PN}-v${PV}
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+IUSE="+man varlink"
+
+RDEPEND="
+ dev-libs/wayland
+ varlink? ( dev-libs/libvarlink )
+"
+BDEPEND="
+ ${RDEPEND}
+ virtual/pkgconfig
+ dev-libs/wayland-protocols
+ dev-util/wayland-scanner
+ man? ( >=app-text/scdoc-1.9.3 )
+"
+
+src_configure() {
+ local emesonargs=(
+ $(meson_feature man man-pages)
+ $(meson_feature varlink ipc)
+ )
+ meson_src_configure
+}