summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAisha Tammy <aisha@bsd.ac>2023-02-12 07:52:57 -0500
committerSam James <sam@gentoo.org>2023-02-13 00:39:04 +0000
commit337a7d2d1203369e54b913848ab9a3cedb1dcc6e (patch)
treece7c127ee9beacc9a59cfea5a4afabb7ef42776b /gui-libs
parentgui-apps/wcm: add 0.7.5 (diff)
downloadgentoo-337a7d2d1203369e54b913848ab9a3cedb1dcc6e.tar.gz
gentoo-337a7d2d1203369e54b913848ab9a3cedb1dcc6e.tar.bz2
gentoo-337a7d2d1203369e54b913848ab9a3cedb1dcc6e.zip
gui-libs/wayfire-plugins-extra: add 0.7.5
Closes: https://bugs.gentoo.org/884055 Signed-off-by: Aisha Tammy <aisha@bsd.ac> Closes: https://github.com/gentoo/gentoo/pull/29557 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'gui-libs')
-rw-r--r--gui-libs/wayfire-plugins-extra/Manifest1
-rw-r--r--gui-libs/wayfire-plugins-extra/wayfire-plugins-extra-0.7.5.ebuild36
-rw-r--r--gui-libs/wayfire-plugins-extra/wayfire-plugins-extra-9999.ebuild7
3 files changed, 42 insertions, 2 deletions
diff --git a/gui-libs/wayfire-plugins-extra/Manifest b/gui-libs/wayfire-plugins-extra/Manifest
index 61fc021a3331..7331f5a979d8 100644
--- a/gui-libs/wayfire-plugins-extra/Manifest
+++ b/gui-libs/wayfire-plugins-extra/Manifest
@@ -1 +1,2 @@
DIST wayfire-plugins-extra-0.7.0.tar.xz 74312 BLAKE2B f72d706502499e4d467a4b59e10f66628024be1bab1c5e10c807758869c9b9e4aacbe426c2db0e3faa5ab166f7e4f4d0f1c345e205c6747a16a164745c6f0d74 SHA512 ff25a4685c88ca0129a2372b216166246cab072c2cb4f84eb7bd500db525bf5881bd7e54d0d888473d4aab0e5b33d2ee13eb7f788bb2a524e1e8e0c5efc1a6bd
+DIST wayfire-plugins-extra-0.7.5.tar.xz 75136 BLAKE2B 7ffbb73f09175cc92f09b8a3f0493942741564278f95ff1d80066044b02ce4ceb925919ddb54fc6a37676b925d95ea7f93d09c6b0ccd448c6e9b821106d6e3ea SHA512 9cc816c3c727b0093fd15ef52dea215598b4c49ef96c098f53938c041b3908b30f4dd616be4b459b7382d630a47b36baf845c24de84f35670ba2912711205911
diff --git a/gui-libs/wayfire-plugins-extra/wayfire-plugins-extra-0.7.5.ebuild b/gui-libs/wayfire-plugins-extra/wayfire-plugins-extra-0.7.5.ebuild
new file mode 100644
index 000000000000..b9222da14f98
--- /dev/null
+++ b/gui-libs/wayfire-plugins-extra/wayfire-plugins-extra-0.7.5.ebuild
@@ -0,0 +1,36 @@
+# Copyright 2019-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit meson
+
+DESCRIPTION="extra plugins for wayfire"
+HOMEPAGE="https://github.com/WayfireWM/wayfire-plugins-extra"
+
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/WayfireWM/wayfire-plugins-extra.git"
+else
+ SRC_URI="https://github.com/WayfireWM/wayfire-plugins-extra/releases/download/v${PV}/${P}.tar.xz"
+ KEYWORDS="~amd64 ~arm64 ~x86"
+fi
+
+LICENSE="MIT"
+SLOT="0"
+
+DEPEND="
+ dev-cpp/glibmm:2
+ x11-libs/pixman
+ gnome-base/librsvg
+ >=gui-libs/wlroots-0.16.0:0/16
+ <gui-libs/wlroots-0.17.0:=
+ >=gui-wm/wayfire-0.7.5
+ x11-libs/cairo
+ x11-libs/pixman
+"
+RDEPEND="${DEPEND}"
+BDEPEND="
+ dev-libs/wayland-protocols
+ virtual/pkgconfig
+"
diff --git a/gui-libs/wayfire-plugins-extra/wayfire-plugins-extra-9999.ebuild b/gui-libs/wayfire-plugins-extra/wayfire-plugins-extra-9999.ebuild
index 2558b0e79566..e1eb8908ec68 100644
--- a/gui-libs/wayfire-plugins-extra/wayfire-plugins-extra-9999.ebuild
+++ b/gui-libs/wayfire-plugins-extra/wayfire-plugins-extra-9999.ebuild
@@ -1,7 +1,7 @@
-# Copyright 2019-2021 Gentoo Authors
+# Copyright 2019-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
inherit meson
@@ -21,9 +21,12 @@ SLOT="0"
DEPEND="
dev-cpp/glibmm:2
+ x11-libs/pixman
+ gnome-base/librsvg
~gui-libs/wlroots-9999:=
~gui-wm/wayfire-9999
x11-libs/cairo
+ x11-libs/pixman
"
RDEPEND="${DEPEND}"