summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2018-09-08 10:53:06 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2018-09-08 14:03:48 +0200
commit44068399ad98520a66cafb092af777af8d77a11e (patch)
tree41ec18453e7fe581c9f6020280baaa81ae0a167d /kde-apps/umbrello
parentkde-frameworks: Add KDE Frameworks 5.50.0 (diff)
downloadgentoo-44068399ad98520a66cafb092af777af8d77a11e.tar.gz
gentoo-44068399ad98520a66cafb092af777af8d77a11e.tar.bz2
gentoo-44068399ad98520a66cafb092af777af8d77a11e.zip
kde-apps: Add KDE Applications 18.08.1
Package-Manager: Portage-2.3.49, Repoman-2.3.10
Diffstat (limited to 'kde-apps/umbrello')
-rw-r--r--kde-apps/umbrello/Manifest1
-rw-r--r--kde-apps/umbrello/umbrello-18.08.1.ebuild59
2 files changed, 60 insertions, 0 deletions
diff --git a/kde-apps/umbrello/Manifest b/kde-apps/umbrello/Manifest
index 3d93d539055a..1b81b8400c00 100644
--- a/kde-apps/umbrello/Manifest
+++ b/kde-apps/umbrello/Manifest
@@ -1 +1,2 @@
DIST umbrello-18.04.3.tar.xz 3019628 BLAKE2B 1c2fe22828bd7716a1d9af42c6c4a2de15633933463fc553d981b0585b0a1ba0a03fe0372e5890c6189652d97084301ed36599e13eae0c39a3e25c892de94276 SHA512 fefecbdb4bc82e84f8174b45be63e195bd2fd769fd91acd6300e6eec8e4fe1c573c3043fb052682caa4772db0c3d73149d40b14cf181fe8c9889e652be03be41
+DIST umbrello-18.08.1.tar.xz 3047172 BLAKE2B 395d7b8d2b91952c1f1d202216e09332502dc429ea27b7f55ed847a134f6aefd0387765e5eb50224f30f9cce82ac5a249d7e0bf7c214e7500e11ae2ddfba526f SHA512 614ad45d95bc7f07eec668b5f2a54e6748be31b4bb0fe60fd86fe35df3df73a7ce6e12b867118674dd6961ed167249824344e2fb2155e8a58b1e07074dec8679
diff --git a/kde-apps/umbrello/umbrello-18.08.1.ebuild b/kde-apps/umbrello/umbrello-18.08.1.ebuild
new file mode 100644
index 000000000000..7b9d3d5c2d81
--- /dev/null
+++ b/kde-apps/umbrello/umbrello-18.08.1.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+KDE_HANDBOOK="forceoptional"
+KDE_TEST="forceoptional"
+VIRTUALX_REQUIRED="test"
+inherit kde5
+
+DESCRIPTION="KDE UML Modeller"
+HOMEPAGE="
+ https://www.kde.org/applications/development/umbrello
+ https://umbrello.kde.org
+"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+COMMON_DEPEND="
+ $(add_frameworks_dep karchive)
+ $(add_frameworks_dep kcompletion)
+ $(add_frameworks_dep kconfig)
+ $(add_frameworks_dep kconfigwidgets)
+ $(add_frameworks_dep kcoreaddons)
+ $(add_frameworks_dep kcrash)
+ $(add_frameworks_dep ki18n)
+ $(add_frameworks_dep kiconthemes)
+ $(add_frameworks_dep kio)
+ $(add_frameworks_dep kjobwidgets)
+ $(add_frameworks_dep ktexteditor)
+ $(add_frameworks_dep ktextwidgets)
+ $(add_frameworks_dep kwidgetsaddons)
+ $(add_frameworks_dep kwindowsystem)
+ $(add_frameworks_dep kxmlgui)
+ $(add_qt_dep qtgui)
+ $(add_qt_dep qtprintsupport)
+ $(add_qt_dep qtsvg)
+ $(add_qt_dep qtwebkit)
+ $(add_qt_dep qtwidgets)
+ $(add_qt_dep qtxml)
+ dev-libs/libxml2
+ dev-libs/libxslt
+"
+DEPEND="${COMMON_DEPEND}
+ $(add_frameworks_dep kdelibs4support)
+"
+RDEPEND="${COMMON_DEPEND}
+ !<kde-apps/kde4-l10n-17.07.80
+"
+
+src_configure() {
+ local mycmakeargs=(
+ -DBUILD_KF5=ON
+ -DBUILD_unittests=$(usex test)
+ )
+ use test && mycmakeargs+=( -DCMAKE_DISABLE_FIND_PACKAGE_LLVM=ON )
+
+ kde5_src_configure
+}