summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2021-04-10 20:23:19 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2021-04-10 20:44:11 +0200
commit35bb0618944fb830ee3ba148a4e1a207a346ea5a (patch)
tree565fba4870aeaffbe2a6112f2ce64b7ce128342e /kde-frameworks/kcompletion
parentkde-frameworks/kauth: 5.81.0 version bump (diff)
downloadgentoo-35bb0618944fb830ee3ba148a4e1a207a346ea5a.tar.gz
gentoo-35bb0618944fb830ee3ba148a4e1a207a346ea5a.tar.bz2
gentoo-35bb0618944fb830ee3ba148a4e1a207a346ea5a.zip
kde-frameworks/kcompletion: 5.81.0 version bump
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'kde-frameworks/kcompletion')
-rw-r--r--kde-frameworks/kcompletion/Manifest1
-rw-r--r--kde-frameworks/kcompletion/kcompletion-5.81.0.ebuild33
2 files changed, 34 insertions, 0 deletions
diff --git a/kde-frameworks/kcompletion/Manifest b/kde-frameworks/kcompletion/Manifest
index 3ba32030e64e..c7de3760e0dd 100644
--- a/kde-frameworks/kcompletion/Manifest
+++ b/kde-frameworks/kcompletion/Manifest
@@ -1,2 +1,3 @@
DIST kcompletion-5.77.0.tar.xz 121432 BLAKE2B ca1b4bd3cd2459891dbe44a90fdd48a6f2a14529598f70dfa354e0fc44a840b2f058e7aa43cf030cf0c98b37e001f2cc18a618ad39d5e04dc576ce2b7064a925 SHA512 1dbce42fab7d640083ec936586d89878d2b05c2a341bf6cdd58571b306600b8864d100a84cbfbc4d110bc5c87f6b07fe20859558d9b60e1927a012b98a67b87e
DIST kcompletion-5.80.0.tar.xz 121488 BLAKE2B 8ab2146ab0d76e54cd348297091826d6ecd2622a08595784d4c8fef6d3f4f8d676a49decd0f7a59bfdd9e714eea6be5675003d71652809a82e5d30e54b261885 SHA512 7e0d9764c646f2b68b18d122a20a36c1d67aa4cda80f6c2e7091727ac328ec9c62d9851fcf93f2d80336b7dbe886b7087a5a0c1e3fb9a71c348e4e03c2345897
+DIST kcompletion-5.81.0.tar.xz 121996 BLAKE2B 998397f4c10f965d34d9fa0f44b38dd02b5a276c81a1a917b6604b09479e84e7c1806f57ed2a22fe4bd848bf75a9eb4d7d8f48a4645dea2be551c7a84666047f SHA512 ee12c7bc0deb9e3a3bdd0e138c4ffb7c5d04360581b8cf0e3741d2d7e6a60ae840918c0488d5ee50ec3c01f55963ee2c943e17b24ecec89649100bac7ffb2ce9
diff --git a/kde-frameworks/kcompletion/kcompletion-5.81.0.ebuild b/kde-frameworks/kcompletion/kcompletion-5.81.0.ebuild
new file mode 100644
index 000000000000..a0fa08fde404
--- /dev/null
+++ b/kde-frameworks/kcompletion/kcompletion-5.81.0.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+ECM_DESIGNERPLUGIN="true"
+PVCUT=$(ver_cut 1-2)
+QTMIN=5.15.2
+VIRTUALX_REQUIRED="test"
+inherit ecm kde.org
+
+DESCRIPTION="Framework for common completion tasks such as filename or URL completion"
+LICENSE="LGPL-2+"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86"
+IUSE="nls"
+
+BDEPEND="
+ nls? ( >=dev-qt/linguist-tools-${QTMIN}:5 )
+"
+DEPEND="
+ >=dev-qt/qtgui-${QTMIN}:5
+ >=dev-qt/qtwidgets-${QTMIN}:5
+ =kde-frameworks/kconfig-${PVCUT}*:5
+ =kde-frameworks/kwidgetsaddons-${PVCUT}*:5
+"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ local mycmakeargs=(
+ -DCMAKE_DISABLE_FIND_PACKAGE_PythonModuleGeneration=ON # bug 746866
+ )
+ ecm_src_configure
+}