summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2019-03-09 19:09:42 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2019-03-09 19:47:17 +0100
commit2d191df87083c3e17db0ce6e815f93883be4172c (patch)
tree609994abfb68e69f566162d204dc062c4f851434 /kde-frameworks/kdesu/kdesu-5.56.0.ebuild
parentmedia-libs/gegl: 0.2 with ffmpeg 4 (diff)
downloadgentoo-2d191df87083c3e17db0ce6e815f93883be4172c.tar.gz
gentoo-2d191df87083c3e17db0ce6e815f93883be4172c.tar.bz2
gentoo-2d191df87083c3e17db0ce6e815f93883be4172c.zip
kde-frameworks: Add KDE Frameworks 5.56.0
Package-Manager: Portage-2.3.62, Repoman-2.3.12 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'kde-frameworks/kdesu/kdesu-5.56.0.ebuild')
-rw-r--r--kde-frameworks/kdesu/kdesu-5.56.0.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/kde-frameworks/kdesu/kdesu-5.56.0.ebuild b/kde-frameworks/kdesu/kdesu-5.56.0.ebuild
new file mode 100644
index 000000000000..19af92e08b02
--- /dev/null
+++ b/kde-frameworks/kdesu/kdesu-5.56.0.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+KDE_TEST="true"
+inherit kde5
+
+DESCRIPTION="Framework to handle super user actions"
+LICENSE="LGPL-2"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+IUSE="X"
+
+RDEPEND="
+ $(add_frameworks_dep kconfig)
+ $(add_frameworks_dep kcoreaddons)
+ $(add_frameworks_dep ki18n)
+ $(add_frameworks_dep kpty)
+ $(add_frameworks_dep kservice)
+ X? ( x11-libs/libX11 )
+"
+DEPEND="${RDEPEND}
+ X? ( x11-base/xorg-proto )
+"
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake-utils_use_find_package X X11)
+ )
+
+ kde5_src_configure
+}