summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2019-06-08 19:41:52 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2019-06-08 21:28:07 +0200
commit960b53f1cd249091348514ca4d444eb0ba967cfd (patch)
tree44882776b9db1882d72f47230991d1128a38b2d1 /kde-frameworks/kwallet
parentmedia-gfx/kxstitch: 2.2.0 version bump (diff)
downloadgentoo-960b53f1cd249091348514ca4d444eb0ba967cfd.tar.gz
gentoo-960b53f1cd249091348514ca4d444eb0ba967cfd.tar.bz2
gentoo-960b53f1cd249091348514ca4d444eb0ba967cfd.zip
kde-frameworks: Add KDE Frameworks 5.59.0
Package-Manager: Portage-2.3.67, Repoman-2.3.14 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'kde-frameworks/kwallet')
-rw-r--r--kde-frameworks/kwallet/Manifest1
-rw-r--r--kde-frameworks/kwallet/kwallet-5.59.0.ebuild57
2 files changed, 58 insertions, 0 deletions
diff --git a/kde-frameworks/kwallet/Manifest b/kde-frameworks/kwallet/Manifest
index a0f4c71b3c65..41d957abd7e8 100644
--- a/kde-frameworks/kwallet/Manifest
+++ b/kde-frameworks/kwallet/Manifest
@@ -1,2 +1,3 @@
DIST kwallet-5.57.0.tar.xz 308036 BLAKE2B d2da2e0bf99b455946973dd7ec00008affdf31abd03d5eae0509383c2309ce3d5d86ec65d8a9757d15ea04269525296ce9ffc505ba3f669a012e33463465fac3 SHA512 7a3809d6563dbd46c1a8de6f9fe7f1665ede884430ac83782cfed4e02f4fc9ecd275293f8c09463a42054d071a545308c8353ddb447e8b0acab5a9c6e47966f2
DIST kwallet-5.58.0.tar.xz 307348 BLAKE2B 3b16f63d9f5d38d26f8a45e87860f639fea0aeb211a4b312b6b7ceb7835c605f189590d39f295314149cad3fa013ec23d3478f31f77d79d9e1ee072ff0549f31 SHA512 7145510aa75c179a7c283f26c6d479d753a435a14e423881793ef061b3dc6144c4126365719118b3fdd5d36560a706b36cb003d829d3c469f6f0844351ddc4f4
+DIST kwallet-5.59.0.tar.xz 306796 BLAKE2B 505f623c4f571b98dc75fe8af84d4bab3cc58c0709b09a8212117c54510d162ef29763a1f04ead0c04671f243c5a237cd7169859b9d41e2e114581af0d88cd8c SHA512 5f7094c914ad37c634758826d878f5cc204e853722d2555e20ff4f8fb5471311d1ad43d3aad5ca05df0e7b60b6febc243f4205d9c68919d62cbe2f0e9d4f2d04
diff --git a/kde-frameworks/kwallet/kwallet-5.59.0.ebuild b/kde-frameworks/kwallet/kwallet-5.59.0.ebuild
new file mode 100644
index 000000000000..817d760a27ff
--- /dev/null
+++ b/kde-frameworks/kwallet/kwallet-5.59.0.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit kde5
+
+DESCRIPTION="Framework providing desktop-wide storage for passwords"
+LICENSE="LGPL-2+"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+IUSE="gpg +man"
+
+BDEPEND="
+ man? ( $(add_frameworks_dep kdoctools) )
+"
+DEPEND="
+ $(add_frameworks_dep kconfig)
+ $(add_frameworks_dep kconfigwidgets)
+ $(add_frameworks_dep kcoreaddons)
+ $(add_frameworks_dep kdbusaddons)
+ $(add_frameworks_dep ki18n)
+ $(add_frameworks_dep kiconthemes)
+ $(add_frameworks_dep knotifications)
+ $(add_frameworks_dep kservice)
+ $(add_frameworks_dep kwidgetsaddons)
+ $(add_frameworks_dep kwindowsystem)
+ $(add_qt_dep qtdbus)
+ $(add_qt_dep qtgui)
+ $(add_qt_dep qtwidgets)
+ dev-libs/libgcrypt:0=
+ gpg? ( >=app-crypt/gpgme-1.7.1[cxx,qt5] )
+"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake-utils_use_find_package gpg Gpgmepp)
+ $(cmake-utils_use_find_package man KF5DocTools)
+ )
+
+ kde5_src_configure
+}
+
+pkg_postinst() {
+ if ! has_version "kde-plasma/kwallet-pam" || ! has_version "kde-apps/kwalletmanager:5" ; then
+ elog
+ elog "Install kde-plasma/kwallet-pam for auto-unlocking after account login."
+ elog "Install kde-apps/kwalletmanager:5 to manage your kwallet."
+ elog
+ fi
+ if has_version "kde-apps/kwalletd"; then
+ elog "Starting with 5.34.0-r1, ${PN} is able to serve applications"
+ elog "that still require old kwalletd4. After migration has finished,"
+ elog "kde-apps/kwalletd can be removed."
+ fi
+ elog "For more information, read https://wiki.gentoo.org/wiki/KDE#KWallet"
+}