summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2021-02-13 14:00:24 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2021-02-13 14:03:48 +0100
commit5989e0c3e84ab753a04da8251ccff61bba17c5f3 (patch)
tree696b371aef25d39b3bb9cba117e806ee2148c0da /kde-frameworks/sonnet
parentkde-frameworks/solid: 5.79.0 version bump (diff)
downloadgentoo-5989e0c3e84ab753a04da8251ccff61bba17c5f3.tar.gz
gentoo-5989e0c3e84ab753a04da8251ccff61bba17c5f3.tar.bz2
gentoo-5989e0c3e84ab753a04da8251ccff61bba17c5f3.zip
kde-frameworks/sonnet: 5.79.0 version bump
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'kde-frameworks/sonnet')
-rw-r--r--kde-frameworks/sonnet/Manifest1
-rw-r--r--kde-frameworks/sonnet/sonnet-5.79.0.ebuild43
2 files changed, 44 insertions, 0 deletions
diff --git a/kde-frameworks/sonnet/Manifest b/kde-frameworks/sonnet/Manifest
index 659b85fa2670..d7511d534cdc 100644
--- a/kde-frameworks/sonnet/Manifest
+++ b/kde-frameworks/sonnet/Manifest
@@ -1,2 +1,3 @@
DIST sonnet-5.77.0.tar.xz 294360 BLAKE2B e0131044b8ea1e5dc4c7508bc661b5ce61c95de148bd95ae1ca68d0b04f43db64ef4c2e330466bed7de8ccbc2e8bd31609d13995c75edaa41ad9c5407131499d SHA512 f453edf4e4becb2e4433ace3a2251f7261d4dfa549a70877fd46c37432fe6e117e542f4db1331893bcc4ac22ed99bc620e5facf03cf783a64a19ca76f7783df0
DIST sonnet-5.78.0.tar.xz 294556 BLAKE2B 739fc44a3c729755f940e1036a4b743ed967a20bf585e9bd3f6aa57aa96090ff67bf21c89144adab2a5a72af59d8e894f95621c7e2e760ce3f44efc12d5148a2 SHA512 558e8a1d97053af5524c29f4fd677dfef3a59859e03f285cdcc02a9032cd09dc92da4ff253f3d7dd7d0d554d2574e36884984a14da7b5c09be7aad84a1950b59
+DIST sonnet-5.79.0.tar.xz 294672 BLAKE2B b5636a5e400bb7d0ce9ee616461db2aede6aa75d52e0e8b6cefc0fcd6985ed614dd43d1447a0bd90382849008201b92a4d56be50f3a99c02d73b8a4138ffffdd SHA512 dfefe2a96ea2b700421086fe769a8e25447f4bfd6be19517ade1f7743feb5478c93dcf9946f843598f31a92ac0061cf740a39b7978d97b24f754f9b1f7abd920
diff --git a/kde-frameworks/sonnet/sonnet-5.79.0.ebuild b/kde-frameworks/sonnet/sonnet-5.79.0.ebuild
new file mode 100644
index 000000000000..83a586a6c920
--- /dev/null
+++ b/kde-frameworks/sonnet/sonnet-5.79.0.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+ECM_DESIGNERPLUGIN="true"
+QTMIN=5.15.2
+VIRTUALX_REQUIRED="test"
+inherit ecm kde.org
+
+DESCRIPTION="Framework for providing spell-checking through abstraction of popular backends"
+LICENSE="LGPL-2+ LGPL-2.1+"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86"
+IUSE="aspell +hunspell nls"
+
+BDEPEND="
+ nls? ( >=dev-qt/linguist-tools-${QTMIN}:5 )
+"
+DEPEND="
+ >=dev-qt/qtgui-${QTMIN}:5
+ >=dev-qt/qtwidgets-${QTMIN}:5
+ aspell? ( app-text/aspell )
+ hunspell? ( app-text/hunspell:= )
+"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake_use_find_package aspell ASPELL)
+ $(cmake_use_find_package hunspell HUNSPELL)
+ )
+
+ ecm_src_configure
+}
+
+src_test() {
+ # bugs: 680032
+ local myctestargs=(
+ -E "(sonnet-test_settings|sonnet-test_highlighter)"
+ )
+
+ ecm_src_test
+}