summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohannes Huber <johu@gentoo.org>2017-10-12 19:42:04 +0200
committerJohannes Huber <johu@gentoo.org>2017-10-12 19:45:44 +0200
commit4fe359a11b3f9908a7cf476ff8d56c21cbc7bf2f (patch)
tree2f6c33c08a4c706f7effa09bb082127b56563455 /kde-plasma/ksshaskpass
parentkde-frameworks/qqc2-desktop-style: New package (diff)
downloadgentoo-4fe359a11b3f9908a7cf476ff8d56c21cbc7bf2f.tar.gz
gentoo-4fe359a11b3f9908a7cf476ff8d56c21cbc7bf2f.tar.bz2
gentoo-4fe359a11b3f9908a7cf476ff8d56c21cbc7bf2f.zip
kde-plasma: Version bump KDE Plasma 5.11.0
Package-Manager: Portage-2.3.11, Repoman-2.3.3
Diffstat (limited to 'kde-plasma/ksshaskpass')
-rw-r--r--kde-plasma/ksshaskpass/Manifest1
-rw-r--r--kde-plasma/ksshaskpass/ksshaskpass-5.11.0.ebuild49
2 files changed, 50 insertions, 0 deletions
diff --git a/kde-plasma/ksshaskpass/Manifest b/kde-plasma/ksshaskpass/Manifest
index a538995e796c..cf6edeb427ca 100644
--- a/kde-plasma/ksshaskpass/Manifest
+++ b/kde-plasma/ksshaskpass/Manifest
@@ -1 +1,2 @@
DIST ksshaskpass-5.10.5.tar.xz 20316 SHA256 5c4a166ca5d6a9d99f91c8640121f02db2002a1480b299e47995533651508ca4 SHA512 bf55ea1b5b79b43d1720c32bbd569aabdde1516d818de3ab567de95736e967327a58055e1e4f73c895c90b35b8149ecc4e736c9b067a05a13852ae4579d0cd6b WHIRLPOOL 16ae562fc0016d40b73aa7924226af816f2ec38b649eb09d3e70239dcfbdd41e435a3646fa292f64d1224f1a5d1ea9fdf5849f991cafc052f35c993d820f3021
+DIST ksshaskpass-5.11.0.tar.xz 20632 SHA256 e01a97c937e275db5695b1ab0066cdb8bfda5dbe2a03222a9561ab25ffdeccda SHA512 8cfd7e1ea77dabaedabf321a520829496a1f550557211142417fc5c6906dec4d7877b2b5b41e82ffc4fda591a27d16ecd6a1381e9222afb520b7061c984a0a5f WHIRLPOOL 96aec23ff9362bec1e3a29d25a8632436f963568ff763a4b9640e76881c29a62507e8cfaf082b09162a05efff6d3796aba8180ee8c650d9427f690066dc88e07
diff --git a/kde-plasma/ksshaskpass/ksshaskpass-5.11.0.ebuild b/kde-plasma/ksshaskpass/ksshaskpass-5.11.0.ebuild
new file mode 100644
index 000000000000..468b1b597c06
--- /dev/null
+++ b/kde-plasma/ksshaskpass/ksshaskpass-5.11.0.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit kde5
+
+DESCRIPTION="KDE implementation of ssh-askpass with Kwallet integration"
+HOMEPAGE="https://projects.kde.org/projects/kde/workspace/ksshaskpass"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE=""
+
+DEPEND="
+ $(add_frameworks_dep kcoreaddons)
+ $(add_frameworks_dep ki18n)
+ $(add_frameworks_dep kwallet)
+ $(add_frameworks_dep kwidgetsaddons)
+ $(add_qt_dep qtwidgets)
+"
+RDEPEND="
+ ${DEPEND}
+ !kde-plasma/ksshaskpass:4
+"
+
+src_install() {
+ kde5_src_install
+
+ insinto /etc/plasma/startup
+ doins "${FILESDIR}/05-ksshaskpass.sh"
+}
+
+pkg_postinst() {
+ kde5_pkg_postinst
+
+ elog ""
+ elog "In order to have ssh-agent start at kde startup,"
+ elog "edit /etc/plasma/startup/10-agent-startup.sh and uncomment"
+ elog "the lines enabling ssh-agent."
+ elog
+ elog "If you do so, do not forget to uncomment the respective"
+ elog "lines in /etc/plasma/shutdown/10-agent-shutdown.sh to"
+ elog "properly kill the agent when the session ends."
+ elog
+ elog "${PN} has been installed as your default askpass application"
+ elog "for Plasma 5 sessions."
+ elog "If that's not desired, select the one you want to use in"
+ elog "/etc/plasma/startup/05-ksshaskpass.sh"
+ elog ""
+}