summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2024-06-17 23:05:57 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2024-06-18 16:51:12 +0200
commit004682ffb3537fc95208543be040a6d0c4866fc7 (patch)
treec54e025bc68081688c1cd5dbb013da004d512e0f /kde-plasma/kwallet-pam
parentkde-plasma/ksystemstats: 6.1.0 version bump (diff)
downloadgentoo-004682ffb3537fc95208543be040a6d0c4866fc7.tar.gz
gentoo-004682ffb3537fc95208543be040a6d0c4866fc7.tar.bz2
gentoo-004682ffb3537fc95208543be040a6d0c4866fc7.zip
kde-plasma/kwallet-pam: 6.1.0 version bump
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'kde-plasma/kwallet-pam')
-rw-r--r--kde-plasma/kwallet-pam/Manifest1
-rw-r--r--kde-plasma/kwallet-pam/kwallet-pam-6.1.0.ebuild36
2 files changed, 37 insertions, 0 deletions
diff --git a/kde-plasma/kwallet-pam/Manifest b/kde-plasma/kwallet-pam/Manifest
index ac28f5a31a7c..e3672c856414 100644
--- a/kde-plasma/kwallet-pam/Manifest
+++ b/kde-plasma/kwallet-pam/Manifest
@@ -1,2 +1,3 @@
DIST kwallet-pam-5.27.11.tar.xz 22948 BLAKE2B 1c0cf86bb7e57696e44ac34a4392d1f81a6ade8fbaef6c61eefc79df39890aa1799ddbb39ec59fbde3ea4536c1113c1147b28bcdfc898049e847af99b107267b SHA512 b52177df434bf71214874a2410637240bb5a23f0fd06d41f3b62630d90e5262a231012c4f11119f96c151bb222e73652e5e8506ccc26c7cc451090f3bd156b6a
DIST kwallet-pam-6.0.90.tar.xz 23148 BLAKE2B 4c1e6a6adb4347002fbe90710d1997f7f3c48e5e8c937fbffab43600fbe028300d386d31a187958857d72e10d121cee1d09d242d4b554a0c0c65505bd4b67660 SHA512 a5a8f5bc3637454dc0b4f1e37114c11ceaa0f4bd02d5e0d1f9e8f4a9e8c0af1bf0874a7a7f1eb8d846cc211361d347abf51283977cc78d087789d3def2d8c81a
+DIST kwallet-pam-6.1.0.tar.xz 23064 BLAKE2B a98ebb6d21383a9ef3a7d2680328645110f49edc6f317b5888300722a15224e74219dc8c75439e80ad6f1482ea862d479a27a20187b7cb95fc6f9ac5ef7cc2f9 SHA512 71b3a79103136c4fd04228e437e8f07a176abf1666ebccc7936097b4f97a363fef71427998e0680d68aede7d3e2182dea049a73e7122c4b198fe19f5e5f06717
diff --git a/kde-plasma/kwallet-pam/kwallet-pam-6.1.0.ebuild b/kde-plasma/kwallet-pam/kwallet-pam-6.1.0.ebuild
new file mode 100644
index 000000000000..ea7774ffa79f
--- /dev/null
+++ b/kde-plasma/kwallet-pam/kwallet-pam-6.1.0.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+KFMIN=6.3.0
+inherit ecm plasma.kde.org
+
+DESCRIPTION="PAM module to not enter KWallet password again after login"
+
+LICENSE="LGPL-2.1"
+SLOT="6"
+KEYWORDS="~amd64"
+IUSE=""
+
+DEPEND="
+ dev-libs/libgcrypt:0=
+ >=kde-frameworks/kwallet-${KFMIN}:6
+ sys-libs/pam
+"
+RDEPEND="${DEPEND}
+ net-misc/socat
+"
+
+src_configure() {
+ local mycmakeargs=(
+ -DCMAKE_INSTALL_LIBDIR="/$(get_libdir)"
+ )
+ ecm_src_configure
+}
+
+pkg_postinst() {
+ ecm_pkg_postinst
+ elog "This package enables auto-unlocking of kde-frameworks/kwallet:6."
+ elog "See also: https://wiki.gentoo.org/wiki/KDE#KWallet_auto-unlocking"
+}