summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2024-10-08 17:26:50 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2024-10-08 17:35:22 +0200
commit797abc1713a15766145781457947fad5e8999383 (patch)
tree139b05dd7b963fbf04552d2f5ce243f34f5b284e /kde-plasma/print-manager
parentkde-plasma/powerdevil: 6.2.0 version bump (diff)
downloadgentoo-797abc1713a15766145781457947fad5e8999383.tar.gz
gentoo-797abc1713a15766145781457947fad5e8999383.tar.bz2
gentoo-797abc1713a15766145781457947fad5e8999383.zip
kde-plasma/print-manager: 6.2.0 version bump
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'kde-plasma/print-manager')
-rw-r--r--kde-plasma/print-manager/Manifest1
-rw-r--r--kde-plasma/print-manager/print-manager-6.2.0.ebuild68
2 files changed, 69 insertions, 0 deletions
diff --git a/kde-plasma/print-manager/Manifest b/kde-plasma/print-manager/Manifest
index 56071c3cd61b..23f26b4a3601 100644
--- a/kde-plasma/print-manager/Manifest
+++ b/kde-plasma/print-manager/Manifest
@@ -1 +1,2 @@
DIST print-manager-6.1.5.tar.xz 371292 BLAKE2B 140f63488f381dde409d673fac692197163efa200866311c0bb346e9dd57a57780dc3dd1a47fb950793b6bd5512e3d82ed2bae47e9476e1ece20e7dc0079b928 SHA512 0c83c5fdbd73ad47cde287ed2f3d89c735a44cce4c2d753201258183491bc9612091802bf639445a775f0b2ed7f485d7bc94d98904fb40ca11e23affbd046ceb
+DIST print-manager-6.2.0.tar.xz 374740 BLAKE2B 9ea90d1497f4da30168befeb0bd7aa76964ff09fb90f9827e883cc62728ae6ff8ed2d2cd8721aa7ff91f2229ea822ae1fe2d66e35435fd7da2c6d5d9f278a395 SHA512 13b5029f1041a09eb6348a6ad4ae9cb8102794d759970d10f31b80141d2f1ee6e6b2a1dd52dd09ba3e9114630b7c8373d279747658a4fd2eaf583aa332f3d485
diff --git a/kde-plasma/print-manager/print-manager-6.2.0.ebuild b/kde-plasma/print-manager/print-manager-6.2.0.ebuild
new file mode 100644
index 000000000000..62e8df621130
--- /dev/null
+++ b/kde-plasma/print-manager/print-manager-6.2.0.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+KFMIN=6.6.0
+PVCUT=$(ver_cut 1-3)
+QTMIN=6.7.2
+inherit ecm plasma.kde.org
+
+DESCRIPTION="Manage CUPS print jobs and printers in Plasma"
+
+LICENSE="GPL-2" # TODO: CHECK
+SLOT="6"
+KEYWORDS="~amd64 ~arm64 ~ppc64 ~riscv ~x86"
+IUSE="+gtk"
+
+DEPEND="
+ >=dev-qt/qt5compat-${QTMIN}:6
+ >=dev-qt/qtbase-${QTMIN}:6[dbus,gui,network,widgets]
+ >=dev-qt/qtdeclarative-${QTMIN}:6
+ >=kde-frameworks/kcmutils-${KFMIN}:6
+ >=kde-frameworks/kconfig-${KFMIN}:6
+ >=kde-frameworks/kconfigwidgets-${KFMIN}:6
+ >=kde-frameworks/kcoreaddons-${KFMIN}:6
+ >=kde-frameworks/kdbusaddons-${KFMIN}:6
+ >=kde-frameworks/ki18n-${KFMIN}:6
+ >=kde-frameworks/kiconthemes-${KFMIN}:6
+ >=kde-frameworks/kio-${KFMIN}:6
+ >=kde-frameworks/kirigami-${KFMIN}:6
+ >=kde-frameworks/knotifications-${KFMIN}:6
+ >=kde-frameworks/kservice-${KFMIN}:6
+ >=kde-frameworks/kwidgetsaddons-${KFMIN}:6
+ >=kde-frameworks/kwindowsystem-${KFMIN}:6
+ >=kde-plasma/libplasma-${PVCUT}:6
+ >=net-print/cups-2.4
+"
+RDEPEND="${DEPEND}
+ !<kde-plasma/print-manager-23.08.5-r100:5
+ >=kde-frameworks/kdeclarative-${KFMIN}:6
+ gtk? ( app-admin/system-config-printer )
+"
+BDEPEND=">=kde-frameworks/kcmutils-${KFMIN}:6"
+
+src_configure() {
+ local mycmakeargs=(
+ -DCMAKE_DISABLE_FIND_PACKAGE_PackageKitQt6=ON # not packaged
+ )
+
+ ecm_src_configure
+}
+
+pkg_postinst() {
+ ecm_pkg_postinst
+
+ if [[ -z "${REPLACING_VERSIONS}" ]] && ! use gtk ; then
+ ewarn "By switching off \"gtk\" USE flag, you have chosen to do without"
+ ewarn "an important, though optional, runtime dependency:"
+ ewarn
+ ewarn "app-admin/system-config-printer"
+ ewarn
+ ewarn "${PN} will work nevertheless, but is going to be less comfortable"
+ ewarn "and will show the following error status during runtime:"
+ ewarn
+ ewarn "\"Failed to group devices: 'The name org.fedoraproject.Config.Printing"
+ ewarn "was not provided by any .service files'\""
+ fi
+}