summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAkinori Hattori <hattya@gentoo.org>2024-05-12 15:17:26 +0900
committerAkinori Hattori <hattya@gentoo.org>2024-05-12 15:17:26 +0900
commit79a7379439af433d1184e2b8be1c1b523e7e93cd (patch)
tree9d4a4a47e62168cfa443ae0babe29b0db22d98a0 /mail-filter
parentapp-editors/shed: drop old (diff)
downloadgentoo-79a7379439af433d1184e2b8be1c1b523e7e93cd.tar.gz
gentoo-79a7379439af433d1184e2b8be1c1b523e7e93cd.tar.bz2
gentoo-79a7379439af433d1184e2b8be1c1b523e7e93cd.zip
mail-filter/scmail: fix parallel build
Closes: https://bugs.gentoo.org/882513 Closes: https://bugs.gentoo.org/884759 Signed-off-by: Akinori Hattori <hattya@gentoo.org>
Diffstat (limited to 'mail-filter')
-rw-r--r--mail-filter/scmail/files/scmail-parallel-make.patch19
-rw-r--r--mail-filter/scmail/scmail-1.3.ebuild7
2 files changed, 21 insertions, 5 deletions
diff --git a/mail-filter/scmail/files/scmail-parallel-make.patch b/mail-filter/scmail/files/scmail-parallel-make.patch
new file mode 100644
index 000000000000..7e35dd6f34d2
--- /dev/null
+++ b/mail-filter/scmail/files/scmail-parallel-make.patch
@@ -0,0 +1,19 @@
+--- a/Makefile
++++ b/Makefile
+@@ -24,7 +24,7 @@
+
+ all: check-gauche $(TARGET) update-doc
+
+-update-doc:
++update-doc: dot.scmail/deliver-rules.sample
+ cd doc && make
+
+ check-gauche:
+--- a/tests/Makefile
++++ b/tests/Makefile
+@@ -41,3 +41,5 @@
+ @rm -f $(TARGET)
+ @rm -rf Mail Maildir test.*
+
++.NOTPARALLEL:
++
diff --git a/mail-filter/scmail/scmail-1.3.ebuild b/mail-filter/scmail/scmail-1.3.ebuild
index 25809d282452..6a36d68334e5 100644
--- a/mail-filter/scmail/scmail-1.3.ebuild
+++ b/mail-filter/scmail/scmail-1.3.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI="8"
@@ -21,6 +21,7 @@ PATCHES=(
"${FILESDIR}"/${PN}-doc-encoding.patch
"${FILESDIR}"/${PN}-gauche-0.9.patch
"${FILESDIR}"/${PN}-gauche-0.9.10.patch
+ "${FILESDIR}"/${PN}-parallel-make.patch
"${FILESDIR}"/${PN}-undefined-reference.patch
)
HTML_DOCS=( doc/{${PN},scbayes}{,-ja}.html )
@@ -41,7 +42,3 @@ src_install() {
install
einstalldocs
}
-
-src_test() {
- emake -j1 -s check
-}