summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /media-gfx/asymptote/files
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'media-gfx/asymptote/files')
-rw-r--r--media-gfx/asymptote/files/64asymptote-gentoo.el9
-rw-r--r--media-gfx/asymptote/files/asy-ftd.vim2
-rw-r--r--media-gfx/asymptote/files/asymptote-2.21-configure-ac.patch32
-rw-r--r--media-gfx/asymptote/files/asymptote-2.21-info.patch13
-rw-r--r--media-gfx/asymptote/files/asymptote-2.21-xdg-utils.patch22
-rw-r--r--media-gfx/asymptote/files/asymptote-2.27-configure-ac.patch32
-rw-r--r--media-gfx/asymptote/files/asymptote-2.27-info.patch13
-rw-r--r--media-gfx/asymptote/files/asymptote-2.27-xdg-utils.patch23
-rw-r--r--media-gfx/asymptote/files/asymptote-2.32-configure-ac.patch32
-rw-r--r--media-gfx/asymptote/files/asymptote-2.32-ghostscript-9.15.patch24
-rw-r--r--media-gfx/asymptote/files/asymptote-2.32-info.patch13
-rw-r--r--media-gfx/asymptote/files/asymptote-2.32-xdg-utils.patch23
12 files changed, 238 insertions, 0 deletions
diff --git a/media-gfx/asymptote/files/64asymptote-gentoo.el b/media-gfx/asymptote/files/64asymptote-gentoo.el
new file mode 100644
index 000000000000..57cd48d04a64
--- /dev/null
+++ b/media-gfx/asymptote/files/64asymptote-gentoo.el
@@ -0,0 +1,9 @@
+
+;; site-init for media-gfx/asymptote
+
+(add-to-list 'load-path "@SITELISP@")
+
+(autoload 'asy-mode "asy-mode" "Asymptote major mode." t)
+(autoload 'lasy-mode "asy-mode" "Hybrid Asymptote/Latex major mode." t)
+(autoload 'asy-insinuate-latex "asy-mode" "Asymptote insinuate LaTeX." t)
+(add-to-list 'auto-mode-alist '("\\.asy$" . asy-mode))
diff --git a/media-gfx/asymptote/files/asy-ftd.vim b/media-gfx/asymptote/files/asy-ftd.vim
new file mode 100644
index 000000000000..0f5e3957900a
--- /dev/null
+++ b/media-gfx/asymptote/files/asy-ftd.vim
@@ -0,0 +1,2 @@
+au BufNewFile,BufRead *.asy setf asy
+filetype plugin on
diff --git a/media-gfx/asymptote/files/asymptote-2.21-configure-ac.patch b/media-gfx/asymptote/files/asymptote-2.21-configure-ac.patch
new file mode 100644
index 000000000000..e65c18dc455b
--- /dev/null
+++ b/media-gfx/asymptote/files/asymptote-2.21-configure-ac.patch
@@ -0,0 +1,32 @@
+Index: asymptote-2.21/configure.ac
+===================================================================
+--- asymptote-2.21.orig/configure.ac
++++ asymptote-2.21/configure.ac
+@@ -154,7 +154,7 @@ if test "x$ac_cv_use_gc" != "xno" ; then
+ fi
+ CPPFLAGS_SAVE=$CPPFLAGS
+ CPPFLAGS=$CPPFLAGS" $INCL"
+- AC_CHECK_HEADER(gc.h,
++ AC_CHECK_HEADER([gc/gc.h],
+ AC_CHECK_LIB([gc],[GC_malloc],[
+ LIBS=$LIBS"-lgc "
+ AC_MSG_NOTICE([enabling system $GCNAME])],[
+@@ -227,7 +227,17 @@ AC_MSG_ERROR([*** Please install libm on
+ AC_CHECK_LIB([z], [deflate],,
+ AC_MSG_ERROR([*** Please install libz on your system ***]))
+ AX_PTHREAD
+-AC_CHECK_LIB([sigsegv], [stackoverflow_install_handler])
++
++AC_ARG_WITH(sigsegv,
++ [ --with-sigsegv use libsigsegv],
++ [with_sigsegv=$withval],
++ [with_sigsegv="no"])
++if test "$with_sigsegv" = "yes"; then
++AC_CHECK_HEADER([sigsegv.h],
++ AC_CHECK_LIB([sigsegv], [stackoverflow_install_handler]),
++ AC_MSG_NOTICE([*** Header file sigsegv.h not found ***]))
++fi
++
+ AC_CHECK_LIB([rt], [sched_yield])
+
+ AC_ARG_ENABLE(readline,
diff --git a/media-gfx/asymptote/files/asymptote-2.21-info.patch b/media-gfx/asymptote/files/asymptote-2.21-info.patch
new file mode 100644
index 000000000000..cb5f43671add
--- /dev/null
+++ b/media-gfx/asymptote/files/asymptote-2.21-info.patch
@@ -0,0 +1,13 @@
+Index: asymptote-2.21/doc/asymptote.texi
+===================================================================
+--- asymptote-2.21.orig/doc/asymptote.texi
++++ asymptote-2.21/doc/asymptote.texi
+@@ -21,7 +21,7 @@ file LICENSE in the top-level source dir
+
+ @dircategory Languages
+ @direntry
+-* asymptote: (asymptote/asymptote). Vector graphics language.
++* asymptote: (asymptote). Vector graphics language.
+ @end direntry
+
+ @titlepage
diff --git a/media-gfx/asymptote/files/asymptote-2.21-xdg-utils.patch b/media-gfx/asymptote/files/asymptote-2.21-xdg-utils.patch
new file mode 100644
index 000000000000..5fb54d80f785
--- /dev/null
+++ b/media-gfx/asymptote/files/asymptote-2.21-xdg-utils.patch
@@ -0,0 +1,22 @@
+Index: asymptote-2.21/settings.cc
+===================================================================
+--- asymptote-2.21.orig/settings.cc
++++ asymptote-2.21/settings.cc
+@@ -90,14 +90,14 @@ bool msdos=false;
+ string HOME="HOME";
+ string docdir=ASYMPTOTE_DOCDIR;
+ const char pathSeparator=':';
+-string defaultPSViewer="gv";
++string defaultPSViewer="xdg-open";
+ #ifdef __APPLE__
+ string defaultPDFViewer="open";
+ #else
+-string defaultPDFViewer="acroread";
++string defaultPDFViewer="xdg-open";
+ #endif
+ string defaultGhostscript="gs";
+-string defaultDisplay="display";
++string defaultDisplay="xdg-open";
+ string defaultAnimate="animate";
+ void queryRegistry() {}
+ const string dirsep="/";
diff --git a/media-gfx/asymptote/files/asymptote-2.27-configure-ac.patch b/media-gfx/asymptote/files/asymptote-2.27-configure-ac.patch
new file mode 100644
index 000000000000..df02ad92fcb3
--- /dev/null
+++ b/media-gfx/asymptote/files/asymptote-2.27-configure-ac.patch
@@ -0,0 +1,32 @@
+Index: asymptote-2.27/configure.ac
+===================================================================
+--- asymptote-2.27.orig/configure.ac
++++ asymptote-2.27/configure.ac
+@@ -155,7 +155,7 @@ if test "x$ac_cv_use_gc" != "xno" ; then
+ fi
+ CPPFLAGS_SAVE=$CPPFLAGS
+ CPPFLAGS=$CPPFLAGS" $INCL"
+- AC_CHECK_HEADER(gc.h,
++ AC_CHECK_HEADER([gc/gc.h],
+ AC_CHECK_LIB([gc],[GC_malloc],[
+ LIBS=$LIBS"-lgc "
+ AC_MSG_NOTICE([enabling system $GCNAME])],[
+@@ -229,7 +229,17 @@ AC_MSG_ERROR([*** Please install libm on
+ AC_CHECK_LIB([z], [deflate],,
+ AC_MSG_ERROR([*** Please install libz or zlib-devel on your system ***]))
+ AX_PTHREAD
+-AC_CHECK_LIB([sigsegv], [stackoverflow_install_handler])
++
++AC_ARG_WITH(sigsegv,
++ [ --with-sigsegv use libsigsegv],
++ [with_sigsegv=$withval],
++ [with_sigsegv="no"])
++if test "$with_sigsegv" = "yes"; then
++AC_CHECK_HEADER([sigsegv.h],
++ AC_CHECK_LIB([sigsegv], [stackoverflow_install_handler]),
++ AC_MSG_NOTICE([*** Header file sigsegv.h not found ***]))
++fi
++
+ AC_CHECK_LIB([rt], [sched_yield])
+
+ AC_ARG_ENABLE(readline,
diff --git a/media-gfx/asymptote/files/asymptote-2.27-info.patch b/media-gfx/asymptote/files/asymptote-2.27-info.patch
new file mode 100644
index 000000000000..a64c8eb467ac
--- /dev/null
+++ b/media-gfx/asymptote/files/asymptote-2.27-info.patch
@@ -0,0 +1,13 @@
+Index: asymptote-2.27/doc/asymptote.texi
+===================================================================
+--- asymptote-2.27.orig/doc/asymptote.texi
++++ asymptote-2.27/doc/asymptote.texi
+@@ -21,7 +21,7 @@ file LICENSE in the top-level source dir
+
+ @dircategory Languages
+ @direntry
+-* asymptote: (asymptote/asymptote). Vector graphics language.
++* asymptote: (asymptote). Vector graphics language.
+ @end direntry
+
+ @titlepage
diff --git a/media-gfx/asymptote/files/asymptote-2.27-xdg-utils.patch b/media-gfx/asymptote/files/asymptote-2.27-xdg-utils.patch
new file mode 100644
index 000000000000..1be4a4b89435
--- /dev/null
+++ b/media-gfx/asymptote/files/asymptote-2.27-xdg-utils.patch
@@ -0,0 +1,23 @@
+Index: asymptote-2.27/settings.cc
+===================================================================
+--- asymptote-2.27.orig/settings.cc
++++ asymptote-2.27/settings.cc
+@@ -90,15 +90,15 @@ bool msdos=false;
+ string HOME="HOME";
+ string docdir=ASYMPTOTE_DOCDIR;
+ const char pathSeparator=':';
+-string defaultPSViewer="gv";
++string defaultPSViewer="xdg-open";
+ #ifdef __APPLE__
+ string defaultPDFViewer="open";
+ #else
+-string defaultPDFViewer="acroread";
++string defaultPDFViewer="xdg-open";
+ #endif
+ string defaultGhostscript="gs";
+ string defaultGhostscriptLibrary="/usr/lib/libgs.so";
+-string defaultDisplay="display";
++string defaultDisplay="xdg-open";
+ string defaultAnimate="animate";
+ void queryRegistry() {}
+ const string dirsep="/";
diff --git a/media-gfx/asymptote/files/asymptote-2.32-configure-ac.patch b/media-gfx/asymptote/files/asymptote-2.32-configure-ac.patch
new file mode 100644
index 000000000000..597e915539be
--- /dev/null
+++ b/media-gfx/asymptote/files/asymptote-2.32-configure-ac.patch
@@ -0,0 +1,32 @@
+Index: asymptote-2.32/configure.ac
+===================================================================
+--- asymptote-2.32.orig/configure.ac
++++ asymptote-2.32/configure.ac
+@@ -158,7 +158,7 @@ if test "x$ac_cv_use_gc" != "xno" ; then
+ fi
+ CPPFLAGS_SAVE=$CPPFLAGS
+ CPPFLAGS=$CPPFLAGS" $INCL"
+- AC_CHECK_HEADER(gc.h,
++ AC_CHECK_HEADER([gc/gc.h],
+ AC_CHECK_LIB([gc],[GC_malloc],[
+ LIBS=$LIBS"-lgc "
+ AC_MSG_NOTICE([enabling system $GCNAME])],[
+@@ -232,7 +232,17 @@ AC_MSG_ERROR([*** Please install libm on
+ AC_CHECK_LIB([z], [deflate],,
+ AC_MSG_ERROR([*** Please install libz or zlib-devel on your system ***]))
+ AX_PTHREAD
+-AC_CHECK_LIB([sigsegv], [stackoverflow_install_handler])
++
++AC_ARG_WITH(sigsegv,
++ [ --with-sigsegv use libsigsegv],
++ [with_sigsegv=$withval],
++ [with_sigsegv="no"])
++if test "$with_sigsegv" = "yes"; then
++AC_CHECK_HEADER([sigsegv.h],
++ AC_CHECK_LIB([sigsegv], [stackoverflow_install_handler]),
++ AC_MSG_NOTICE([*** Header file sigsegv.h not found ***]))
++fi
++
+ AC_CHECK_LIB([rt], [sched_yield])
+
+ AC_ARG_ENABLE(readline,
diff --git a/media-gfx/asymptote/files/asymptote-2.32-ghostscript-9.15.patch b/media-gfx/asymptote/files/asymptote-2.32-ghostscript-9.15.patch
new file mode 100644
index 000000000000..aa826c5c251f
--- /dev/null
+++ b/media-gfx/asymptote/files/asymptote-2.32-ghostscript-9.15.patch
@@ -0,0 +1,24 @@
+diff -r -U2 asymptote-2.32.orig/runlabel.in asymptote-2.32/runlabel.in
+--- asymptote-2.32.orig/runlabel.in 2014-05-22 23:11:47.000000000 +0700
++++ asymptote-2.32/runlabel.in 2015-01-11 21:41:30.268889133 +0600
+@@ -112,5 +112,5 @@
+ const string null="/dev/null";
+ #endif
+- cmd.push_back("-sDEVICE=epswrite");
++ cmd.push_back("-sDEVICE=eps2write");
+ cmd.push_back("-sOutputFile="+null);
+ cmd.push_back(stripDir(psname));
+@@ -310,5 +310,5 @@
+ cmd.push_back("-dBATCH");
+ if(safe) cmd.push_back("-dSAFER");
+- cmd.push_back("-sDEVICE=epswrite");
++ cmd.push_back("-sDEVICE=eps2write");
+ cmd.push_back("-sOutputFile=-");
+ cmd.push_back(pdfname);
+@@ -399,5 +399,5 @@
+ cmd2.push_back("-P");
+ if(safe) cmd2.push_back("-dSAFER");
+- cmd2.push_back("-sDEVICE=epswrite");
++ cmd2.push_back("-sDEVICE=eps2write");
+ cmd2.push_back("-sOutputFile=-");
+ cmd2.push_back("-");
diff --git a/media-gfx/asymptote/files/asymptote-2.32-info.patch b/media-gfx/asymptote/files/asymptote-2.32-info.patch
new file mode 100644
index 000000000000..8a1e3f464231
--- /dev/null
+++ b/media-gfx/asymptote/files/asymptote-2.32-info.patch
@@ -0,0 +1,13 @@
+Index: asymptote-2.32/doc/asymptote.texi
+===================================================================
+--- asymptote-2.32.orig/doc/asymptote.texi
++++ asymptote-2.32/doc/asymptote.texi
+@@ -21,7 +21,7 @@ file LICENSE in the top-level source dir
+
+ @dircategory Languages
+ @direntry
+-* asymptote: (asymptote/asymptote). Vector graphics language.
++* asymptote: (asymptote). Vector graphics language.
+ @end direntry
+
+ @titlepage
diff --git a/media-gfx/asymptote/files/asymptote-2.32-xdg-utils.patch b/media-gfx/asymptote/files/asymptote-2.32-xdg-utils.patch
new file mode 100644
index 000000000000..2ac59e59f058
--- /dev/null
+++ b/media-gfx/asymptote/files/asymptote-2.32-xdg-utils.patch
@@ -0,0 +1,23 @@
+Index: asymptote-2.32/settings.cc
+===================================================================
+--- asymptote-2.32.orig/settings.cc
++++ asymptote-2.32/settings.cc
+@@ -90,15 +90,15 @@ bool msdos=false;
+ string HOME="HOME";
+ string docdir=ASYMPTOTE_DOCDIR;
+ const char pathSeparator=':';
+-string defaultPSViewer="gv";
++string defaultPSViewer="xdg-open";
+ #ifdef __APPLE__
+ string defaultPDFViewer="open";
+ #else
+-string defaultPDFViewer="acroread";
++string defaultPDFViewer="xdg-open";
+ #endif
+ string defaultGhostscript="gs";
+ string defaultGhostscriptLibrary="/usr/lib/libgs.so";
+-string defaultDisplay="display";
++string defaultDisplay="xdg-open";
+ string defaultAnimate="animate";
+ void queryRegistry() {}
+ const string dirsep="/";