summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Mair-Keimberger <mmk@levelnine.at>2024-06-29 12:16:55 +0200
committerConrad Kostecki <conikost@gentoo.org>2024-06-30 01:55:14 +0200
commit27ba6451168824db0e5344cd38cea02927970287 (patch)
tree95d9ebaae8e8c27094eac1bcf4fa12667ce69113 /media-gfx/jpeginfo
parentmedia-gfx/librecad: add 2.2.0.2 (diff)
downloadgentoo-27ba6451168824db0e5344cd38cea02927970287.tar.gz
gentoo-27ba6451168824db0e5344cd38cea02927970287.tar.bz2
gentoo-27ba6451168824db0e5344cd38cea02927970287.zip
media-gfx/jpeginfo: add 1.7.1
Signed-off-by: Michael Mair-Keimberger <mmk@levelnine.at> Closes: https://github.com/gentoo/gentoo/pull/37351 Signed-off-by: Conrad Kostecki <conikost@gentoo.org>
Diffstat (limited to 'media-gfx/jpeginfo')
-rw-r--r--media-gfx/jpeginfo/Manifest1
-rw-r--r--media-gfx/jpeginfo/jpeginfo-1.7.1.ebuild34
2 files changed, 35 insertions, 0 deletions
diff --git a/media-gfx/jpeginfo/Manifest b/media-gfx/jpeginfo/Manifest
index 5f4cc5abda64..d0cd10cf2b36 100644
--- a/media-gfx/jpeginfo/Manifest
+++ b/media-gfx/jpeginfo/Manifest
@@ -1 +1,2 @@
DIST jpeginfo-1.6.1.tar.gz 64856 BLAKE2B 5d9748a4af26087e45f2ae3fa709bb2099547f22aaeaf1fde529d92d633b1bc665dfde301a9ecaf4a8e4fa190ef637126d6f4ee43118bb31f5782a402d4a08d1 SHA512 9cc9367b8b3e38ba46bff9477b8f61e63b55bd41a67ea2895cca9c097abba2a7a3ae068c235ecfea72c99af52bba91cbb1eb92feb019ba4eb08e826a7083c68b
+DIST jpeginfo-1.7.1.tar.gz 448213 BLAKE2B 4fa8a875a14b85b6b04bb8cd436dd5b6f68867ad10324ca56da24d247c46b6051fa566ac5f13c469cf90ffcdbc3f16bf6296cdda3f3c794e0986468971b5f31b SHA512 16c670b4f7eb2355fa2e1a665225d45bc135021565b4a950f8193bd0dbc1f55eed7af4e37ca71ea7df325aeb0c13ee52b0cc71e71b06ed39b013cc3377eca63b
diff --git a/media-gfx/jpeginfo/jpeginfo-1.7.1.ebuild b/media-gfx/jpeginfo/jpeginfo-1.7.1.ebuild
new file mode 100644
index 000000000000..8ff1d8261abe
--- /dev/null
+++ b/media-gfx/jpeginfo/jpeginfo-1.7.1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools toolchain-funcs
+
+DESCRIPTION="Prints information and tests integrity of JPEG/JFIF files"
+HOMEPAGE="https://www.kokkonen.net/tjko/projects.html"
+SRC_URI="https://www.kokkonen.net/tjko/src/${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos"
+
+RDEPEND="media-libs/libjpeg-turbo:="
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+ default
+
+ # Clang 16
+ eautoreconf
+}
+
+src_configure() {
+ tc-export CC
+ econf
+}
+
+src_install() {
+ emake INSTALL_ROOT="${D}" install
+ dodoc README
+}