summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2021-05-09 20:38:38 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2021-05-09 21:12:11 +0200
commitf26b020e95bf497d99a8398226cf08288f93909b (patch)
treeadbbb3cddd74854a0da931841daefd3c472634f0 /media-gfx/librecad
parentdev-util/bcc-0.20.0: Version bump (diff)
downloadgentoo-f26b020e95bf497d99a8398226cf08288f93909b.tar.gz
gentoo-f26b020e95bf497d99a8398226cf08288f93909b.tar.bz2
gentoo-f26b020e95bf497d99a8398226cf08288f93909b.zip
media-gfx/librecad: Fix build with >=dev-libs/boost-1.76
Closes: https://bugs.gentoo.org/788706 Package-Manager: Portage-3.0.18, Repoman-3.0.3 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'media-gfx/librecad')
-rw-r--r--media-gfx/librecad/files/librecad-2.1.3-boost-1.76.patch29
-rw-r--r--media-gfx/librecad/librecad-2.1.3-r5.ebuild11
2 files changed, 35 insertions, 5 deletions
diff --git a/media-gfx/librecad/files/librecad-2.1.3-boost-1.76.patch b/media-gfx/librecad/files/librecad-2.1.3-boost-1.76.patch
new file mode 100644
index 000000000000..2500bab79b19
--- /dev/null
+++ b/media-gfx/librecad/files/librecad-2.1.3-boost-1.76.patch
@@ -0,0 +1,29 @@
+From 1fd07fcd847659d518efa0897a9f603de83fe362 Mon Sep 17 00:00:00 2001
+From: Jiri Slaby <jslaby@suse.cz>
+Date: Tue, 4 May 2021 09:25:03 +0200
+Subject: [PATCH] add boost tuple include to fix build
+
+With boost 1.76, we see:
+lib/engine/rs_ellipse.cpp:70:15: error: 'tuple' in namespace 'boost::math' does not name a template type
+ 70 | boost::math::tuple<double, double, double> operator()(double const& z) const {
+ | ^~~~~
+
+Fix this by including the proper boost header.
+---
+ librecad/src/lib/engine/rs_ellipse.cpp | 3 +++
+ 1 file changed, 3 insertions(+)
+
+diff --git a/librecad/src/lib/engine/rs_ellipse.cpp b/librecad/src/lib/engine/rs_ellipse.cpp
+index 291f734ea..d47bf6ca4 100644
+--- a/librecad/src/lib/engine/rs_ellipse.cpp
++++ b/librecad/src/lib/engine/rs_ellipse.cpp
+@@ -48,6 +48,9 @@
+ #include <boost/version.hpp>
+ #include <boost/math/tools/roots.hpp>
+ #include <boost/math/special_functions/ellint_2.hpp>
++#if BOOST_VERSION > 104500
++#include <boost/math/tools/tuple.hpp>
++#endif
+ #endif
+
+ namespace{
diff --git a/media-gfx/librecad/librecad-2.1.3-r5.ebuild b/media-gfx/librecad/librecad-2.1.3-r5.ebuild
index bc56b908be42..7b21b0e12ca4 100644
--- a/media-gfx/librecad/librecad-2.1.3-r5.ebuild
+++ b/media-gfx/librecad/librecad-2.1.3-r5.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -14,9 +14,6 @@ SLOT="0"
KEYWORDS="amd64 ~ppc64 x86 ~amd64-linux ~x86-linux"
IUSE="debug doc tools"
-BDEPEND="
- dev-qt/linguist-tools:5
-"
RDEPEND="
dev-cpp/muParser
dev-libs/boost:=
@@ -31,13 +28,17 @@ DEPEND="${RDEPEND}
dev-qt/qthelp:5
dev-qt/qtxml:5
"
+BDEPEND="
+ dev-qt/linguist-tools:5
+"
S="${WORKDIR}/LibreCAD-${PV}"
PATCHES=(
"${FILESDIR}/${P}-qt-5.11.patch"
"${FILESDIR}/${P}-gcc-9.patch"
- "${FILESDIR}/${P}-qt-5.15.patch" # pending upstream PR#1224
+ "${FILESDIR}/${P}-qt-5.15.patch"
+ "${FILESDIR}/${P}-boost-1.76.patch" # bug 788706, upstream PR#1345
)
src_configure() {