summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Vetter <jubalh@iodoru.org>2023-04-15 18:39:58 +0000
committerJimi Huotari <chiitoo@gentoo.org>2023-04-18 01:05:32 +0300
commit893856d5b98c53b311a84b0e14f64f9ef75cac0b (patch)
treec357628a85e4972ccdd5f4c7855d44e2c7efb53c /media-gfx
parentlxqt-base/liblxqt: add 1.3.0 (diff)
downloadgentoo-893856d5b98c53b311a84b0e14f64f9ef75cac0b.tar.gz
gentoo-893856d5b98c53b311a84b0e14f64f9ef75cac0b.tar.bz2
gentoo-893856d5b98c53b311a84b0e14f64f9ef75cac0b.zip
media-gfx/lximage-qt: add 1.3.0
Signed-off-by: Michael Vetter <jubalh@iodoru.org> Signed-off-by: Jimi Huotari <chiitoo@gentoo.org>
Diffstat (limited to 'media-gfx')
-rw-r--r--media-gfx/lximage-qt/Manifest1
-rw-r--r--media-gfx/lximage-qt/lximage-qt-1.3.0.ebuild54
2 files changed, 55 insertions, 0 deletions
diff --git a/media-gfx/lximage-qt/Manifest b/media-gfx/lximage-qt/Manifest
index fd2ac9af3eba..eb603c253ce3 100644
--- a/media-gfx/lximage-qt/Manifest
+++ b/media-gfx/lximage-qt/Manifest
@@ -1 +1,2 @@
DIST lximage-qt-1.2.0.tar.xz 837692 BLAKE2B a51ad797882d2725e488226954672df1d6a175237ba5d0f21930af135c92afb46648ba3965f5e65c026eceb324a1e109a08b8f9921dff27d3f6685d35e898da7 SHA512 aa7cbc9f9e2e0ea1ea0cda446887002e285a17b54adb0bd87def1fabc9ad9dd5d25c5c1db56785e67f4767c2da8d8db9b4e73a440c676f80d7094434357b86e1
+DIST lximage-qt-1.3.0.tar.xz 838632 BLAKE2B eceee2fcdd6eae2360c8c7d27417d4e165520155050dae6c0fadfa22184634372582ac52c6233924b54b9d94e814967eb0abdd8ee3e7c719cdfde85840b51400 SHA512 c3fc8e24f78a9cd65736ba1af07b7fd5ba241eab233a595f7b05982d64a0a7a88d81c60eafea632779faa44f76cdb3bb501d2dc3b3758e3f6256fe2da10c37ac
diff --git a/media-gfx/lximage-qt/lximage-qt-1.3.0.ebuild b/media-gfx/lximage-qt/lximage-qt-1.3.0.ebuild
new file mode 100644
index 000000000000..28536ab0b803
--- /dev/null
+++ b/media-gfx/lximage-qt/lximage-qt-1.3.0.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+MY_PV="$(ver_cut 1-2)"
+
+inherit cmake xdg-utils
+
+DESCRIPTION="Qt Image Viewer"
+HOMEPAGE="https://lxqt-project.org/"
+
+if [[ ${PV} = *9999* ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/lxqt/${PN}.git"
+else
+ SRC_URI="https://github.com/lxqt/${PN}/releases/download/${PV}/${P}.tar.xz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~loong ~ppc64 ~riscv ~x86"
+fi
+
+LICENSE="GPL-2 GPL-2+"
+SLOT="0"
+
+BDEPEND="
+ >=dev-qt/linguist-tools-5.15:5
+ >=dev-util/lxqt-build-tools-0.13.0
+ virtual/pkgconfig
+"
+DEPEND="
+ dev-libs/glib:2
+ >=dev-qt/qtcore-5.15:5
+ >=dev-qt/qtdbus-5.15:5
+ >=dev-qt/qtgui-5.15:5
+ >=dev-qt/qtnetwork-5.15:5
+ >=dev-qt/qtprintsupport-5.15:5
+ >=dev-qt/qtsvg-5.15:5
+ >=dev-qt/qtwidgets-5.15:5
+ >=dev-qt/qtx11extras-5.15:5
+ media-libs/libexif
+ =x11-libs/libfm-qt-${MY_PV}*:=
+ x11-libs/libX11
+ x11-libs/libXfixes
+"
+RDEPEND="${DEPEND}"
+
+pkg_postinst() {
+ xdg_desktop_database_update
+ xdg_icon_cache_update
+}
+
+pkg_postrm() {
+ xdg_desktop_database_update
+ xdg_icon_cache_update
+}