summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEli Schwartz <eschwartz93@gmail.com>2023-11-13 16:52:47 -0500
committerMichał Górny <mgorny@gentoo.org>2023-12-05 05:20:33 +0100
commite94bf085fb28b26a70973bd72e1d66cdbda67062 (patch)
tree1c475b75f08236dff8b7be5e0a071fe292a8f6f0 /media-gfx
parentdev-python/matplotlib: drop optional certifi dependency (diff)
downloadgentoo-e94bf085fb28b26a70973bd72e1d66cdbda67062.tar.gz
gentoo-e94bf085fb28b26a70973bd72e1d66cdbda67062.tar.bz2
gentoo-e94bf085fb28b26a70973bd72e1d66cdbda67062.zip
media-gfx/displaycal-py3: remove incorrect upstream certifi dependency
Upstream's setup.cfg has several oddities to it, including claiming an RDEPEND on dev-python/build from when they copied their requirements.txt verbatim into setup.cfg. As for certifi specifically, it is handled in a fiddly try/except that falls back to using a bundled copy that is copied over from certifi into displaycal iff building a py2app/py2exe edition, and if that still doesn't work, silently does nothing. The object of all this is that if a custom cacert.pem is found somewhere, it goes and sets os.environ['SSL_CERT_FILE'] to affect later uses of urllib.request. Reasonably enough, none of this is needed except on Windows and macOS, so displaycal does precisely that: runs this entire thing only on Windows and macOS. On Linux, it never even attempts to import certifi, nor set an environment variable. So we shouldn't depend on it either. Signed-off-by: Eli Schwartz <eschwartz93@gmail.com> Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'media-gfx')
-rw-r--r--media-gfx/displaycal-py3/displaycal-py3-3.9.10-r3.ebuild (renamed from media-gfx/displaycal-py3/displaycal-py3-3.9.10-r2.ebuild)4
1 files changed, 3 insertions, 1 deletions
diff --git a/media-gfx/displaycal-py3/displaycal-py3-3.9.10-r2.ebuild b/media-gfx/displaycal-py3/displaycal-py3-3.9.10-r3.ebuild
index d6ac7689141f..6cf08031c321 100644
--- a/media-gfx/displaycal-py3/displaycal-py3-3.9.10-r2.ebuild
+++ b/media-gfx/displaycal-py3/displaycal-py3-3.9.10-r3.ebuild
@@ -28,7 +28,6 @@ PATCHES="${FILESDIR}/${P}-python-3.11.patch"
DEPEND="
dev-python/build[${PYTHON_USEDEP}]
- dev-python/certifi:0[${PYTHON_USEDEP}]
dev-python/dbus-python[${PYTHON_USEDEP}]
dev-python/distro[${PYTHON_USEDEP}]
dev-python/numpy[${PYTHON_USEDEP}]
@@ -46,6 +45,9 @@ src_prepare() {
# Fix QA warning
sed -e 's/license_file/license_files/g' -i setup.cfg || die
+ # remove dependency only imported if `sys.platform in ("darwin", "win32")`
+ sed -e '/certifi/d' -i setup.cfg || die
+
# Remove x-world MIME
sed -i 's|x-world/x-vrml;||g' \
misc/displaycal-vrml-to-x3d-converter.desktop || die