summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-02-24 14:35:43 +0000
committerSam James <sam@gentoo.org>2021-02-24 16:21:40 +0000
commit225c9479190eb11ea39f17e277dcefb7953856d9 (patch)
tree4c37e1541fa189f8b3f9a99aad773b056514dbd6 /media-libs/glfw
parentsci-electronics/fritzing: Fix typo in quazip sed (diff)
downloadgentoo-225c9479190eb11ea39f17e277dcefb7953856d9.tar.gz
gentoo-225c9479190eb11ea39f17e277dcefb7953856d9.tar.bz2
gentoo-225c9479190eb11ea39f17e277dcefb7953856d9.zip
media-libs/glfw: bump to 3.3.3
Package-Manager: Portage-3.0.14, Repoman-3.0.2 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'media-libs/glfw')
-rw-r--r--media-libs/glfw/Manifest1
-rw-r--r--media-libs/glfw/glfw-3.3.3.ebuild48
2 files changed, 49 insertions, 0 deletions
diff --git a/media-libs/glfw/Manifest b/media-libs/glfw/Manifest
index 5f8953cf8f8d..ae4c36d1a7d5 100644
--- a/media-libs/glfw/Manifest
+++ b/media-libs/glfw/Manifest
@@ -1 +1,2 @@
DIST glfw-3.3.2.tar.gz 759972 BLAKE2B a246681d580dd569a045b76db71c18f8dbfacb8483c2d825aa68094d655468d093c52ba3770b2b5d566de62149a775001f5acd7c7539a8235c43e3e9ab58df28 SHA512 f5af749d33b5b900ccf07988ad0bf51bd766a18e4cf2bc2a76020c88e98a2528ff1b965224184fe0d290cfe34b1af1e6f633600660d81194fe354078e2f35c56
+DIST glfw-3.3.3.tar.gz 763713 BLAKE2B bd6202877a3462d717a6d77b6381de704da854df011f7ab5172e626dc46df90793190284241b470a4b78e020302e5dca4051476e092e73e34731f6245a43ea14 SHA512 6d743d89d159bff6c4f7fa3fc5bc407fd728bdc432d76acc4897fd392580be272f8a9d1d7c375c4323e82bf2fd28310e5daab097fef33e8f43b69ce104f9bd31
diff --git a/media-libs/glfw/glfw-3.3.3.ebuild b/media-libs/glfw/glfw-3.3.3.ebuild
new file mode 100644
index 000000000000..ea8df33cd67c
--- /dev/null
+++ b/media-libs/glfw/glfw-3.3.3.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake
+
+DESCRIPTION="The Portable OpenGL FrameWork"
+HOMEPAGE="https://www.glfw.org/"
+SRC_URI="https://github.com/glfw/glfw/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="ZLIB"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc64 ~x86"
+IUSE="wayland"
+
+RDEPEND="
+ x11-libs/libxkbcommon
+ !wayland? (
+ virtual/opengl
+ x11-libs/libX11
+ x11-libs/libXcursor
+ x11-libs/libXinerama
+ x11-libs/libXrandr
+ x11-libs/libXxf86vm
+ )
+ wayland? (
+ dev-libs/wayland
+ media-libs/mesa[egl,wayland]
+ )
+"
+DEPEND="
+ ${RDEPEND}
+ !wayland? ( x11-libs/libXi )
+ wayland? ( dev-libs/wayland-protocols )
+"
+BDEPEND="
+ wayland? ( kde-frameworks/extra-cmake-modules )
+"
+
+src_configure() {
+ local mycmakeargs=(
+ -DGLFW_BUILD_EXAMPLES=no
+ -DGLFW_USE_WAYLAND="$(usex wayland)"
+ -DBUILD_SHARED_LIBS=1
+ )
+ cmake_src_configure
+}