summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlessandro Barbieri <lssndrbarbieri@gmail.com>2021-07-03 08:39:38 +0200
committerLars Wendler <polynomial-c@gentoo.org>2021-07-09 10:39:25 +0200
commit8f3da124ff78ea8c12ddff052fd6b541d193ab04 (patch)
tree441b2431d45e2e4b4d592f07d9ba69d7539b68a9 /media-libs/harfbuzz
parentprofiles/base/use.mask: mask ruby_targets_ruby25 for removal (diff)
downloadgentoo-8f3da124ff78ea8c12ddff052fd6b541d193ab04.tar.gz
gentoo-8f3da124ff78ea8c12ddff052fd6b541d193ab04.tar.bz2
gentoo-8f3da124ff78ea8c12ddff052fd6b541d193ab04.zip
media-libs/harfbuzz: add experimental useflag
EAPI 8 bump python implementations Bug: https://bugs.gentoo.org/800109 Package-Manager: Portage-3.0.20, Repoman-3.0.3 Signed-off-by: Alessandro Barbieri <lssndrbarbieri@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/21510 Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
Diffstat (limited to 'media-libs/harfbuzz')
-rw-r--r--media-libs/harfbuzz/harfbuzz-9999.ebuild18
-rw-r--r--media-libs/harfbuzz/metadata.xml5
2 files changed, 14 insertions, 9 deletions
diff --git a/media-libs/harfbuzz/harfbuzz-9999.ebuild b/media-libs/harfbuzz/harfbuzz-9999.ebuild
index 9f52c19d3421..e77ca3c2cf7a 100644
--- a/media-libs/harfbuzz/harfbuzz-9999.ebuild
+++ b/media-libs/harfbuzz/harfbuzz-9999.ebuild
@@ -1,9 +1,9 @@
# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
-PYTHON_COMPAT=( python3_{7..9} )
+PYTHON_COMPAT=( python3_{8..10} )
inherit flag-o-matic meson-multilib python-any-r1 xdg-utils
@@ -21,7 +21,7 @@ fi
LICENSE="Old-MIT ISC icu"
SLOT="0/0.9.18" # 0.9.18 introduced the harfbuzz-icu split; bug #472416
-IUSE="+cairo debug doc +glib +graphite icu +introspection static-libs test +truetype"
+IUSE="+cairo debug doc experimental +glib +graphite icu +introspection static-libs test +truetype"
RESTRICT="!test? ( test )"
REQUIRED_USE="introspection? ( glib )"
@@ -76,18 +76,22 @@ src_prepare() {
multilib_src_configure() {
# harfbuzz-gobject only used for instrospection, bug #535852
local emesonargs=(
- $(meson_native_use_feature cairo)
-Dcoretext="disabled"
- $(meson_native_use_feature doc)
-Dfontconfig="disabled" #609300
- $(meson_native_use_feature introspection)
- $(meson_use static-libs static)
+
$(meson_feature glib)
$(meson_feature graphite)
$(meson_feature icu)
$(meson_feature introspection gobject)
$(meson_feature test tests)
$(meson_feature truetype freetype)
+
+ $(meson_native_use_feature cairo)
+ $(meson_native_use_feature doc)
+ $(meson_native_use_feature introspection)
+
+ $(meson_use experimental experimental_api)
+ $(meson_use static-libs static)
)
meson_src_configure
}
diff --git a/media-libs/harfbuzz/metadata.xml b/media-libs/harfbuzz/metadata.xml
index 1c768f83411d..6d22e7368956 100644
--- a/media-libs/harfbuzz/metadata.xml
+++ b/media-libs/harfbuzz/metadata.xml
@@ -17,7 +17,8 @@
<remote-id type="cpe">cpe:/a:harfbuzz_project:harfbuzz</remote-id>
</upstream>
<use>
- <flag name="glib">Compile with GLib Unicode support</flag>
- <flag name="graphite">Use graphite to render complex non-Roman writing systems</flag>
+ <flag name="experimental">Enable experimental APIs</flag>
+ <flag name="glib">Enable <pkg>dev-libs/glib</pkg> unicode functions</flag>
+ <flag name="graphite">Enable <pkg>media-gfx/graphite2</pkg> complementary shaper</flag>
</use>
</pkgmetadata>