summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMiroslav Šulc <fordfrog@gentoo.org>2021-09-23 08:52:40 +0200
committerMiroslav Šulc <fordfrog@gentoo.org>2021-09-23 08:53:13 +0200
commit3a8dcd8218960acb200b8990b074bc08180961d7 (patch)
treef9ba78125d0b7fbf380c85c5602983a434424ed4 /media-libs/libsoundtouch/libsoundtouch-2.3.1.ebuild
parentwww-apps/chromedriver-bin: bump to 94.0.4606.41 (diff)
downloadgentoo-3a8dcd8218960acb200b8990b074bc08180961d7.tar.gz
gentoo-3a8dcd8218960acb200b8990b074bc08180961d7.tar.bz2
gentoo-3a8dcd8218960acb200b8990b074bc08180961d7.zip
media-libs/libsoundtouch: bump to 2.3.1
Package-Manager: Portage-3.0.23, Repoman-3.0.3 Signed-off-by: Miroslav Šulc <fordfrog@gentoo.org>
Diffstat (limited to 'media-libs/libsoundtouch/libsoundtouch-2.3.1.ebuild')
-rw-r--r--media-libs/libsoundtouch/libsoundtouch-2.3.1.ebuild55
1 files changed, 55 insertions, 0 deletions
diff --git a/media-libs/libsoundtouch/libsoundtouch-2.3.1.ebuild b/media-libs/libsoundtouch/libsoundtouch-2.3.1.ebuild
new file mode 100644
index 000000000000..f9bd26503556
--- /dev/null
+++ b/media-libs/libsoundtouch/libsoundtouch-2.3.1.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools multilib-minimal toolchain-funcs
+
+MY_PN=${PN/lib}
+MY_P=${MY_PN}-${PV}
+DESCRIPTION="Audio processing library for changing tempo, pitch and playback rates"
+HOMEPAGE="https://www.surina.net/soundtouch/ https://gitlab.com/soundtouch/soundtouch"
+SRC_URI="https://gitlab.com/${MY_PN}/${MY_PN}/-/archive/${PV}/${MY_P}.tar.bz2"
+
+LICENSE="LGPL-2.1"
+# subslot = libSoundTouch.so soname
+SLOT="0/1"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~mips ~ppc ~ppc64 ~riscv ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-solaris"
+IUSE="cpu_flags_x86_sse openmp static-libs"
+
+BDEPEND="virtual/pkgconfig"
+
+S="${WORKDIR}/${MY_P}"
+
+src_prepare() {
+ default
+ if use openmp ; then
+ tc-has-openmp || die "Please switch to an openmp compatible compiler"
+ fi
+ sed -i "s:^\(dist_doc_DATA=\)COPYING.TXT :\1:" Makefile.am || die
+ sed -i 's:AM_CONFIG_HEADER:AC_CONFIG_HEADERS:g' configure.ac || die
+ eautoreconf
+}
+
+multilib_src_configure() {
+ local myeconfargs=(
+ --enable-shared
+ --disable-integer-samples
+ $(use_enable cpu_flags_x86_sse x86-optimizations)
+ $(use_enable openmp)
+ $(use_enable static-libs static)
+ )
+ ECONF_SOURCE="${S}" econf "${myeconfargs[@]}"
+}
+
+multilib_src_compile() {
+ emake CFLAGS="${CFLAGS}" CXXFLAGS="${CXXFLAGS}"
+}
+
+multilib_src_install() {
+ emake DESTDIR="${D}" pkgdocdir="${EPREFIX}"/usr/share/doc/${PF}/html install
+}
+
+multilib_src_install_all() {
+ find "${ED}" -name '*.la' -delete || die
+}